[OBSOLETE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

The Iris Smart Plug is a rebranded Centralite on/off plug which looks remarkably similar to the SmartThings SmartPower Outlet. In fact, this is a new version of the same hardware which adds a very interesting feature; A Z-Wave Plus repeater within the Zigbee HA 1.2 Plug.

Because this device has two different wireless protocols within it, it will effectively be treated as two separate devices within SmartThings. The following is how you will need to pair each device and get it working within your system:

First: The Zigbee Outlet

In order to pair the Zigbee Outlet, first add the devicetype at the bottom of this post to your IDE. Once you have the devicetype added and published, open the SmartThings app and hit ‘Connect New Device’ within the Marketplace. After SmartThings starts searching for a new device, plug the Iris Smart Plug into the wall, and wait for it to be discovered by the hub. It should pair as an ‘Iris Smart Plug’. If you are having trouble getting it to pair follow the ‘Zigbee Reset Instructions’ below.

Optional Step: If you want to have this plug run locally, go into your IDE and switch the devicetype for the plug to the ‘SmartPower Outlet’ devicetype.

Second: The Z-Wave repeater

Once you have the Zigbee Plug added into SmartThings you can go back to add the Z-wave repeater. In order to do this, first start the pairing mode by selecting ‘Connect New Device’ within the Marketplace in the SmartThings app. Once the hub is searching for a new device, hold down the button on the front of the Iris Smart Plug until the light begins to blink, this should only take a few seconds. Some users have reported than holding down the button doesn’t work and instead they needed to tap the button 8 times rapidly in order to get it into pairing mode. Once the light is blinking SmartThings should discover the repeater as a ‘Z-Wave Device’. This is the proper devicetype for the repeater. It will show On/Off and Dimming functionality within the device in the SmartThings app but you can ignore this, it doesn’t actually do anything and is something extra within the default devicetype.

At this point you should have two different devices added to your home, one Zigbee switch (which also acts as a Zigbee repeater) and one Z-Wave repeater.

ZIGBEE RESET INSTRUCTIONS: If the Zigbee portion will not pair you may need to reset the plug. In order to do this, unplug the Iris Smart Plug, hold down the button and plug it back in while continuing to hold the button. When the light first comes on, release the button and you should now be in pairing mode. Open the ‘Connect New Device’ screen and it should instantly find the Iris Smart Plug.


Damn, didn’t know this was a thing. Not sure it’s worth replacing devices for, but this would’ve been very helpful had it been out two months ago when I was purchasing plugs.

It would really only be worth replacing plugs with this if you were having zigbee and z-wave mesh issues. Though, compared to the ST plugs, these are pretty reasonably priced.

Apparently Lowes doesn’t think my immediate area doesn’t needs any Iris Smart Plug Home Automation devices…

It looks like they aren’t selling it in stores yet. I personally got mine through the Comfort and Control kit: http://www.lowes.com/pd_753204-41277-9404-L_1z0v12a__?productId=999929892&pl=1

1 Like

Anyone know how to reset the 3210-L plug? I’ve tried the instructions from the Lowes site (unplug, hold the button for 15 seconds, plug back in & press the button 8X in a row at 1 second intervals), but it seems to be for the previous generation because after 5-8 times of trying that method, I’ve not yet been able to reset it. I also unplugged it and let it sit all night, but I still can’t get it back to pairing mode. Holding the button down while it’s plugged in also doesn’t seem to do anything.



Did you try the general Device Exclusion under Z-Wave Utilities?

This is great info thanks! Mine is tucked behind the Xmas tree so it will be a while until I can get to it.

Did you have it paired to the system initially? If so, how did you remove it from your system?

This will only work for removing the Z-Wave repeater, not the plug itself, which is Zigbee.


This paired right up with no problem at all using your device type with the Iris fingerprint, thanks! I did change it to the ‘SmartPower Outlet’ devicetype in the IDE so it stays as a local device.

1 Like

Perfect! Glad to hear, thanks for the feedback.

Wow. Bonus feature not expected.

So when all this is done and the SmartPower Outlet device type is used, does the power monitoring features improve? Does it go from reporting power level only when turned on/off to reporting when changes >1W also? And every 10 minutes? The ST Outlet does that with this device type.

It should work exactly like the SmartPower Outlet, I haven’t actually used the outlet other than setting it up so I’m not sure how the power reporting works.

1 Like

Wow. @blebson, I got the more advanced SmartPower Outlet functionality working now following your instructions. I wanted it with energy reporting on energy changes. Apparently when I added the device the first time, adding it under device type SmartPower Outlet, I got it stuck doing dumb energy reporting (only upon on/off event), even if I switched to device type Iris Smart Button and back.

I reset my Iris Smart Plug and followed the directions on the 1st post on this topic. Worked great at getting the great energy reporting functionality. I did set the device handler to SmartPower Outlet at the end of instruction #1.

However I couldn’t get the Z-Wave Repeater to connect in instruction #2. Definitely the plug would not go into pairing mode and make the light blink. I held it up to 10 seconds with no success. I tried other ways to get it to blink but no success. @blebson, do you have any other detail on how to do this?

@Paulrus, I sympathize with you. I struggled with resetting this. I swear it doesn’t work a normal way. I finally got it to reset by holding the button down while its plugged, but releasing the button about 1-2 seconds later immediately after the light just starts to blink. It then goes into blinking state, ready to pair. Can’t hold it until it blinks. Have to release after the first blink. Strange. Try that out. BTW, I think the Z-Wave Exclusion instructions are irrelevant unless you got the Z-Wave repeater paired and need to remove it to start over.

@Paulrus, also if you have already set this up as a plug and need to clear it out, remove the device in the app first (frees up the hub to pair to this plug again) before starting the pairing mode on the plug. Also I noticed my hub light was not blinking green when trying to connect (pair). I had to reset it.

If you had previously had the z-wave repeater added to smartthings then you’ll have to run a z-wave exclude before pairing it back to the hub. Once it’s in pairing mode (light blinking) it should automatically find it.

@blebson I know this thread is specifically about the 3210-L, but do you know if any of the other IRIS V2 devices work and or if they need custom device types? Where did you find this device type, I note that Smartthings themselves authored it.

Hey Kraig,

@mitchp has created devicetypes for pretty much all of the other Iris v2 devices. I created this devicetype by modifying the standard Smart Things SmartPower Outlet devicetype to include the 3210-L fingerprint (allowing it to automatically assign itself during discovery). See below for a list of other threads with devicetypes:

1 Like

I just got my plug in the mail today. The zigbee part worked like a champ. As for the zwave… I can (occasionally) get the plug into a pairing mode (more on that below), but my hub can’t find it. If I go into exclusion mode and poke the little button off/on repeatedly, it will eventually tell me it excluded an unknown device. But nothing shows up when looking to add a device. I tried for about half an hour and eventually ran out of time & had to give up for now.

To get it into pairing is a bit fidgety. I pull the plug from the wall, hold down the button for a few seconds, plug it into the wall (while holding the button), and start rapidly poking the button (faster than the once-per-second instructions you can online find for the old version of the plug) until it does the flash-flash, pause, flash-flash bit.


Try getting it into pairing mode by simply holding the button until the light starts to blink. That’s the way I got it to pair and it was almost instant.

I held the button multiple times for over 30 seconds… all it does on mine is toggle the state on/off.