[OBSOLETE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

Did you hold the button after you excuded it? For me the light starting blinking at a constant rate after entering pairing mode for the z-wave portion (which didn’t exist in the old version, so that pairing instruction should have no bearing on it).

@blebson, I finally got the repeater to pair. I needed to Z-wave exclude it first. I believe I needed to get the device real close to the hub and wasn’t doing that. Thanks!

1 Like

@benjaminellison, I don’t recall clearly what the key was for me to pair the z-wave. My brain is mush from struggling with this stuff. I think I needed to get the hub within an inch of the device and just press the button repeatedly a bunch of times. It didn’t need to be in pairing mode. Try that.

I can confirm, perform a general device exclusion first, then unplug/replug the smart outlet. quickly press the button 4 or 5 times. It will start blinking in pairing mode. if it doesn’t do it immediately, just keep quickly pressing in groups of pushes, it will eventually get in pairing mode.

and actually for the zigbee join, I used the SmartThings instructions to hold the button while plugging in and wait for the light blink once, and then let go,


Great code. Worked like a charm and it is $20 less than the equivalent Smartthings device!

$20 less AND has the z-wave repeater, hard to beat! :slight_smile:

1 Like

I am using this device type with two Iris 3210-L smartplugs.
The plugs work fine, they report power use, but only when I refresh them.

I can’t get them to automatically report power use for notification purposes.


Finally got this device for $35 at our local Lowes and it was very difficult to pair. Tooks several attempts with several exclusions. I followed the instructions and added the custom device app provided at the top of this post.

Two devices are added, the Z-Wave Outlet first, and then after another pairing the Outlet appears and function perfectly as a controllable power outlet with wattage display.

According to the Lowe’s Iris Device Support page for this model, it will handle up to 1,400 watts. I currently have it connected to my supplemental kitchen electric baseboard heater and it was pulling 1,250 watts.

I have the ST power monitor app installed which insures that if it exceeds 1,300 watts, it will turn off. I also installed the SmartAPP that turns it off after X minutes. Hopefully the ST cloud will function to perform these functions should we forget and leave the heater on for longer than X minutes.

@blebson: One question: When I check devices that run locally, it does not show this device in the list (actually I do not any devices in the list) and I changed the device type to “Smart Power Outlet” as you suggested and rebooted the V2 hub. I am guessing that I have one of the following issues:
For a little more clarity there are 3 things needed to run an app locally.

  1. The app is able to run locally
  2. The device itself is able to run locally
  3. The official device has been added to local execution in appEngine

If one of those three things is missing it will run in the cloud.

I don’t really know how to fix this using the custom devicetype but I’ll look into it. This is currently how mine works. You could always use Pollster to refresh the device at a specific interval.

When I changed my devicetype to the SmartPower Outlet it made it so the device was handled locally and shows on the appropriate list. I’m using it with a SmartLighting automation which also properly shows as a locally running SmartApp. Not sure what is preventing yours from running locally (I’m already assuming you’re using the v2 hub.)

Where is this list of devices that run locally? How do you check that? Is it in the app or on the website?

Edit: I found this post with a link to the locally executing smart apps: Local Processing in Hub V2, is that the place where you check?

These links will show you what devices and SmartApps are running locally (at least for the US v2 Hub).

1 Like

[quote=“kicko, post:30, topic:31028, full:true”]
Where is this list of devices that run locally? How do you check that? Is it in the app or on the website? [/quote]

Only in the IDE. The link to display the local devices your V2 knows about is below: https://graph.api.smartthings.com/localInstalledSmartApp/list


Check out my growing list of devices but I do not have any supported SmartApps controlling them, so they still process in the flaky cloud:

Again, there are several conditions to be met that can exclude a supported device from being on this…

  1. Approved ST Device (very few devices make this hurdle)
  2. Approved SmartApp to run the local App
  3. A Full Moon (just joking, but I’m sure this will be added by ST at some future date)

I have been fighting with this for a couple hours now. I seem to be having the opposite issue everyone else is having.

I cannot get the Zigbee Plug part to pair. I am able to pair the Z-wave device.

I have tried resetting the plug, I have tried Z-wave exclude also.

I cannot get Iris Smart Plug to show up at all no matter what I have tried.

I picked this up today from Lowes. It is in the new purple box. Model# 3210-L. It says ZIGBEE HA 1.2 Compatible Device on the side of the box.

Am I missing something here? Please advise. Any and all help is appreciated. Thanks.

Was there a generic “thing” added that hasn’t been assigned a device type? Sometimes the app won’t associate the device type properly.

If not, how are you resetting the plug? I believe the proper way is to hold the button down while plugging in the module and only releasing the button when the light blinks, or something similar.

So I decided to go back and give it the old college try again.

It wasn’t working all all. No generic “thing” was showing up either.

I performed the reset on the Iris outlet 2 or 3 more times. Then I got really frustrated and started banging the on/off switch on the outlet.

Not expecting anything at all to happen and first the Z-wave showed up again and I said to myself well go figure.

Then like a miracle all of a sudden “Outlet” popped up. Smartthings app was now showing 2 things.

I quickly selected “Outlet” configured it then it had me configure Z-Wave next.

So now it was showing up. Strangely it would let me at first turn the outlet on. Then when I tried to turn it off it just sat there with the Turning icon. This of course locked up Smartthings app and possibly the hub because I couldn’t control the Original Smartthings outlet at all.

I rebooted the Hub, cleared the cache from the app and forced stopped it. At this point I had already changed the type to SmartPower Outlet.

It let me turn it off then on again. The third try it did that lockup turning icon again. This time I did not reboot the hub but I closed the app.

When I went back into the app and then to the Things section it gave me an error in the app in a red warning display box.

So I went back out and cleared the app cache and forced stop.

This time when I went back in to the app the Outlet appears to toggle just fine. So far it’s working. For how long I don’t know.

I will have to monitor it and report back what happens next.

I am curious the Z-Wave Device shows up in the Things list. I believe I read it has no actual function. Does it have to be paired for the Repeater to function? If so is there a way to hide it in the list? Or at least take away the On/Off toggle option?


That’s very odd. Maybe you’re just getting unlucky with some server-side issues that SmartThings has been having.

As far as the repeater, it needs to be paired as a z-wave device in order to work (and work locally), and I don’t know of any way to hide it. The only way to get rid of the on/off button would be to create a custom devicetype for it but then you wouldn’t have the ability for it to run locally (though I’m not sure if that matters for a repeater or not).

This! So after struggling as well to get the Z-Wave portion working, I put 2 and 3 together and got 4!

Couldn’t get it to reset, at least pretty sure I couldn’t so I removed the ZigBee portion from ST and tried the reset procedure again, failed, I think.

Started discovery and it saw the ZigBee portion, set that up fine. Couldn’t get Z-Wave. Figured old+new=work, so after letting it rest a few seconds with the relay off, I just quickly tapped the button 8 times, and it started flashing! The relay did not turn on/off while doing this, gotta be quick!

Now hopefully my power monitoring is more than just when turned on/off, the only real reason I tried to get this working…

That’s very odd, I’ll go ahead and add the 8 quick pushes to the z-wave pairing tutorial. As far as the energy monitoring, for me I have to refresh the plug to get an updated reading. You could easily write a simple smartapp to refresh the plug at a certain interval while it’s on.

It is still working. I tried it again this morning. Perhaps it will be stable after all.

This may be a dumb question but how do you view power usage on these outlets. I read people mentioning it here. I looked in the Marketplace in the Energy Management section and see things like Energy Alerts, Energy Saver and Wattvision. The others seem to relate to the Thermostat and Windows. Wattvision seems to be for their whole house monitor.

Thanks for making these outlets work with Smartthings.

I can view my wattage usage on the bottom of the Tile or in the “Recently” tab of the device. The device also reports each measurement in the “Live Logging” screen of the IDE.

1 Like