Zigbee repeater needed after moving my hub

Phillips hue bulbs use the ZLL profile when they are attached to the HUE bridge. But if you attach them directly to smart Things, they will switch to the ZHA profile. A number of community members use them as zigbee repeaters. There’s just the usual caveat that you cannot reset them unless you buy an additional device like the Lutron remote. You also have to use a different device handler then the official default, because that one assumes they are attached to the bridge. But the zigbee dimmer device handler should work.

1 Like

I knew you could connect them directly to the hub, but didn’t know they switched protocol once you did.
That is great information from you, as always!

1 Like

They have to, because the hub does not support ZLL profile. Or more accurately, if they cannot change to the ZHA profile, they cannot be connected directly to the SmartThings hub. :sunglasses:

It seems @Luke_Perrie had the exact same issue I am having and these bulbs didn’t help. So not sure that is a good option. Guess I have to splurge for the plug. I was hoping there were some newer devices. Why is it that only Smart Things has zigbee devices. Shouldn’t there be some third party zigbee stuff ?

What about this device ?

Does it work with Smart Things ? It’s not listed in products that work with ST so maybe not.

Also the smarten IT relays which are on the official compatibility list will act as zigbee repeaters if you have a place to use those.

But there are lots of community member successful using zigbee bulbs as repeaters. I’m not sure what Luke’s issues were, “all home automation is local.”

And The Iris Smart Plug is a Zigbee pocket socket that also has a Zwave repeater in it. Which is weird, but it works and there is already a community created device type for it:

It’s about $35 at regular price.

Remember that no matter what device you use as a repeater, you have to do a network heal after you add the repeater or the sensor won’t know that it’s there and won’t use it.

1 Like

I have been using 2 of the iris smart plugs as zigbee repeaters and they have worked great so far. Not sure if they repeat the z-wave or not but my z-wave mesh was fine in those areas already.

1 Like

Thanks I may try one of them. I wonder why the bulbs didn’t work for @Luke_Perrie because looking at my situation I have a light hanging exactly 1/2 way between hub and garage it would be perfect !

The Lowes Iris 2nd Gen Outlet is basically the Same as the Smartthings outlet. Except it has the capability to extend your Zwave mesh as well and it’s still on sale at the 10001 zip code for $27.98.

Change your store to the 10001 zip code, Select parcel shipping and add coupon code.

if you order mutliples you can use the $10 off $50 purchase coupon or 10% off all online orders from http://renovopower.com/lowes.html

It’s literally twice the product for half the price. The same manufacturer (centralite) makes it, and you can still run the plug on the stock device handler after you get the zwave set up so that it can run locally.

Hey guys! Just chiming in here. @JDRoberts was helping me on the other thread. I guess I have to do the network heal that JD is recommending before I can let you know @Ron if it fixes it and allows it to be used as a zigbee repeater. I had no idea you had to do the network heal. The bulb im using is this one: http://www.amazon.com/gp/product/B014H2OZ1Q?psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00. It’s in my garage and sits right above the car that my Arrival sensor is in. The other day I had an episode where it left and arrived repeatedly (mistakenly) over about an hour’s time. I had to remove all the Smart Apps associated with it so it would stop opening and closing my garage door repeatedly. This was all WITH the bulb installed and connected to ST.

I’ll try the network heal and let you guys know if it works because it’s still the cheapest option, with the Iris outlet being $35 or so. If not, I guess IRIS outlet it is to see if that works.

@JDRoberts should I leave the Hue bulb plugged in while I unplug the ST hub and do the heal? Or should I unscrew the bulb first, then unplug the ST Hub, then let the Hub come back online, and then screw the bulb back in?

$25.18 + tax/shipping if you buy one from the 10001 zip

I bought 2 for 53.13 after tax and shipping the other day -

Leave the bulb on power while you take the hub off power.

We should also note that even if the bulb is acting as a repeater, you might still have the problems with the arrival sensor doing the home/away/home/away pattern due to Wi-Fi interference. I have this particular problem at my own house. But that’s a topic for an entirely different thread.

Back to this thread: anytime you physically move a device to a new position or add a new device to the network you need to rebuild the neighbor tables for each device or they won’t know who their true neighbors are (and won’t use the new repeater even if it’s right next to them).

For zigbee devices, you force a network heal by taking The hub off power (including taking out batteries if it has them) for at least 15 minutes. When it comes back onto power, all the other devices will begin rebuilding their neighbor tables. This can take a few hours, so you may not see the results until the next day.

1 Like

I wouldn’t think that putting a repeater in the same location as the device not receiving a signal would help. If the repeater (bulb) is the same distance then it too gets a weak signal and can’t repeat it. Do you have any location for the bulb between the location your sensor arrives and the location of your ST hub ? I would think that would work much better. Perhaps that is the issue ? I guess maybe a plugged in device could handle the weak signal better but I still think allowing the signal to hop from hub to repeater to sensor would work better.

Hey @Ron - I see what you’re saying for sure. The bulb is maybe 3-5 ft closer than the arrival sensor, so who knows. They are both only maybe 10-15ft away from the hub, but there are a lot of HVAC and pipes in the walls inbetween the two.

My main reason for putting the bulb in the garage to repeat was actually to repeat the signal out in front of my house so the arrival sensor gets recognized as I am approaching my house. Right now I end up sitting in front of my garage for 30 seconds to a minute waiting for it to recognize the arrival sensor. I have been told by ST support that putting a repeater in the garage should solve the problem.

But you’re right, having the bulb and the arrival sensor about the same distance away from the hub may not help get the arrival sensor any better signal (to solve the “losing signal while sitting in the garage” issue).

1 Like

Good point I had just moved the hub and was having issue until I realize the batteries were keeping it from establishing a network connection on a new router install. I decided to remove the batteries for good because I have nothing that works offline anyway so why have them in there.

I should probably do a zwave repair network now also. But every thing seems to be working well again.

I also discovered that my presence sensor battery was dead so I replaced it. Was a coincidence that I moved the hub and the sensor stopped working or perhaps the extra distance didn’t work with the weakened battery.

Hmm… Did the hub utilities always have a presence sensor timeout adjustment ?

I never noticed that before. Looks like default is 1min. I wonder what this does exactly. I am assuming it waits x min before reporting sensor change and if it changes back during that window it ignores the changes and doesn’t report ? Interesting because 1min is already a long time to wait if you are using this to open a garage or something. Setting it higher will likely prevent false reports but you have to realize that now you have to wait X min for your presence activities to fire.

I wonder if this feature was always there, I never noticed it. Guess it was because this thread started in 2014 :slight_smile:

It’s always been there, I think the presentation just used to look a little different.

The presence sensor always does exactly the same thing, whether it can reach the hub or not. All it does is send a check in message every 30 seconds. It doesn’t wait for a response. It doesn’t care whether it’s in range or out of range. It just send that message every 30 seconds.

It’s the SmartThings cloud that decides what to do about a missing check in. And all it does is mark the sensor as being “away” if it has missed a certain number of check ins in a row. The minimum that can be sent to is one minute (two check ins). That number can be set higher if there’s a problem with the device being marked as a way when it was actually physically present.

For example if there’s a lot of Wi-Fi interference in the Home, a couple of check-in’s might be missed from time to time, so setting the evaluation period to longer would help avoid changing the sensor status inappropriately.

OK sounds reasonable, thanks for the excellent explaination.

However I don’t understand how I can have an away and return in my log with the exact same time based on this description. NOTE: 4:40 PM left and arrived at the same time.

Left 5:00
Arrived 5:01
This is a false set of messages, maybe I should increase to 2min.

Left 4:40
Arrived 4:40
How is this possible if the wait is 1 min ? Makes me think there is a bug on ST side.

Left 4:26
Arrived 4:31
This is a false set of messages, but too far apart 5min to fix because then I would have to wait 6 min for every presence action.

I have plantlink that uses zigbee one is out of range can I use a smart hung plug as a repeater or do I have to have a hub also?