Updates to the SmartThings Platform

I was wondering about family members as well!

I migrated, and am still unable to get family members working in new app. The error: Can’t accept invitation. Unfortunately, your Samsung account region isn’t the same as the person who invited you. You can only join this location with an account from the same region.

Called support, they fixed my region from UK to USA. I validated it was changed. Waited a few days to make sure all systems updated. I still cannot add a family member! Same error. We live in the same household how are we not in same Region? Surely Samsung has access to my location data for both phones, and yet still does not work!!!

Amazingly my 10 year old Samsung washer/dryer with Wifi are integrated into SmartThings. Yet my 2014 Samsung Smart TV has NEVER worked. Samsung updated my TV firmware and removed functionality such that it would never work with networked apps like SmartThings. SO Sick of Samsung taking functionality away that I paid for with my hard earned money (Old fashion way by working an honest living, rather than selling future empty promises which is like stealing).


I have a lot of devices which are mostly physical with custom DTHs. I’m going to spend time this weekend switching over everything I can to stock DTH and just pray that the awesome Devs here update their custom DTHs to meet the new API standards.

For those that are left in the dark, I’ll move them over to Hubitat. I’m still a fanboy of SmartThings and I’m hanging in there. However, a “New” product should ALWAYS be better than the “Old”. So far, this is not my experience.


I do not see the banner for migration on my phone. BTW a screenshot would have been nice in the documentation. My wife is already using the new app. No idea if that means we’re done, but if I install and open the new app on my phone, nothing is showing and it cannot find the hub or other devices, just the crappy old samsung6 tv.

Though what does “migrate your other locations” mean in the classic app and why does touching it do absolutely nothing?

There should be a force-migration menu item or some such thing…this is crazy.

Sounds like you have two Home Locations. Most likely, an extra was created when you added the tv. Click on menu (3 bars in the upper left of the screen) and see if there are more than one Home location. Switch to the other to see if your devices appear. If they do, it may be easier to remove the tv and add it to the other location.

1 Like

I have an embarrasing amount of Iris Smart Plugs using the Custom DTH here that give you energy use over time.

The stock DTH (Zigbee Switch Power) only gives you current wattage.

Is there a stock DTH that gives you energy use over time? If not, then will the Custom DTH I am currently using still work? I really rely on energy use to control energy consumption.

Well this is an example of how the “New App” is actually better!!!

This is the tile using the stock DTH (Zigbee Switch Power) in the New App. Even has a cool graph! :+1:t5: Don’t see where it shows how long it’s been tracking energy though like the custom DTH in the Classic…


I see that there is also a Zigbee Metering Plug which shows the energy use in the Classic App but again, does not show how long energy has been tracking. Also, don’t see a way to reset the meter in both the Zigbee Metering Plug DTH and Zigbee Switch Power DTH…


That form got me a reply with the same info pasted into the reply!

Will the Version 2 Hub be compatible with 0.32x firmware update? Will this update happen automatically? Will I be forced to buy the Version 3 Hub to unlock the new local features?

1 Like

Well, I allowed it to migrate me to the new app completely, and now I’m seeing some problems. I have some Homeseer WD200+ dimmers, which have additional “buttons” that are triggered by double/triple tap up/down (actually quite a few buttons). These were working fine in the old app as triggers for routines, as they showed as possible buttons to push. More recently, probably a few weeks ago, I had looked at the new Smartthings app and saw that I could use those buttons to trigger things in the Smart Lighting smartapp (although the correct names of the buttons didn’t appear, they just showed up as button 1, button 2, button 3, etc… under the specific switch).
Today, I went in to look at the Automation that was automatically created by the migration tool that is supposed to replace the routine. The trigger just says “button is pushed or held”, but actually doesn’t say WHICH button (i.e., double tap up, triple tap up, etc…"). I tried to recreate one of the original automations using the Smart Lighting app, and when I got to the point of choosing a button as a trigger, I selected the “stairs” switch which is one of the homeseer switches, and when it SHOULD have gone to the screen to select which button to use it crashed and went back to the main Smart Lighting screen. There is now a Smart Lighting automation listed called “lighting automation” that simply crashes when I select it (it says “Something’s Wrong, We can’t load your screen right now” with a retry button.

There seems to be something wrong with how those extra buttons work with the new app. I can contact Homeseer to see if they have any ideas on how to update their code to add those buttons, but they WERE working just fine… FYI, here is the info on how those extra buttons are set up:

These are great switches and used for very specific control of groups of lights (I can turn off/on all my basement lights from the switch at the top of the stairs by double tapping up/down). I actually had plans on using similar functionality in other parts of the house, but I feel like Smartthings just broke everything I had set up there with this migration.

Any ideas or someone I should talk to at Smartthings to try to figure this out?


I understand your frustration. There is already an FAQ which we will be adding to as users provide feedback. https://support.smartthings.com/hc/en-us/articles/360034460812-SmartThings-Classic-App-Transition?mc_cid=b07bdb6929&mc_eid=e1290e0771

We’re releasing information about the platform transition work as early and transparently as we can since we respect that our users have complicated setups and want ample time to make changes. The tradeoff is that we ask for your patience and collaboration.


so far the V2 hub has maintained the same firmware version as teh V3


Thanks. I hope it stays that way. I don’t really see the point to buy v3 unless you need to use the WiFi option, which in my case I don’t.


@blake.arnold, you get my stuff to all work in the new app, and I will personally send you a case of beer. I have been having a hell of a time with my old multi-purpose and leak/moisture sensors.

I also have some devices that do not exist showing up.

Rachio zones do not work, either.

I have a ticket open, ticket 1009083.


Any plans to fix the new Alexa and Google skills to allow selecting specific devices for exposure, or should I start planning my Hubitat or Home Assistant migration now?


All of us?


Agree. We all are requesting
1 - Control which devices are shared with Google/Alexa
2- See presence indicator in the new app
3- See location status (home, away, night, etc) in the new app

These should not be difficult requests, people have been asking for this since the new app/skill was released.


This one is in the new app.

Click on More Options (3 dots in the upper right of the screen)
Select Manage Location

1 Like

Cool, at least they listened to something

Looking at the code referenced on your link, it appears there are twelve button states being used, and they are using the ‘pushed’ value in the button attribute with a button number from 1 to 12 being embedded in the event data as a fudge to differentiate what is what. That’s fine for Smart Lighting and webCoRE and some other Classic apps as that was the de facto workaround when they were in their pomp.

However SmartThings has long since evolved. Every single one of those button states is now a valid value of the ‘button’ attribute and the Automations rather expect you do do it that way instead of messing around with the numbers. Smart Lighting understands this way of doing things and, although it can’t do it natively, webCoRE has the flexibility to cope. That is something that would be trivial to fix, but, unlike where the similar trick is used for multiple buttons, you can’t really have the two approaches co-exist.

It looks like a lot of custom commands and tiles are also being used to give you momentary actions to simulate each of the different types of button press from the app. Retaining that capability the same way might be awkward, though there might be a way of doing it differently in custom capabilities. Not something I’ve considered deeply.

1 Like

Lucky I saw this post before buying smartthings hub … It seems that they are planning to end the advanced features and an uncertain future on webcore and controllers … I will not take any chances, I will go to another platform.