FAQ: My lock/device does not pair or appears to pair but it won't show up in the mobile app or IDE - stale DTH

While the topic title talks about locks, this issue affects any device which appears to pair but doesn’t complete pairing.

If you’re having trouble pairing your device and you’re using custom DTH’s see this FAQ:


  • When you try to pair a device using the ST app or the Classic ST app it may appear to pair successfully, i.e.: the device will provide feedback that it has paired. e.g.
    • Devices/locks flash green lights or other lights to indicate successful pairing
    • Device may successful sounds/beeps
  • But the ST mobile app won’t show any new devices, it’ll continue saying Looking for devices
  • There are no new devices showing up in the IDE under My Devices
  • You are able to successfully manually exclude the device using the General Exclusion process


This is caused by custom DTH’s being marked as “stale” in the platform cache which then prevents the device from being created because the “stale” DTH is inaccessible to the platform, even through it pairs successfully.
Ideally the platform should automatically refresh the cache but due to an issue sometimes it fails to do and the custom “stale” DTH then prevents successful creation of a paired device. ST’s engineers are aware of the issue and hopefully it’ll be fixed in future.


  • Open the custom DTH in the IDE and “Publish” it again. Do this a couple of times, publishing the DTH removes the “stale” mark and refreshes the DTH cache which allows the platform to access the DTH and finish the pairing process to create the device.
  • Check if you have multiple custom DTH’s which may match your device fingerprint. Sometimes you may have old unused DTH’s lying around who’s “fingerprints” match the device you’re trying to pair. If any of those old/duplicate/multiple custom DTH’s are marked as “stale”, the device will not be created (it’s a chain process that goes through all custom DTH’s who’s fingerprint match and the weakest link fails). Steps to rectify the issue:
    1. Delete any used/duplicate/multiple DTH’s who’s fingerprints match your device. If you’re unsure which DTH’s are being used, just start deleting all custom DTH’s. Any DTH’s that are in use cannot be deleted (the IDE will print an error saying that it’s in use), and the ones in use will be left behind, all the rest (unused) will be gone.
    2. If you want to keep the DTH’s for legacy reasons, open the DTH’s and delete or comment out the “fingerprint” lines, “Save” and “Publish” so now the DTH’s won’t be used by the pairing process
    3. If for whatever reason you need to keep all the fingerprints in all your DTH’s, then you need to open each DTH and “Publish” them again so that it refreshes the cache of all the DTH’s

At this time there is no way for the user to tell which custom DTH has been marked “stale” by the platform. The only solution is to follow the steps above. Removing unused DTH’s is the easiest long term solution to avoid future problems caused by “stale” DTH’s.
This should not impact any DTH’s that actively in use (i.e. assigned to a device) but only DTH’s which are not in use by any devices and contain fingerprints that match the device you’re trying to pair.

If you’re facing this issue please report it to one of ST’s engineers and report it here so it can be tracked and analyzed by ST’s engineers.

RBoy Apps


I have the exact same issue, but it wasn’t solved.

I removed every unused DTH. Then I removed all devices, which use my custom DTH. I completely deleted and recreated the DTH, did a small comment modification, saved it and published it around 20 times. Same result, I cannot add z-wave device.

I even tried to add the device without any DTH at all.

A symptom of this issue is that it works when not using a custom DTH (i.e. using a local processing DTH). If it isn’t pairing with the stock DTH then it’s a different issue as this only impacts the ability to use custom DTH’s.

Have you tried to reboot the hub and bring the device within a few inches of the hub while trying to pair it? Without any DTH it should pair as a generic Z-Wave Device.

I went through exactly this situation yesterday trying to include a Fibaro Dimmer 2, it was working fine for a couple of years on a custom DTH, but I decided to factory reset it, to clear out any cobwebs and make use of the new locally running official DTH. I started to see the green light indicating inclusion, but the device wasn’t showing up in the app, “Add a Thing” kept spinning, however excluding it with 3 b button clicks worked each time, I went through this process maybe 10 times, power cycle, factory reset, calibration, ghost include, exclude. Before I decided to break something of value out of frustration, I wrote to support who luckily wrote back within 30 minutes, saying they could see the join/exclude’s on their side for a device with ID AR, suggesting to create a device manually with that ID. That AND deleting old Fibaro Dimmer DTH’s finally got me up and running again.

Yes, I rebooted the hub, I even disconnected power cord and removed batteries.

Well it does pair according to hub events, I experience the exact same symptoms. Might be different issue.

If you don’t have any custom DTH’s and you’re seeing the zwJoin event in your hub’s event list when you try to pair it and the device still doesn’t show up it may be a different issue. Can you post the details of your zwJoin event (it is reporting all 0’s or the full device information)

Device Handlers are completely empty. When I try to include Z-Wave device, after quite a long period of time it does join the network, device indicates that by green light. Device is still nowhere to be found. ZWJoin reports full device information correctly. Device exclusion is almost immediate.

2019-03-29 5:59:47.192 PM CET
moments ago HUB zw removed device: 56 zw removed device: 56 zw removed device: 56
2019-03-29 5:59:47.189 PM CET
moments ago HUB zwStatus device exclusion Z-Wave device exclusion started
2019-03-29 5:59:47.189 PM CET
moments ago HUB zwStatus ready Z-Wave device exclusion finished
2019-03-29 5:59:44.814 PM CET
moments ago HUB zwStatus exclude search Z-Wave exclude search started

2019-03-29 5:56:41.178 PM CET
moments ago HUB zwjoin 56 zw:Fs type:0806 mfr:010F prod:1301 model:1000 ver:4.03 zwv:4.61 lib:03 cc:5E,98,9F,55,56,22 sec:86,8E,31,40,43,53,59,5A,7A,60,…
2019-03-29 5:56:41.177 PM CET
moments ago HUB zwStatus device configuration Z-Wave device configuration started
2019-03-29 5:56:41.176 PM CET
moments ago HUB zwStatus device inclusion Z-Wave device inclusion started
2019-03-29 5:56:41.170 PM CET
moments ago HUB zwStatus device setup Z-Wave device setup started

Same issue here. Impossible for me to add a Fibaro Roller Shutter 3. I am able to exclude it, and I have the “Z-Wave device inclusion started” tag when trying to include it.

Symptoms are identical. Your join looks good. Tagging @Kianoosh_Karami. Maybe he can throw some light on what’s going on. Maybe something hidden in the IDE.

Do you have any custom DTH’s installed? None of the steps in the first post worked for you?

I have other DTH installed, not that muche (no more than 10), but they are each of them not related to this kind of device, and most important everyone of them is in use.

Did you check the event log to see if you would be able to get the device ID manually ? If so, we could look at it and do th same as you.

I already told him about the issue yesterday. But thank you for help! I’m just glad that winter is over.

It sounds like you are in the same situation I was in. Once included, find the ID of the device either in Event Logs or ask Support. Create a new device with that ID. Personally, I moved all my other Fibaro Dimmers to the official hander. Deleted the 2 year old custom Fibaro Dimmer handler so there was no trace of it. Then deleted the manually created device, as it didn’t have the correct raw data. Excluded it. THEN it joined correctly.

Amongst my trials and tribulations, powering down the hub for 20 minutes, turning breakers on and off, factory resets etc I remember doing a Z-Wave repair, and seeing a failed message for a Fibaro Dimmer custom handler, so I knew something was a miss.

First open the IDE, click on My Hubs -> List Events. Do this and try to pair your device. After it pairs (according to the device) refresh the page and look for zwJoin. If you see the zwJoin and the data is complete, I would recommend you open every DTH you have and “publish” it again. One of them may be interfering with your pairing process and without looking at the fingerprints it may be hard to figure out which one.

I did that but it did not work.

What did work though, was indeed to look closely to the logs in order to find the device ID. After many attempts, I finally found it, created a manual device using this ID, and now it works ! Thanks.

@RBoy hello and thanks for the help you are giving. I have the same problem, I reset everything, have no DH there (deleted them), the device seems to join (in pairing mode it blinks one or two times, then solid green, than turns off) but the app keeps on searching. On the zwjoin it shoes everything, even the model of my fibaro fgr 223 (v.5.00) but I go to devices and no device is found. I try to see the catchall but it’s nowhere. Can you please help me? Thanks a lot

I have four Aeotec multi sensors and running for a couple of years now’s and recently tried to add a fifth one with no succsess. I could exclude it and was also able to pair it with Aeotec stick and OTA the firmware to and down a level, just could not get it to pair with V2 hub and Classic app. Then one of the original four stopped responding and Repair did not fix so excluded via with hub ok. Tried Paring and again this sensor would not show up in devices although I did see a device in the IDE logging referencing the Advanced DTH and then a second one!

After a lot of searching I came across this thread and the link to RBoys description of Stale DTHs linked to multiple versions of a DTH. I removed all unused DTHs and tried excluding and re-Pairing, at first pairing did not appear to work until I tried leaving the Pair function of “Add a Thing” when the device turned up.

both devices are up and running, so big thanks to this forum once again for fixing a particularly vexing problem.

Yours Lumpy

1 Like