SmartThings Community

[RELEASE] DTH for Fibaro Heat Controller FGT-001

I developed new version of DTH. If you want to update, please remove your device from z-wave network and add it again. DTH is not backwards compatible due to some settings initialized during installation.

Hello,

I seem to be having problems with the Thermostat when no sensor is attached. More specifically, I don’t get any temperature reading, even though it has an integrated temperature sensor.
Message: “parsed event SensorMultilevelReport(scale: 0, sensorValue: [0, 0], precision: 1, sensorType: 1, scaledSensorValue: 0.0, size: 2) into: [name:temperature, unit:C, value:0.0, isStateChange:false, displayed:false, linkText:Living 1, descriptionText:Living 1 temperature is 0.0°C]”
Does anyone else have this problem?

Thanks.

This is expected behavior. The device itself cannot display temperature from its internal sensor. You can read about it here.

On the other hand, the device handler displays 0.0°C, but should display --°C, when external sensor isn’t connected. I have this in mind for a few months, I guess it’s time to implement it.

Hey! I was trying out my Fibaro Thermostat for couple of weeks with this DTH, but it does not seem to work correctly. The device is communicating and everything, but it does not behave as I expect. E.g. I have sensor temperature 24 and device set to 22, but it still heats the radiator. Sometimes it heats even if it is in Closed state.

What could be the problem? Is it the devices themselves (I have 2 with the same behaviour)? I’m not sure if I need to update the firmware? I don’t have Fibaro HC though and it seems it is required for firmware update. Or is it the DTH? How could I troubleshoot it?

Anyone has it working correctly?

Hi. At this point, I’m not sure. I don’t see how this issue could be related to DTH itself. There could be a bug, which sets wrong setpoint, but the value is propagated back and it would show immediately. DTH does not touch regulation itself, because it cannot.

You’re not the first one with this problem. As a matter of fact I also have this issue, but most of my heads are on firmware 4.3, which is a shitty one – according to Fibaro forums. I advise you to update firmware.

Anyway valve should definitely not heat, when the state is closed. First, try refresh button. If the state is still closed, I’d say that the valve is faulty and you should RMA it.

Hi again. So you were right. With the help of the local retailer I updated the firmware to 4.4 and it works very well! Thank you for this DTH!

Glad that it did help! That’s actually good news. I should finally update my TRVs too, but I still rather wait for 4.5 firmware.

May your contribution proposed upstream ? if not done yet please link pull request url here.

just for curiosity are there any DTH for other radiator’s valve ?

Sorry I haven’t noticed. I don’t quite understand your comment, you mean pull request to official Smartthings Community repo? If yes, I don’t know, if that’s a good idea, since dth does not work with new Smartthings platform.

hey,

hope someone in this post can help me.

i cant pair the device with my ST, are some able to help me troubleshoot.
copied the DTH from this post into the ST IDE - published to me.
when looking into my device handlers, the text is green, but as far as i have read, this should be fine.
using the old classic app, to add a thing - triple click on the thermostat, but nothing showing up.

have tried reset trying to pair the device on the valve and off the valve to take it closer to the HUB.

i do not know, if i missed any steps. i bought the devices second hand. and the devices worked before.

I have the same issue. It’s probably caused by a major bug in latest hub firmware. Could you check, that you have hub firmware version 25.26?

Also look at the firmware thread, where I raise my complaints and you can check this FAQ thread, where is a possible solution to our issue. Altought it did not work for me.

Lastly, send a PM to @Kianoosh_Karami. He forwarded my issue to dev team.

Thanks for the feedback… my version is 25.27… and my hub is v3.

So you havnt solved the issue yet either.?

I cannot solve it. Since the device won’t pair even without DTH, there’s nothing I can do. I hoped that 25.27 would solve it, shame.

@danni_mieritz @Toka There are a number of people reporting similar issues pairing Fibaro roller shutters over the past day or two. They all seem to be having success by checking the hub event list in the IDE for a successful join, then using the zwave ID from that event to manually create the device in the IDE. The work around is documented here.

Indeed that works. Thank you.

Do you have any idea, what’s the issue? I’m trying to figure out, if I can fix it in DTH itself. I wonder if capability “Configuration” is somehow messed up.

I don’t think it’s the DH (and, even if there were a problem, it should just show up as a Thing). There were a number of people who were able to include using my roller shutter DH up until this last firmware update . The firmware update included a “new zwave framework” so I’m betting that’s the problem. Hopefully they get it straightened out and push another firmware version soon.

@philh30, thannk you…

@Toka, you got i working now, right?

im still got some minor issue, with the connection, it connects, than disconnects… but i think its a local problem.

I’d suggest you post here about your problem. ST staff are active in that thread, and say they’ve found the issue with joining based on what @Toka posted there. Whatever connection problem you’re having could be related.

We all agree that’s it’s still not working, right?

The DTH does work, but you have to add devices manually via Developer Workspace.

Sometimes tho the scheduler drops and in that case your temperature reading will be disabled. In that case you just need to manually click on “reset” tile.