SmartThings Community

Fibaro fgr-223 DH needed!

How do I change the buttons from simple movement up down to entirely close and open each click

Have you set any parameters besides #20?

No, only #20

From the manual, it looks like default operation should be that one push makes it open/close, and pushing again makes it stop. Have you run calibration? My only thought is that the Fibaro should automatically set parameters 156 and 157 to the amount of time required to raise/lower as part of calibration, which might play a role in how long the motor runs when the button is pressed. Even if you’ve already done it, try running calibration again.

I was able to add a total of 6 Fibaro Roller Shutters 3 (FGR-223) earlier this month using the info on this page. Today, I wanted to add 3 more with no success, they simply would not be discovered by the hub no matter how close I put them while pairing. All the 6 already paired still work without an issue. I am hesitant to remove any of them and try to pair them again as they work just fine. I removed one Fibaro Roller Shutter 2 as I wanted to replace it with a model 3, and I was able to pair it again with its own handler.
I tried pretty much everything I could think of (restoring the roller shutters, etc.).
I suspect it might have something to do with a recent smartthings update, I got an e-mail on 26 March 2019 (European time) about it (version 25).
Please advise.

Maybe you have this…

Have you tried a general exclude on the troublesome devices? Sometimes that’s necessary before including a zwave device.

Thank you both very much for your prompt replies! If I understood correctly, these instructions amounted to

  1. ‘publishing’ the device handler again a few times (i do not have any other device handlers except this one and the handler for one FGR-222) [picture 1] and
  2. doing the general exclusion process (i looked up in the manual how to do it, picture 2), I got the confirmation from smartthings hub that a zwave device was removed.
    Unfortunately, the shutters do not appear in the search after all this (and after I try to pair them, I am able to remove them again using the General Exclusion process).
    Please advise

it’s letting me put only one image in the post

Same issue here. Impossible to add it and I can perform the exclusion process well.

Do you also have some roller shutters 3 which do work from before (the firmware update to the smartthings hub)?

No, this is my first one, as a test.

Well then, it’s a good chance that the firmware update messed up the device handler, if you are doing the pairing process correctly

I really think I am doing it correctly. The Fibaro’s LED turns solid green as if the pairing was succesful. And then nothing, but I can exclude it easily after trying to include it. And I just saw this, so I hope it is firmware update related and that it will be fixed soon.

https://status.smartthings.com/

Yes, that is my case as well, the Fibaro’s LED say the pairing is successful, however the device does not appear in the smartthings search. Okay then, we will wait for a few days…I might get a fibaro hub lite in the meantime though xD

Ok, I succeeded in including my Fibaro Roller 3. Here are the steps I performed :

  • Exclude it before anything
  • Then try including it again like the usual
  • Just after the Fibaro Roller Shutter 3 shows a green light meaning it is sucessfully paired, log into the IDE and check your Hub events
  • Look for the event that will look like "zw device: 15, command: 3202, payload: 21 32… "
  • You need to write down the number or combination of letters/numbers just after the "zw device: ". In my example, it is simply “15”.
  • Create a new device manually in the IDE, using the ID you found out at the previous step (again, for me it was “15”). Put it in “Device Network Id”.

And then in the app, add th manually created device, it should work with your Fibaro module !

2 Likes

Brilliant, thank you so much! I did exactly as you said and I managed to pair the shutters with my hub :smiley:

How can I disable the automatic open\close on first clicks.

Tried this and could not see a clear connection that you described looking for zw… i have the same symptoms that the fibaro green light confirms its added but does not show in ide or either apps. Though i could exclude device sucessfully multiple times. What is it that i am missing. Thanks

Just to clarify, after the roller shutter confirms the connection with the green light, you look up it’s number in ide under ‘my hubs’ and then click ‘list events’ (down on the right), there cloud be plenty of other devices above it in spite of you pairing it just now, for instance I had a few Belkin wemo switches showing above the roller shutter even though I haven’t touched any of them. You are looking for a 2 digit number after zw device, eg. ‘zw device: 18’

had same problems. thanx guys!