Cannot add my Schlage Connect Lock to SmartThings Hub

In the new app, click your hub from your dashboard. In the top right hand corner there’s 3 dots, click that and choose z wave exclusion. Then run the pairing command on your lock. And you may be able to completely unpair your lock, which allows the lock to be paired again with your hub.

If your hub has already got some pairing information from a failed pair, then it may not be able to pair again. I’m sure there’s a more technical description of this. But I think that’s the gist of it

Perfect the exclusion worked!

Onto a new problem, I have followed this guide https://www.dropbox.com/s/pfi9ciqmxbjq9lo/guide.pdf?dl=0

However, the last step where the app should show up under My Apps doesn’t work, nothing shows there.

You’re using the classic app, right?

Keep trying to “Add” the new thing and plugging in that Schlage “6 digit code” followed by a 0. It took me several times and I still go the red “X” but eventually while running Connect ADD Thing it showed up and I was able to rename and add to my routines (unlock with presence arrives; etc).

Keep trying it is quirky. However, using the new SmartThings app (I have both installed) the new version does not register the lock. I am still working on it and if anyone has any suggestions please let me know. At least I have both the front and back door connected and it has been working correctly. I did unplug the hub for 15 minutes and run the Utilities Repair and that may have also helped.

I just came across another topic where folks were having other issues with Schalge.

Assuming that you’re using the “scan” feature in the new app, I’m wondering if you’re facing an issue with your mesh, it’s worth trying it out, see this FAQ which explains it nicely. FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?

Reboot the hub, bring the lock within 5 ft of the hub and then try to pair it. Thereafter add a repeater between the lock and the hub to improve the communication stability.

I have a Schlage connect lock. When I first paired it on my front door it was fine. This was a good 30 feet away from the hub. When I renamed my network it just point blank refused to connect. I spent hours on the phone with Schlage and tried a million different things but nothing worked. I eventually gave up and moved it to the side door that doesn’t get used much. I replaced it with a Yale lock and that works perfectly every time.

I fond Schlage customer service to be worse than useless. The door it’s on now is directly below the hub, less than 2 feet away from a smart strip which is also outside and about 6 feet away from a smart plug and Samsung motion detector which are both in the room that the door opens onto and it still won’t connect. The lock works, just not with ST. I wouldn’t recommend Schlage to anyone.

Do you mean it doesn’t pair? If so try this:

  1. Exclude the lock
  2. Reset the lock to factory defaults
  3. Reboot the hub (don’t miss this)
  4. Bring the lock within 5ft of the hub and then try to pair it

Yup, tried that. About a dozen times when this first started, and again when Schlage suggested it. It’s just not showing up at all. I brought the hub and the lock to the same room as the router and sat them all in a triangular pattern about 2m apart, and it still didn’t see it.

Do you have any custom device handlers installed? If so remove them or republish them due to the stale DTH issue with unused DTH’s.
Ideally you should only be using one of two DTHs’ for the Schlage connect, the stock “Z-Wave Lock” or the “Enhanced Z-Wave Lock” DTH.
If there are any unused lock DTH’s lying around in the IDE it can interfere with the lock pairing process.

Thank you for the tip. I ran the z wave exclusion and was able to pair my lock.

This was from a few months ago - any success? I’m having the same problem - I can exclude the lock, but when trying to pair ST never finds it. Like previous suggestions, I’ve tried the exclude/factory reset the lock/reboot ST hub/ pair again (with the lock touching the hub) many, many times.
As a quirk, I also have a Nexia hub (built into the Trane T-stat, not used for any other HA devices). I tried connecting the lock to that and it paired right away. I excluded from the Nexia, then tried connecting to ST - no dice. Must be a ST issue?
As a note - I have two of these locks - the first one connected no problem at all, but the second refuses…

Yes, I did get it resolved, but unfortunately I can’t remember what we did. I do remember that I called Schlage again and the steps the lady I spoke with took me through were subtly different to before. The lock is on my house in Mexico though and I am back in the UK now so I can’t remind myself of the steps to see if it prompts anything. Racking my brains, I seem to remember it was something to do with a pause in the process somewhere along the line

Migrating to Aeotec Hub:
I had to use the 6 digit Programing Code + 0 on BOTH the Exclude & Include procedures!
I had the hub within 5 feet of the lock…not sure if needed.
I did a Repair Z-Wave Network after the Inclusion.

New locks are seamless adding. just open bolt \ schlage button + prog code + 0 \ and it adds lock fairly quick.

The problem occurs when lock is from a previous network. I have run into this problem several times before. the normal factory reset doesn’t do it. ( disconncting batt and holding schledge button on pad)

You have to go into the previous hub system and release it.

ie. I had WINK and had to subscribe just to be able to release the lock from WINK hub. It was $5 bucks only used it for 10 minutes and canceled service but lock added and registered on smartthing hub immediately.

it’s kinda extortion what WINK did but just pay the 4.99 , cancel and be done with them. I recommend to gracefully remove all devices that were connected just to be sure. some might require to add again and remove but it’s the only way you can insure that is clean for migration.

WINK membership will work till end of month once you cancel.

You will need to add an extra app on your smartthing app to control user codes you would like to add / manage.

app is call “Smart Lock Guest Access” featured as add on from within Smartthing Android/ ios app.

You don’t need the Wink subscription to exclude your lock, you can do it directly from the SmartThings hub using the exclusion process even it’s wasn’t paired using SmartThings.

You can also check out this lock user management (LUM) app which can create many advanced types of users and schedule codes, create custom actions, notifications and much more:

I’ve never heard of your app but sounds great but how can you
exclude it if Smart things can’t even see it.

this thread is about smart things
going fforward

if the lock was on an automated hub like wink I have found that if you’re able to remove it from within the wink app everything works perfect. You’re able to see the lockthat was not even recognize or found in any scans. After doing this it just connect and registers in smartthing like a breeze.

don’t know why wink does this but maybe it’s some type of safety feature if somebody runs off with your llock they can’t use it.

Take a look the exclusion link I posted above which explains how to do a generic exclusion for zwave devices which aren’t paired with the hub (zwave standard allows for this)

The z-wave standard says that a z-wave device can be excluded/reset from any z-wave certified hub, even if it was never paired to it. Since both Wink and SmartThings are z-wave certified, this applies to them. Most older z-wave devices MUST be excluded. Resetting them alone won’t work. Here’s how to exclude any z-wave device using a SmartThings hub:

Well in the same boat as others. Relocated lock to another door. Have gone through the factory reset numerous times, excluded it, added it back in. Have it sitting right next to my hub. Have rebooted the hub, including pulling batteries. It will join but it’s not secure so can’t do anything with it. As I’m adding it back in it will search for it, then ask to scan the bar code (which of course is inside the device) and then won’t recognize it so I enter the 5 digit prefix which it seems to accept, to a point. I did have this lock on my system before so I know it works, just now can’t get it back in.

I went ahead and reinstalled the lock, far end of the garage at an entry door and tried to add it back in one more time. As before, it would join, even through 5+ walls and almost 70’ away, but just won’t do it securely.