SmartThings Community

Hub Firmware Release Notes - 25.26

Yup, I know. Sometimes that works but I have 1 device in particular that neither ST nor I could clean up.

FYI, That works, but if the device is still in the network and responding, it will fail to be deleted, however the classic app forcefully deletes the device record in the cloud, and the user gets the wrong impression that the ghost device was removed. However, if you the new app, “force delete” will only be successful if the device (ghost device in this case) was actually removed from the network.

Thanks for sharing that with others.

3 Likes

They are definitely not The same across the many different hubs. There are different development teams working on all of the specialty hubs, including the Wi-Fi mesh ones, the Nvidia one, and the ADT one. They will not all have the same firmware number nor receive firmware updates at the same time.

2 Likes

I found that did not work in my cases as I too followed this hoping it would. I suspect it is based n how the device became phantom to begin with as in my case the devices just disappeared one day. Regardless, Support will backstop this
if you can’t do it manually.

24.x is only one major revision behind 25.x. So not far behind at all.

1 Like

Is that related to the “stale” DTH issue, or is that a separate problem?

1 Like

Yes, this is the stale DTH issue.

1 Like

Something has definitely changed for the worst on Z-Wave. I am consistently seeing very slow updates of state from devices manually operated. This did NOT happen before this FW update.

It’s a real pain for a number of reasons… one being I have several smart switches with no load that have a Smart Lighting rule to mirror to another device. So now when I operate the switch at the wall the device that should mirror the switch might take a minute or two to kick in. If I had delays before it was seconds.

@Kianoosh_Karami, I appreciate you trying to help but you said what you saw was expected behavior because I have many devices and some do not report status so I have to wait on polling and my mesh is large. Respectfully I have to point out that I did not get these issues before this update…

My problem is not with just one or two devices but so far every device I have tried.

Operating via the app is fine. This looks like a change in the polling or whatever was changed with Z-Wave in this update has affected polling, badly.

After getting rid of a few bad devices in my network some time back I had been so happy with my Z-Wave stuff - all was performing very well. Now things have taken a step or two backwards and all that changed was the hub FW.

EDIT: My door locks are taking even longer to report state so my automations based on those are also useless right now.

My Zen is fine, it has been all the way through this beta rollout. It updated to the latest Zen firmware that was included.

My hub is still on 26. Zw node ID shows as 01. All zw devices in new smart things app show as disconnected. Is this a separate issue or the same as everyone mentioned this morning? Because the devices are working, but not showing as connected in the app since the update yesterday.

Unless you’re using math ADT hub which was touted as the latest and greatest less than a year ago and is still on 20.x – which means it is missing out on an awful lot of local device handlers…

right. but he was specifically referring to the SmartThings WiFi system.

Did you try rebooting the hub and the router. I’ve found that network latency makes things a lot worse and simple reboots of the devices in the chain tend to help tremendously especially if you’re using custom DTH’s because of timing issues introduced by latency.

I did reboot the hub yesterday after the FW update and after I noticed the problem. I have not rebooted my router. Many of the problematic devices are using stock DTHs and are local (Z-Wave switches/dimmers with standard DTH for example).

As I noted, if I operate the devices from the app then they respond instantly. This is restricted to operating the device manually and the state change taking up to minutes to show in the app/IDE (ie, it’s state is delayed getting to ST). I just don’t buy the idea this is just how it is due to polling requirements when this problem did not occur before the FW update.

I did have an issue weeks back that was traced to some bad devices that were flooding my mesh. I have since removed them and for weeks all was good, really good, best I have experienced to be honest. But, in that scenario before I ditched the bad devices my entire Z-Wave set-up was sluggish. Even when I operated a device from the app or Alexa it would take ages to take effect. My current issue is strictly only when operating the device manually thus my concern that polling is jacked-up now.

Me too. Been offline for 2 days, since the firmware update. Flashing blue light. Reset switch, router, hub, to no avail. Hub is hardwired to unifi switch 24 POE-250W and it to Unifi security gateway 3P.

I’ve been having the same zwave issues mentioned in previous posts but as of a few hours ago there is another odd issue occurring. Everytime I open the smart things app (not classic) one of my zwave devices (a zooz light switch) turns on. Not by me toggling it, by just opening the app. At first I thought I thought I may have accidentally touched the icon, resulting in it turning on, but I noticed every time I would open the app it would suddenly turn on. Has anyone else had any zwave devices suddenly activating/turning on when opening the app after the firmware update?

Hey.

I have a hub v2 UK and it’s installed in Romania, since 27.03.2019 19:00 i’ve been offline and the light is either SOLID BLUE or Blinking Blue. I’ve checked everything and it refuses to get an IP from the SWITCH or from the ROUTER. I’ve tried using DHCP and also hardwired mac with static IP it shows up for a bit then it’s gone.

This started happening when the ST status page started showing Under Maintenance. None of my Fibaro FGS-223 relays are working anymore.

@posborne Hub (v2) has been offline for 2 days. Blue solid light. Router can’t see it. It’s an AT&T ARRIS BGW210-700. Rebooted hub, rebooted router, no luck.

One “major” but the “minor” versions still have some important improvements lol.

Possibly a dumb question, but have you tried cycling power on the hub (remembering to remove the batteries)? I believe there’s an issue where the new app will miss the event indicating things are online, and cycling power should fix it.