Schlage Camelot Pairing Issues


(Brian) #1

I’ve done the searching. I started with my hub inches from the lock. I’ve tried Walter’s general exclusion prior to pairing. I’ve tried to pair. I’ve tried reseting the lock. Literally nothing is working. Has anyone seen this and found a way to get it enabled? The lock is installed, works with codes etc, it just WILL NOT pair to my Z-Wave network.


FAQ: Pairing Schlage Z-Wave Locks
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Are you very close to the Hub?


(Brian) #3

Literally as close as an inch.


(Dan P Parker) #4

That might be “inches” too far. I had to have both my Schlage and my Iris garage door controller essentially touching the hub before they would pair.


#5

First things first: what’s the exact model number? Has this ever worked with another Z wave network? Are you sure it isn’t the zigbee version ( they look just the same, they just have a different radio inside)?


(Brian) #6

Schlage Connect BE469NX. Definitely ZWave. It was new in box, so I assume it was not paired prior. Regardless I’ve tried a general exclusion several times without success.


(jkp) #7

simple question… you are also putting the lock into pairing mode?


(Brian) #8

Yes - putting the bolt out. Pressing Schlage button. Inputting Programming Code. Pressing Zero.

I literally tried again with the hub pressed against the door. Still nothing.


#9

It could be a bad Z wave module, it happens. Do you get any LED indicators when you do the general exclusion?


(Brian) #10

Nothing. The ‘X’ on the touchscreen flashes telling me nothing happened.


(Steve White) #11

I have a couple of these and they are very persnickety about pairing. I trust you’re following these steps:

  1. Press the schlage button.
  2. Enter the master code.
  3. Wait for the LED to flash 3 times.
  4. Press 0

The LED should flash rapidly. If successful the green check mark will flash. If unsuccessful the red X will flash that you are seeing. But wait, there’s more…

Next time to try to pair the lock, before you start, log into the IDE and navigate to the Hub event logs, then do the following.

  1. Start the process in SmartThings to add the device.
  2. Refresh the event log in the browser. You should see a “Z-Wave device inclusion started” message
  3. Follow the steps above to put the lock in discover mode.

If the lock fails again with the dreaded red X, don’t give up. Leave the hub in pairing mode. Refresh the hub event log and look for a Z-Wave “device setup started” message. You may have to scroll down a few pages. If you do see one, that’s a good sign. Just leave it alone for a few minutes. You may likely hear the lock beep and flash the green check.

Here’s why. These locks are very sensitive on the timing involved with the security key exchange which is part of the Z-Wave protocol. Any significant traffic on the network will interrupt this process and cause the lock to indicate the pairing failed but the process of started can still continue in the background.

If you do not see any device setup started messages then the lock has failed to negotiate with the hub.

One more tip, if you have any chatty Z-Wave devices, especially ones that meter power (i.e. Aeon Labs home energy meter), you may want to disconnect power to those devices before you start pairing the lock. I’ve had to take my HEM offline to connect locks in the past.


(Glen King) #12

If it is New, take it back (after deleting your codes) and get another.
My first one did not work.
My second one works very well.


(Brian) #13

Thanks all. Steve’s reply seems most on point to the issue, and it appears he’s experienced something’s similar to my issue. I’ll try it tomorrow.


(Brian) #14

Closer…


(Steve White) #15

That’s an encouraging sign, at least we know the lock is communicating.

Here’s what you do next…

  1. With the lock no more than 3-5 feet from the hub, remove the lock from SmartThings. To trigger device removal on the lock, follow the exact steps used to put the lock in discovery.

  2. Once removed, I recommend trying one more Z-Wave exclusion. Go into Z-Wave utilities on the mobile app, and activate General Device Exclusion. Follow the same steps again to put the lock into discovery. They will ensure the lock is truly dissociated.

  3. Now, reset the lock. This is very easy on the Camelot. Disconnect the battery pack. Press the exterior Schlage button a couple times to discharge the lock. Then press and hold the exterior Schlage button while re-connecting the battery pack and wait a few seconds after which the lock may beep and the green check will flash. The lock has been reset.

  4. Make sure that chatty Z-wave devices are turned off, especially anything that meters power like pocket sockets and energy meters such as the Aeon HEM if you have one. A busy Z-Wave network will make the process unreliable.

  5. Attempt to pair the lock following the normal device installation process.


(Nathan Curtis) #16

I second this, I own three of these. When I first installed them, two of them (all were new in box) needed to be factory reset before they would join successfully… Ever since then they have been relatively trouble free.

And BTW, expect them to start flaking out when the batteries read ~60%. Replace the batteries and you will be good to go again… :wink:


(Brian) #17

I was able to reset the lock and get it to pair on the first attempt this morning. As well, I installed Lock Manager and have been able to set up codes. Thanks so much for everyone’s help!


(Steve White) #18

Great news!! Enjoy your new lock!


(Brian) #19

Actually afddd a 2nd Schlage Connecf to the house today. I guess I’m a gluten for punishment :slight_smile:

Anyway- this one went off without a hitch following the advice on his thread. Thanks again!


(Dan P Parker) #20

I hope it didn’t cost you a lot of dough.