FAQ: Did we lose the ability to add custom smartapps after the app update of June 2021?

I noticed several users reporting the inability to add custom smartapps after updating their ST app (June 2021).

Just wondering… I have not checked into it.


Update: you need to enable developer mode in order to access custom smartapps

To add Developer mode to the ST app…

login into the developer site first at This link

Then in the ST app go to

Menu > settings

Press down on the “About SmartThngs” field
The background color changes to a darker shade as you are pressing and about 5 seconds later the background changes to white so you stop pressing at that point.

Then scroll down to see developer mode at the bottom of that screen.

Update November 2021: to locate custom smartapps, you need to tap on the Automations tab, click on + in the upper right of the screen, Add Routine and choose the Discover tab at the top. Scroll down to find custom smartapps.

4 Likes

Tagging @jody.albritton

2 Likes

I can’t figure out how to do it, so I suspect it’s not there any longer…

I enabled developer mode and now I can see my custom smart apps again. It’s bizarre that support couldn’t tell you this!

3 Likes

Can you do this using new app via IOS? Tried the long hold on the about SmartThings and nothing shows up. It just takes me to the about SmartThings.

To add Developer mode to the ST app…

login into the developer site first at This link

Then in the ST app go to

Menu > settings

Press down on the “About SmartThngs” field
The background color changes to a darker shade as you are pressing and about 5 seconds later the background changes to white so you stop pressing at that point.

Then scroll down to see developer mode at the bottom of that screen.

3 Likes

I’m having the same issue on my end with the new iOS app. I tried holding the About SmartThings button for 5+ seconds but no luck. I even tried on the previous iOS version using an older tablet I have and that didn’t work either. Is there any way to enable Developer mode from the IDE?

Yes. I’ve been able to enable it on both my iPhone and iPad. You have to continue holding the “About SmartThings” for about 5 seconds and then it suddenly un-highlights itself. Then after that the developer mode option shows up at the bottom.

In case anyone wondered, there doesn’t appear to be any way to do this with voice navigation. :disappointed_relieved:

@blake.arnold

4 Likes

I’m sorry, there must be some phone specific bug at play with this. I’ve held it for 30 second and never see the effect described. I’m using an Iphone XS with the next-to-latest version of iOS. Not working for me.

Keep trying… it took about 5 attempts before I got it. It was not a fun experience.

I was able to add custom apps by using an iPad with the previous SmartThings app version, luckily it was dead and didn’t automatically update. Once I added the apps, it showed up on my phone in the new app.

I haven’t been able to activate developer mode in either apps though, but doesn’t look like I need to with the approach I took. Going to keep my iPad with the previous app version for now.

Then I must be looking for a single pixel. It either ends up opening the “About” screen or never turns away from gray, no matter how long I hold it.

1 Like

To add Developer mode to the ST app…

login into the developer site first at This link

Then in the ST app go to

Menu > settings

Press down on the “About SmartThngs” field
The background color changes to a darker shade as you are pressing and about 5 seconds later the background changes to white so you stop pressing at that point.

Then scroll down to see developer mode at the bottom of that screen.

6 Likes

Thanks - appreciate your help. It’s got to be something with the device. I know different iPhones have different haptic and 3D functionality. I just rebooted the phone and tried again, same result. I will continue to try, but I’m thinking something isn’t working on my phone. I have been reluctant to upgrade my wife’s phone, but maybe that’s another approach. Thanks again.

Just got it, apparently you need to have logged in to the devceloper portal at SmartThings . developer .​samsung.com

5 Likes

Yes - this did it for me too (login developer portal).

Nice! This worked for me too. Great find.

Worked! Thank you.

Outstanding… this worked thank you. But I can’t find the Homebridge v2 in the Smartapps.