[RELEASE] Verisure integration

Same here in Sweden.
But if i understood this text right i can choose between 2way authantication or working third party app?

*How does 2-step verification affect third-party integrations with Verisure? *
When 2-step verification is enabled, your connection through the third-party integration might stop working. Please note that if you disable 2-step verification, the risk of unauthorized access to your account is increased.
*Follow these steps to restore the connection: *
1. Log in to MyPages with your username and password. Enter the verification code when you receive it.
2. Go to Account and Subscription > Account > Login credentials > Disable 2-step verification
*3. Follow the instructions to disable 2-step verification. *
In order for us to get valuable input for potential future improvements for users that have a 3rd party integration to Verisure, we have created a short survey as part of the Disable 2-step verification steps.

Did not see that part of the text. :slight_smile: And others have reached out to Verisure and confirmed that you can disable it on your profile. So should be good once you do that. :slight_smile:

I also got that e-mail today (Sweden). I love the Smartthings/Verisure integration. It enables me to trigger a lot of activities when leaving home/coming home.

At the same time, I am also a fan of 2 factor authentication to improve security.

Maybe it would be possible to enable this with 2 factor authentication as well?
I don’t have the skills myself, but maybe someone is up to the challenge :slight_smile:

Thanks again @anderssv and others for this fantastic integration!

since i have updated my hub to the latest firmware version, I can not connect the Samsung arrival sensor…any suggestions will be appreciated
I have tried to rest both the sensor and the hub still no luck

Hi Andreas, sorry for late reply. Did you get it work ?

You need to install all device handlers in addition to smart app.

regards
origami

Hey

I can see on the OG python implementation on github that it’s working with MFA and have support for arm and dismarming the alarm.

I have tested it in python and its working :slight_smile:

but that’s where I reach my max know how.

Anyone having any idea on how to get this working inside ST so ex. you can arm the alarm with an event.

Could be pretty nice :slight_smile:

Link to OG: GitHub - persandstrom/python-verisure: A python module for reading and changing status of verisure devices through verisure app api.

1 Like

Hi!
I just installed both device handlers and the smart app (I have published them “for me”) but I’m not able to see the smart app in ST app to be able to sign in with my credentials to Verisure (I also have turned off 2-step verification)… How do I make it work?

Thanks,
Pehr

I have exactly The same problem, I have the smartapp and DH installed the IDE /Smartthings account page page but not able to see the
Verisure smart app on my iPhone.
Greatly appreciate any input as I’ve been a sincerely happy user of Anders’ work on this integration.

Hi Guys. I am not using this app anymore so I don’t really have the possibility to test it. Sorry. :slight_smile:

The only thing I can think of is that I think you need to use the classic app to add the app? Or am I mistaken here?

Maybe someone that have installed it lately can confirm it’s still working?

BTW: I’d be happy to give anyone wanting to maintain this access to the repo, but of course you can fork as well if you want to. :slight_smile:

Unfortunately the Classic app has been disconnected and is not longer working, however according to Smartthings support they say if it does not show its “no longer supperted”. I find that strange as it worked beautifully some months back.
In my IDE page i get this error message;
00:09:58: error java.lang.NullPointerException: Cannot get property ‘giid’ on null object @line 245 (doCall)

Any idea what this is and may that be the reason? Seems to be populating every minute or so.

Is it so that one have to setup the Verisure integration on the phone or can that be done on the Smartthings IDE page? Ive tried the simulator tab and adding credentials but no luck integrating Verisure unfortunately :frowning:

Thanks alot your input.

Try this FAQ: Did we lose the ability to add custom smartapps after the app update of June 2021?

1 Like

My guess is missing credentials. Doubt it will work adding it through the simulator. I would look into the FAQ posted by @Jepajo above.

Thanks alot, i can now access the smartapps!
Greatly appreciate your suggestion.

Anders, i have now managed to get the smartapps in Smartthings, however i continue to get this error message:

+++
physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Verisure Contact Sensor’ in namespace ‘smartthings.f12.no’ not found. @line 342 (doCall)
+++

When i am triggering the alarm, it does not change the mode that i have set it do do (ie home alarm turns of all lights etc).
Any idea? All other settings seems to correct and i have cross checked username and password. Thanks your suggestion!

Hi Andreas, did you by any chance find a solution to this error message? I have the same error message, but struggeling to solve it.
Thanks!

Hi,
I’m new to Smartthings, but got the error to disappear by changing code line 338:
contactSensorDevice[“doorWindowDevice”].each { updatedJsonDevice →

To:
contactSensorDevice[“doorWindow”].each { updatedJsonDevice →

Hoping this will work for you too.

Br. Mikkel

Wow! That did indeed work - thanks alot for your input, really appreciate that.
Are you able to make Verisure alarm work together with scenes? Say where lights turns off when alarm is turned on?
Thanks again.

I haven’t tried that yet. Currently I only have a virtual switch that turns on/off depending on the state of the “location” which is linked to the state of the alarm.
So my switch is on when the alarm is on and vice versa.

Okey, your suggested finally made this work for me again. So really appreciate your comment. When i turn on alarm at night all my lights turns off and thermostats goes down.
Thanks!!