Can Aeotec Smart Home Hub be connected to Homebridge?

I had a SmartThings hub (Classic) and had it connected to a number of light switches. I also had it connected to Homebridge running on a Raspberry Pi device and that’s how I was able to (fairly easily) connect it up with Apple’s HomeKit so that I could control all of the devices in my house via HomeKit.

I kept receiving notices that I needed to upgrade to the Aeotec Smart Home Hub and so I did. It’s the Aeotec Smart Home Hub v3 (as printed on the box’s packaging). I’ve been able to add a few (but not all) of the light switches to the new hub.

What I can’t seem to figure out how to do is to connect the Aeotec Smart Home Hub to Homebridge. Is this supported? Has anyone been successful in doing that?

Yes, homebridge will work. You are going to need to set it up again. Not sure which smartapp you were using. I use the following:

As for the switches you can not get connected to the hub, what brand and model? If they are z-wave, try a z-wave exclusion on them and then try to pair them. To exclude, go to the Devices section, click on the Home icon in the upper left of the screen, select All devices and locate your new hub and open it, then select the 3 dots in the upper right of the screen and choose z-wave utilities. You can exclude z-wave devices from other hubs.

1 Like

Guessing that’s for IOS. If you are on the Android app, then go to Devices, but select the Rooms drop-down menu to find “All Devices”.

Noted :slight_smile: will just refer to it as menu from now on or side menu


Ok, I have more time to look into it this afternoon. The Homebridge-SmartThings-v2 plugin wants an App URL, App ID, and App Token and says, “To get this information, open Homebridge (SmartThings) SmartApp in your SmartThings Classic Mobile App, and tap on ‘View Configuration Data for Homebridge’”

The Classic Mobile App no longer functions on my iPhone. I can’t find this same information in the new SmartThings app for iPhone. Am I looking at the wrong thing?

Look on the Add Smartapp section or the Automations section at the bottom of the screen. Sorry, I installed before the latest app update so not sure which one for you to look… it will be one of the two. Probably add smartapp to configure and once you do, it will appear in the Automations section after.

If I go to the “Add SmartApp” section of the app, I get a list with the following:

Severe Weather Alert
Enhanced Auto Lock Door
Ready for Rain
Smart LIghting
Color Coordinator
Keep me Cozy
Thermostat Mode Director
Smart Windows
Speaker Companion
Door Knocker
SmartSense by Idaho Farm Bureau

I don’t see Homebridge anything inside the app.

Enable developer mode then look

Ah ha! That was the issue. I think I have it all working. Now I just need to get the rest of my devices connected and should be back to normal again. Thank you so much for steering me the right direction!

1 Like