SmartThings iOS app update (v. 1.6.67/1.6.68) June 2021

After updating the iOS app, all of my devices said “can’t connect.” I deleted the app and reinstalled it and now they’re working intermittently. Sometimes the app crashes when loading a device. :pensive:

How do we add custom SmartApps now? Other than the ones I’ve already got installed (e.g., Webcore), I can’t add any new ones. Added in the IDE but nowhere to be found in the app.

1 Like

Smartthings iOS Widget is a mess. I’ve noticed a bug where if you force close smartthings and the trigger a scene, smart things app opens and actually triggers 2 scenes. Anyone else run into this issue?

Also sometimes the widget just shows “open smartthings” which I keep doing but it’s randomly does this. Argh.

And!!! As others mentioned widget scene triggering opens smarthings app is dumb and defeats the purpose of a widget. Why do that and make us close the app. Otherwise I can just tap on the app itself.

1 Like

Any idea how to enable developer mode on iOS? Went looking for it and can’t find it. Thanks.

You are right. I read it but didn’t comprehend. Small slap to me and thank you. Silly question. Why would they limit it to 4? I was using 8 but that is not a big one. Thank you so much!

I let myself get hung up on everything breaking at the same time and staying up an extra hour rebooting everything until I could turn it all off.

I should have taken screenshots of the missing automations in the app which really threw me.

You are the person!

I have no clue on the limit of 4 scenes for widgets. If enough users complain to ST, who knows, maybe tHey might increase it. But I would not count on it.

Edited to reflect this post was in regards to widgets

Replied in your other thread…not working for me on iPhone XS.

Since iOS update last last night I cannot access my smart things account… reset router, logged out and in again on app, reset hub. nothing is working! no access to devices!!!

Yes and it doesn’t work

1 Like

Thank you eric182! I had no idea I had to add it to the Home Screen and drag it over to the other view. You’re a lifesaver.

So, I had the issue(s) that many others did with this “'Upgrade”

  1. When I first opened the app, it wouldn’t connect to ST or display my connected devices. To address this, I uninstalled the app and reinstalled from the app store.
  2. Once I had done that, I could see the devices, but couldn’t control any of them (I kept getting a network connectivity error. To address this, I unplugged the ST Hub, and kept it unplugged until all of my devices showed as “offline” in the app. Once that happened, I plugged the hub back in and waited until they all showed up again. Once they did, I was able to control them through the app (and via my Amazon Alexa) again.

Quite the “upgrade” - just posting this here since I didn’t see a single response putting both of these steps together to restore full functionality.

I’m in the same boat. All of my Cree and Sengled bulbs stopped responding. I’ve powered off the hub for 15 minutes, reinstalled the app, but still not working. I really don’t want to have to manually re-add two dozen bulbs and then rebuild all of my routines. Hopefully it will resolve with an update. As it stands all of my bulbs are ‘stuck’ on whatever last brightness and color setting they were on last before everything went down.

Welp, not going to install this update (“downdate”) yet. :roll_eyes:

Just to weigh in here. Those of us who had a smooth upgrade are watching silently.

Android 11 on Samsung Tab S5e tablet and Google Pixel 4a-5g phone.

Hub V2. Two Sengled bulbs, three Zigbee sensors, one Zigbee pocket socket, 30 Z-wave smart switches/dimmers, 10 Zigbee smart switches/dimmers, 7 virtual switches/dimmers.

It took a few days from beginning of the rollout before I got the update. When I got it, I had no issues on either device.

1 Like

Where are you seeing that limit? I have eight scenes on my Favorites screen on iOS 14.6 on an iPhone 11.

In the context of widgets… you can only assign 4 scenes to widgets now

I edited my post above to correct that

1 Like

FYI for others having problems with the latest update: After the update I suddenly found several devices had reverted back to their default names and I could not access them to change them back. I tried logging out and back in but the app just got stuck and never displayed any devices. So I uninstalled and reinstalled and voila! Everything seems to be working again.

Still frustrated with how slow this app is to load the status of everything. It is unusable for at least 30 seconds until it updates. Even if I just went out for less than a minute. When I return, it has to reload everything from scratch. Horrible.

Also, this new update where you can only see one room at a time is a pain. It was so much easier for me to get to a room quickly when all I had to do was scroll up and down. Why not provide one scree with all the rooms and let me go to a specific room if I want (like the Alexa app). Very poor design.