FAQ: Did we lose the ability to add custom smartapps after the app update of June 2021?

Did you click Publish → For Me?

Thank you for dealing with this idiot… that worked. Just bought a Pi and trying to set this all up. It is a little more of a challenge than I expected with SmartThings. Especially since ST just changed the app and all the instructions online deal with the old app. Thank you again.

1 Like

You guys saved me. Thanks for this!

1 Like

I was able to activate Developer Mode and see my legacy (Groovy) SmartApps, but my new SmartApp developed under the new process isn’t showing, even though it was previously installed and configured before this new ST app rolled out. If I select Add SmartApp from the menu, I can see my new SmartApp, but when I select it the window closes (takes me back to the Automations tab), and the app isn’t added. My new SmartApp is still working, but I can’t add it to the ST app so I can change the configuration options.

Anyone else having this issue or figured out a fix?

Which smartapp?

In the automations section, did you scroll tO the bottom of the screen? See your other smartapps there?

I do see all of my Groovy SmartApps, but not the new one I created. It’s a webhook SmartApp developed under the new process.

Tagging @nayelyz

Thanks, @jkp!
Make sure you deployed your SmartApp at the Developer Workspace, @JFry. It doesn’t appear in the list otherwise.

1 Like

It’s deployed to test. I was able to access it before the last update. The only reason I tried to access it was because my presence sensors (iPhones) stopped working and I wanted to update the config in the SmartApp in case the new app changed the device id of my phone.

Can you share a screen capture of the SmartApp catalog, please?
Select add (+) > Add SmartApp > go to the bottom part. That’s where the custom published/deployed SmartApps in your account appear, in the screen you shared above, only appear the installed ones.

The error is what I now get (as of the last 15 minutes) when I click it. Previously the Add SmartApp window would just close. Getting closer…

Ok, that means there’s something wrong with it:

  1. There’s a connection problem, it might be because the endpoint is down or the URL is wrong.
  2. There’s an error in your SmartApp, do you receive the requests from SmartThings?
    You should have verified the SmartApp before trying to install it, the following message should not appear:

The app is receiving events from ST as we speak…

The error message above pops up instantly when I click on it.

From the live logging…

Nothing shows in live logging when I click on it in Add SmartApp even though I get the error message. I don’t see it failing trying to talk to my app.

I see, ok, so this SmartApp was previously installed, right?

There are some inconsistencies with the SmartApps in the iOS devices, what you can do is:

  1. Try to open the SmartApp using an Android device (if it still fails, please send an email to build@smartthings.com with your SmartApp definition)
  2. Register the SmartApp as a SmartApp Connector, to do so, go to:

New Project > Device Integration > ST Cloud Connection > SmartApp Connector

You would have to install the SmartApp from add(+) > Device.

  1. You can delete the installed instance of the SmartApp using this endpoint of the API.

Looks like the latest SmartThings iOS update has fixed the issue.

I have the latest iOS update and it’s still not entirely working for me, but it does look like somebody is working on something. Or maybe it was something I did while trying to figure it out.

My app still isn’t listed under the installed SmartApps, but if I Add SmartApp, I now see my app listed twice (but only on my iPhone, not my iPad). One gives the same error the instant I click on it, but the other opens up the configuration page and lets me successfully save changes. However, it still doesn’t show in the installed SmartApps list after saving.

Hopefully someone is actively working on it and will have it fixed soon.

@nayelyz - Unfortunately I don’t have an android device, but I will try to borrow one this weekend.