New SmartThings App - No SmartApps

I have migrated from classic to the new app and none of my smartapps show up. I can click add smartapps and after I add I still have 0. I have reached out to smartthings support and they acknowledge its an IOS bug but give no ETA on a resolution. Had it been a bug I would assume others on IOS would have this same issue but I have so far only found a handful. I am curious how many others have this issue? Also has anyone figured out a resolution?

iOS bug… first time I have heard that.

Does your hub show in the device list?
Running a pi-hole on your home network?
Can you create new rooms?

Yes, my home shows on device list
no pi hole
I can create new rooms.

This video should help explain the problem.
I didn’t make it but that is the problem I am having. Found it over on an actiontiles support.

What apps are you missing?

There are some that were listed as Smartapps in the classic app but are listed in menu > settings > linked services in the new app.

I have a few in linked services but none in smartapps.
Apps I have in Classic SmartApps
Echo Speaks
Ecobee (Connect)
Lock User Management
Logitech Harmony (Connect)
Lowe Battery Monitor and Notification
Lutron Caseta (Connect)
MyQ Lite
Pool Controller
Rachio (Connect)
Simple Device Viewer
Smart Lighting
TP-Link SmartThings Manager
Vacation Lighting Director

New Smartthings “Linked Services”
Ecobee (Connect)
Lutron Caseta (Connect)
Rachio (Connect)
Bond Home

I have the same bug supposedly, with no eta. It only affects one of my locations. I have tried to have the ticket escalated and the rep keeps refusing since its a known bug. Gonna suck in a few weeks when classic goes away.

Oh thats interesting. How can an IOS bug only affect certain locations. Have you given any thought to the possibility of an existing smartapp that you have installed at one location and not the other causing an issue on samsung end? See my list above of all my smartapps.

Keep me posted on your progress.

I’ve seen this happen it usually due to a timeout, if you close the page and re-open it a few times they eventually show up.

However if clicked the “migrate” button in the Classic app then it may have broken something an only ST support can fix it.

rboy. I tried it about 10 times with no luck.

On a side note I contacted support and they implied it will not be fixed before the Oct 14th cut off. I think for me the big issue it I won’t be able to edit my webcore anymore since that is the only way I can get the browser registration code. I guess I can change it to never expire and login on every computer i own.

What’s the issue with running Pi Hole? I have one on my home network…

The pi-hole tends to block the installation or opening Smartapps in the new ST app for some. Whitelist on the pi-hole to solve that issue if you experience it

I did a search in the Pi-Hole Query Log for “” and cannot find any requests for that hostname at all.

UPDATE: In fact, I checked all requests from the ST hub and it hasn’t had any DNS requests blocked at all.

If all is working, then it does not affect you. I did say it only affects some users above. :slight_smile:

True, thanks.

Who knows… maybe it has been resolved. I haven’t seen it reported lately

Support keeps blaming it on me not being signed in with the owner account as this only happens for my parents house where I just have access to help them configure things. I continually have to sign out and in with their account, to prove to them it doesn’t matter what account I am signed in with. On my primary location (my house) it shows fine. It is a problem with the location, not the app. I have tried 5 different devices, uninstalled and reinstalled the app, logged out and back in, refreshed the page, used my login, as well as both my parents logins. Nothing works. They say it is a known bug, but they wont give any information on when it will be resolved. It sucks as in 10 days the classic app will no longer work, and that is the only way to edit existing smartapps currently. I really dont wont to move my parents to a new platform, but with the lack of information on when to expect it to be fixed, Im not sure what Im supposed to do. They told me the workaround is the classic app, which goes away in 10 days. Hell, they can’t even get my name right in reply emails, even though multiple times I have told them my name to correct them. @Brad_ST Ticket # 1024827

That is all very frustrating! I took a look and the mobile app logs we have are from August, can you submit a new set of logs? Force close the app, re-open the app, reproduce the issue, and then submit logs via “Report a problem” (Menu > select “Contact Us”/“Help” > select “Report a problem”).

Thanks Brad. I’m getting pretty frustrated . I went to go do this and now I can’t even see their location. I can see it in the classic app, but it doesn’t show in the new app. Pretty sure support did something to my account, I can still see both locations in the ide.

Hi there

I am all very new to Samsung ST and this community. So I still haven’t found a way to write to somebody directly - thought I’d try this way to contact you.

Is there any way that I can have the “Hello Home” smartapp installed. I haven’t found it in my installed smartapps section under “My location”

Thanks in advance :slight_smile:


Try installing smart lighting and create a rule that includes sunset and/or sunrise.

1 Like