Twinkly Christmas Lights

I’ve added a few minor changes to the smartapp to address this, and it now correctly adds the device and ensures it is assigned to the hub. Give it a try!

1 Like

Looks like that update did it, thank you so much.

1 Like

No worries, just happy to share something that helps others. Happy Holidays!

3 Likes

Hi. Thank you so much for creating this.
I have my gen2 lights connected to Alexa but I can’t see how to add them to ST. I’ve added the DH and the SA but how do physically add the lights ? I’ve tried a local search but not worked. Do I need to put the lights back into pairing mode ? I’ve feed the IP address in the SA but I can’t add the device.

I figured it out. The device name entered into the smart app has to match exactly as it is listed in the routers dhcp list.

Hi, I’ve updated the DH and SA, deleted the old device and created a new one (IP and Name accordingly with the name in the Twinkly APP), but when I open the device in ST it breaks/exit the app and in the log I see a “Invalid Token, returning L213, parse”, not sure if it’s related.

I came across this thread while doing some googling… Very new to IFTTT, but I was curious if I could use my Twinkly lights as a notification of sorts? Specifically thinking if when it snows, change the lights to the “Only Snow” effect.

@Jonathon_Bischof Hello, thank you for creating the DH and SA for this. I cannot get my Twinkly 100 (2nd Gen) to work though. I’ve set a static IP for the lights and tried entering the router’s DHCP name “Twinkly 100” and the Twinkly app name “Palm Tree” for the SA name. Both created a device, but neither worked.

Hi
Have same problem, add my lights but cant contol, mayby new FW dont work?

Anyone have it Rolling?
Have 2 icicle 2gen

Just added my 2 Twinkly lights without any problems even not using the DHCP names by:

  • Added the SmartApp (Dameon87/SmartThings/master) with the IP Address of the “first” light
  • Added the SmartApp (Dameon87/SmartThings/master) with the IP Address of the “other” light
  • Added the DH (Dameon87/SmartThings/master)
  • Added the 2 lights as devices
  • Added a virtual switch and added on/off automations to turn the 2 lights on/off as one device

And everythings works fine.

EDIT.
Also created some Automations to turn on the virtual switch (e.g., both my Twinkly’s) a sunset, turn it off at midnight, turn it on again at 6am and finally off at sunrise.

/Claus

2 Likes

Its suddenly starts to work,but baybe a little bugg,but i gonna try for some time.
I make no virtual.i control direktly by smart light

I’ve just tried - it’s in and working, but will have to try what automations work with it, next. Thanks for this!

@Jonathon_Bischof, thank you for taking this over I am glad the community won’t miss out.

If you find yourself stuck due to my implementation feel free to reach out and I will help where I can.

Sounds like this was working in Nov 2020, but I seem to be having some odd issues… Successfully created SmartApp and Device Handler, but had to manually create the device (new ST app doesn’t show the SmartApp)… The current status seems to update correctly, sometimes… and I can turn on/off, sometimes… It’s like it will work once then not work again for a number of hours… When it does successfully turn on/off, the status fails to update and a message appears saying “A network or server error occurred. Try again later.”

Anybody that was using this last year, still using it successfully?

Also, it doesn’t show up as a device I can share with WebCoRE :frowning:

Thanks,
Justin

In the ST app, go to the Automations section, click on the + in the upper right of the screen, choose add Routine, then click on the Discover tab at the top of the screen, scroll down to find custom smartapps. You may need to enable developer mode first which you can find in the following thread.

Look in capability group 1-3 when you go to add it to your instance of webcore.

ST app > your instance of webcore > settings > available devices > available devices > capability group 1-3

1 Like

I used this successfully last year and it was still working when I set my tree up in October (yeah I had a Halloween tree).

I started having problems around the first or 2nd week of November this year (2021). I think the problem is in the Twinkly side of things though. I have the exact same issue with Google Home which uses a Twinkly official account link. I even have problems with the Twinkly app if I’m not on my home network.

There was a firmware update around that time and I’m wondering if that’s really where the problem is.

1 Like

Wow… I don’t think I would have ever found that on my own lol Your instructions were perfect…

Also right on, I was able to add to “Which switches” within Capability Group 3. Thank you @jkp

I deleted the device I created manually and used the Twinkly Device Creator Smart App to create the device, but still same odd behavior. WebCoRE seems to have a 50/50 chance of turning on/off the tree. I haven’t tried connecting to Google Assistant.
Similar to @Sethaniel68, when I setup my tree this year it immediately had a firmware update… Another firmware update came down a few days ago (it’s now at version 2.8.3).

1 Like

I wanted to use the handler that @Jonathon_Bischof had improved however I found it super unreliably due to how it was using fixed delays to compensate for the delay in response times during the auth flow.

I’m still working on the code, but already just rewriting it to eliminate delays in favour of properly using callbacks makes it significantly more robust. I’ve also improved it to use a newer xled endpoint to get all the device information in one call instead of having to make separate calls for brightness and led mode.

You can just swap repos in your smartthings ide to mine and update to it and your devices, if you have any, will continue working with the newer code.

2 Likes

I agree! Works about 90% of the time for me now. Thank you @AndrewSmartThings for your work on this!

Thank you, Andrew. Your new code is working well for me.