FAQ: Common issues encountered migrating from a SmartThings to Samsung account (or: "Help! My hub/devices have disappeared!")


(jkp) #1

The issues

The following are some issues experienced by users after migrating from a SmartThings account to Samsung account or by users who have previously added Samsung Appliances and TVs to the Samsung app/account before they had migrated their SmartThings account. Note: Samsung can implement this migration without you realizing it. They don’t send a notification before or after the actual migration event.

  • Devices are missing in the Classic app.
  • Hub/Devices are missing in the Classic app and you are prompted for the Welcome Code to add the hub.
  • Devices do not appear when you login to the SmartThings (Samsung Connect) app (STSC).
  • Two duplicate locations in IDE and unable to delete the empty one.
  • Hub and most devices are in one Home Location and Samsung Appliances and TVs are in another.
  • Two or more locations with devices/hub/Automations being split in those locations (see important notice at bottom of this 1st post)

How to resolve?

#1) The following may help resolve missing hubs or devices

Classic app
option 1 - Sign out of the classic app, choose New to SmartThings when you login and enter your Samsung credentials.
option 2 - try changing the Home Location in the classic app.
option 3 - continue down to #2 below for removing duplicate Home Location.

STSC app
option 1 - try changing the Home Location in the app.
option 2 - continue down to #2 below for removing duplicate Home Location.

Below are links to instructions for how to Change your Home Location in both the Classic and STSC apps. Both are clickable links.

#2) The following instructions should help with deleting a duplicate Home Location that has nothing in it.

  • Login to IDE (with an incognito/private tab in your browser) at https://account.smartthings.com
  • Goto Locations
  • If you have multiple Locations, select the invalid one
  • Make sure there is no Hub associated to it
  • Scroll to the right and click Edit
  • If the Default Location shows “true” (will be read only)
  • If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  • Now you can edit/delete the additional Home location as it will automatically be set to “false”.

If you are unable to set default location to true, try the following suggestion:

#3) How to merge devices that are in two different Home Locations.

To move devices from one Location to another in the STSC app, you must move all devices from the initial Location to the new one, including the SmartThings Hub. The devices will continue to be connected to the SmartThings Hub. This may be useful if you decide to move your existing SmartThings Hub and devices to a Location that already has non-SmartThings devices connected to it, such as an appliance or a television.

  1. Tap on the Devices tab
  2. Tap the Location drop-down menu at the top of the screen
  3. Select your Location
  4. Tap the three dots in the top right
  5. Tap Edit
  6. Tap the three dots in the top right
  7. Tap Move all my devices
  8. Select the new Location
  9. Tap Move

The easiest solution may be to simply remove the devices and add them to the Home Location of your choice. That is If you only have 1 or 2 Samsung TVs or appliances, delete them and add them to the Home Location that has the majority of your devices and your hub.

If any of the above fails to resolve any of the issues, contact ST support at https://support.smartthings.com or post on the forum for assistance.


Important Notice - since February 17, 2019 there have been some users reporting the creation of multiple locations after opening the STSC app with the result of their hub, devices and Automations being separated in those locations. In this case, please open a ticket with ST support. None of the methods noted above will help you resolve this issue. Please note: Do not delete anything at this point but wait for Support to assist. Also, report this issue in the following thread and tag @Brad_ST
New app and multiple locations... is it possible?


V2 Hub disappeared from location after update
Smartthings Connect vs Classic. IDE Inconsistencies. Other Comm Issues
Two default locations?
New App PIECE OF JUNK!
SmartThings Hub Vanished
Nothing is working (Feb 2019)
New App PIECE OF JUNK!
Can't delete a location keeps giving error, any suggestions?
2 Locations in IDE/ Smarthings App
Support Non-responsive for weeks, hub unusable
Where do i get the code?
Samsung TV device added to wrong location
Does ActionTiles work with the ADT/SmartThings Hub?
[RELEASE] Lock Manager
Extra new Home location appeared in my account. Can't delete it
Tickets Ignored, Devices Unavailable, FRUSTRATING
Can't add new user to home
Migrating back to old app?
What the hell happened to the smart things app
What a mess, samsung! (February 2019)
Update wiped out everything
All devices stopped working - No Signature of Method
I opened the Samsung Connect app a MISTAKE
Account got signed off, Hubs cannot be re-added into smartthings
Ghost zigbee devices - can't remove them!
SmartThings Zigbee Device Firmware Updates - January 2019
Classic App Won’t Login
Hub and ALL Devices Gone?!?!
Access to graph-na04-useast2.api.smartthings.com was denied
[solved] Smartthings Classic App Welcome Code Not Working - Frustration
#2

Great work! :tada:

Your title was perfect to describe the cause of the condition. :man_health_worker:t4:

I added the parenthetical phrase to describe the typical symptom as well. :face_with_thermometer:


(R Scott) #3

Thanks, fixed my default location problem.


(jkp) #4

Tip for removing a duplicate Home Location if you are unable to set the default for #2 in first post.


#5

option 2 worked perfectly thanks


(William Brooks) #6

So, I mistakenly opened the new app (I have a Samsung phone so it is easy to accidentally open). Now all my devices are in the new location. All my SmartApps are in my old location. All my automations are in the old location. All my users are in the old location. The old (better) app shows both locations. The new app only shows the new location. I do not see a Location drop down on the devices tab. I am very angry right now. Any help would be great.


(Jimmy) #7

The location switcher in the new app is now in the upper left hamburger menu.


(jkp) #8

Can you login to IDE at https://account.smartthings.com go to My Locations and check to see if both locations have Smartapps and devices assigned to both locations or only one of them. If, by chance, one of the locations is empty - you can follow #2 in the first post of this thread.


#9

Does the just updated STSC app allow for merging devices across locations so that I can get down to one? I don’t see a device “tab”, and when I go into devices, it doesn’t seem to have a “Location” to select. Seems like those steps relate to the app as it was before the last update, or I’m lost.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #10

I don’t think so.

Why do you have stuff in more than one Location?


#11

Ask Samsung. Everything worked until last night.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #12

:cry: :confounded: :frowning_face: :poop:


#13

I suspect I’ll just be redoing all my automations and setups this weekend, and manually redoing the devices. I ended up with two homes, the one the devices except the Harmony and Ecobee and mobile device presenses along with all the automations, etc, and the other with the all the lights, sensors, and hub. So all the devices are in a “home” with no automations.

Also broke Google Home and Echo.

I must have been “migrated”.


New app and multiple locations... is it possible?
#14

I have a very similar situation.
After opening the new app, everything got messed up. My current status is as follows:
-About half of my devices AND my HUB have moved to a new location
-The other half of devices and all automations/apps stayed in original location.

So my questions are:
-With Classic app or IDE is there a way to move my HUB to the original location?
-With Classic app or IDE is there a way to move devices from one location to another?


New app and multiple locations... is it possible?
(jkp) #15

In the Classic app, is everything showing there?


#16

Yes, but split between two locations.


(jkp) #17

You will need to contact ST support at https://support.smartthings.com


#18

Problem is I emailed them two days ago now, and no response. By the time I’m home at night, they’re closed. Guess Saturday I’ll have to call, because after breaking my house setup, they seem to be unable to respond. I suspect it’s because they did this to a number of us.


(jkp) #19

I have added the following to my first post of this thread…

Important Notice - since February 17, 2019 there have been some users reporting the creation of multiple locations after opening the STSC app with the result of their hub, devices and Automations being separated in those locations. In this case, please open a ticket with ST support. None of the methods noted above will help you resolve this issue. Please note: Do not delete anything at this point but wait for Support to assist. Also, report this issue in the following thread and tag @Brad_ST

(New app and multiple locations... is it possible?)


#20

I just tried to call support, and was given a call back queue time of 2 hours, 41 minutes.

EDIT: After waiting 3 hours, the summary of my call was that I had to fix it all myself. They cannot move devices, automations, or the hubs into one consolidated location. I asked if there was any kind of master ticket or any tracking of this situation where some of our installs were broken this week, and he said there was not. I kept mentioning this thread, and even read him jkp’s last post about reporting to support.

Since I sent an email Thursday night and have still not had a response, and phone support was a waste of time, I assume I just have to bite the bullet and start deleting and re-adding devices into the new location, then redoing the automations that are not working.

I’m pretty put out that he didn’t even open a ticket to a higher level of support. He was nice, but those of us affected just seem screwed by Samsung’s software update.