[OBSOLETE] Jasco/GE Z-Wave Plus On/Off Switch (14291) With Double-Tap and Associations

I just created a DTH for the new GE Z-Wave Plus On/Off Switches.

Features included:

Option to change the indicator status from the main page
Commands to change the indicator status (useful for changing from CoRE)
Option to change the inverted setting from the main page
Commands to change the inverted setting (useful for changing from CoRE)
Ability to add associations to groups 2 and 3 from the configuration page
Exposes the double-tap feature of the switch as a button (useful for triggering events in CoRE)


Thank you for taking the time to write this.
I’ll be testing it out later tonight and will let you know how things go.

1 Like

Ok, i am seeing 1 error from time to time.

error groovy.lang.MissingMethodException: No signature of method: script14901161740411468655473.zwaveEvent() is applicable for argument types: (physicalgraph.zwave.commands.configurationv1.ConfigurationReport) values: [ConfigurationReport(configurationValue: [0], parameterNumber: 4, reserved11: 0, scaledConfigurationValue: 0, size: 1)]
Possible solutions: zwaveEvent(physicalgraph.zwave.commands.associationv2.AssociationReport), zwaveEvent(physicalgraph.zwave.commands.basicv1.BasicReport), zwaveEvent(physicalgraph.zwave.commands.basicv1.BasicSet), zwaveEvent(physicalgraph.zwave.commands.configurationv2.ConfigurationReport), zwaveEvent(physicalgraph.zwave.commands.crc16encapv1.Crc16Encap), zwaveEvent(physicalgraph.zwave.commands.manufacturerspecificv2.ManufacturerSpecificReport) @ line 116

I am pretty sure I found what was causing this, new code has been checked into GitHub.

I just updated the code on GitHub to include being able to add associations.

Thank you, I’m testing it out now, so far everything is looking good :grinning:

I have noticed one thing, the blue indicator light won’t toggle on at all.
I could be a problem with the switch its self, but i thought it was worth mentioning to you. To see if anyone else was able to get it to turn on.

I have been able to turn mine on. The tile in the lower left corner controls the behavior for the indicator (On when the switch is on, On when the switch is off, or Never on). I have tested all three settings. If you can’t get it working with my DTH you could try the standard one and see if it works.

Ok, I definitely think the blue led is broken on my switch. I tried your suggestion and changed the DTH to the standard one and its still not working.

Thank you.

1 Like

I just updated the code on GitHub. I think the code is final. Let me know if I missed anything.

Any idea if the double press functions are present in the non-plus model? I was wondering if this functionality could be backported.

It is not available in the non-plus version. In fact for the dimmer version of this switch there is an older firmware that doesn’t include the double tap. For the non-plus version of the switch you can use the smart-app Double Duty to get the double tap functionality although it isn’t 100% reliable. The non-plus version only has the “lifeline” association group 1 used to notify the hub of status changes but the plus version adds group 2 (that directly controls another device when the switch is turned on or off) and group 3 (that directly controls another device when the switch is double-tapped). This DTH adds the hub to the group 3 association group and then triggers the button press events when it gets the Basic Set commands from the switch.

1 Like

I just added one more small change to prevent adding the hub to an association group because doing so would break the double-tap feature.

Thanks for the detailed explanation. I’ll check out Double Duty.

Love this device handler, but did find one potential issue that drove me batty. I was able to convert existing devices just fine, but when I added a new GE z-wave plus switch, it would not pair. I finally noticed an error in the log. I had to delete your device handler, pair the device (actually had to exclude first because the pairing must have made it part way thru), and then re-add the handler to all my Z-Wave plus devices. Any ideas what is going on?


I am not sure. I have my one plus switch installed and linked to a complicated CoRE piston so I don’t want to remove it. I was planning to buy another one in a couple of weeks, I can order it earlier and do some troubleshooting with that one. Thanks for letting me know.

Nice device handler although I’m not completely understanding what is needed in group 2 or group 3. When you say hex format of the ID, you mean of the “Device Network ID”? Also how are you adding a core piston to yours? I have moving my pistons over to webcore and can see this DH being helpful with the double tap feature…


Actually, you wont lose the CoRE piston. Here is what I did:

  1. Modify the existing plus switches to the default Z-Wave Switch
  2. Delete your device handler
  3. Add any new z-wave plus switches
  4. Re-Add your device handler
  5. Update all z-wave plus devices to use your handler

All existing smart apps still work as expected. I didn’t have to delete those, so you wouldn’t have to delete the CoRE piston. I would just be nice to skip steps 1, 2 and 4. :slight_smile:

Does this mean a DTH to include double tap for the dimmer will be impossible? Do you think they will update the firmware?

The only GE Z-Wave Plus switch currently have is the one in the CoRE piston so when I remove the device to test adding it back I will mess up my piston. It did occur to me that I can possibly do some testing using the GE Z-Wave Plus dimmers that I have. I needed to place an order with Amazon today for something unrelated and was going to add a switch but they are currently out of stock. I will let you know if using the dimmers to test works out or not, if not I can order a switch direct from Jasco, but I prefer not to they are slow and don’t have free Prime shipping.