Why do the lights turn on so much faster with the add-on switch (GE)

I have multiple GE switches with add-on switches wired to them. When I turn the light on or off from the add-on switch it is just about instant. When doing it from the main GE switch there is a slight delay for the light to go on and off. WTH doesn’t make sense.

Also there is a slight difference in delay between the zigbee GE switches compared to the Zwave ones when operating from the main switch. Forgot which one is slower, not at home now.

What model numbers?

They have been some reports that on the very newest models, the 14 series, the fact that they allow for double tap means that the switch is slightly delayed in coming on because it is waiting to see if there will be a second tap. I don’t believe this capability is supported in the zigbee switches, so that would be one difference.

There are a lot of people using these switches in the following thread, so you might also ask the question there. A number of them have reported that the double tap will work from the add on when the master is a dimmer, but when the master is a binary on/off switch the add on is processing the first tap immediately and ignoring the second tap.

I’m experiencing the same issue with a 45856GE on/off switch – it takes ~half a second for the relay to flip once tapped. I understand this may be related to the double-tap feature, but it’s a major user experience downgrade relative to physical switches (especially if one is not using double taps!).

Does anyone know if there’s a way to turn this off? Or are there alternative in-wall switches (GE or non-GE) that are nearly-instantaneous?

Yes, I agree if you could disable the double tap feature to gain faster response that would be great

Anybody ever figure anything out here? I have the GE zigbee on/off switches and I HATE the 500ms delay. So much in fact that I stopped upgrading further switches until I find a solution, as I have no interest in that delay…

FTR, as for the double tap, maybe it has that function internally, but I don’t see it offered in the UI, and ergo nor am I using it. If it’s there, I’d love to disable it, like others said here…

Thanks for any advice anybody could offer.