[BETA][Edge Driver] Hue Dimmer Switch / Hue Wall Switch Module (No Hue Bridge)

I made a Edge Driver for “Hue Dimmer Switch”

This is a simplified port of my previous DTH.
[BETA] Hue Dimmer Switch DTH (No Hue bridge) rewritten - Devices & Integrations / Community Created Device Types - SmartThings Community


You can install the driver to your SmartThings Hub with the Invitation link that I’ve created.

Click Invitation Link → Enroll your ST hub → Goto Available Drivers → Install Hue Dimmer Switch driver → Pair your device

Also, I uploaded the source code of the Edge Driver to my github, for anyone who are interested.


  • Edge Driver is still in Beta. It could be unstable, especially with health check. This device don’t send periodic heartbeat packet, so it could be displayed as OFFLINE.

addendum>
I’ve added support for Hue Wall Switch module in this Edge Driver


For the Hue Wall Switch module, you can setup switch type from the settings as below.

12 Likes

Awesome, good stuff @iquix, really excited to see people start to put together drivers for various things. I’ll make sure to make a note with our product people to follow up and on automations and multi-component devices.

I bookmarked and may open a PR with a few suggested changes to make the code a bit more self-documenting (nothing really wrong with what you have, just making use of a few things that are available like constants for cluster IDs, etc.).

2 Likes

Installed and after few rounds of adding and deleting made it work. Thumps up.

1 Like

Thank you so much! I’m able to add it but it isn’t working: greyed out in app, not button press recognised. Any thoughts on what to do?

I have no idea.

If you can use Smartthings CLI and see the hub log, you can take a look and see what happens when you pair the device

Also, if you have previous version of DTH for this device in ST IDE, you might want to remove it before pairing.

Prior to pairing, I did delete the prior custom device handler. Tried multiple times since. The switch shows in the app (greyed out icon) and device list (no Zigbee Id, no Device Network Id, and Execution is ‘Cloud’). Something is wrong. Thoughts anyone?

I had problems at first too but after 3-4 attempts it showed correctly in ST and wotks fine. Couple times it showed as a Thing but after deleting an repairing it eventually worked. :thinking:

Thanks. Yet, I’ve removed and paired more than 10 times now, also using another Hue Dimmer Switch, just to make sure it’s not the device itself. The experience is that the switch is correctly recognised as such, but no actual connection is established. Perhaps something goes wrong during pairing and/or is faulty with the driver? Just leaving this here to describe symptoms as work continues …

What are you using to create the rule?

The edge drivers that I have tested, smoke detector, multipurpose sensor and switch, work well with automations and groovy-based SmartApp. Te switch work with quick controls.

A week ago I commented about it in this thread in case someone wanted to clarify or modify it to avoid misunderstandings.

The triple socket with multi-component driver in smart lighting only works the main switch (endpoint 1).
With automation all 3 plugs work, well as local

2 Likes

Sorry, not sure what you mean by rule. I have not been able to create any rule or automation with the Hue Dimmer Switch yet. I manage to somehow pair the Hue Dimmer Switch using the edge driver, but in the app the switch icon remaines greyed out, and trying to create an automation does not allow me proceed to ‘done’. In the IDE the switch does not show a Zigbee Id or Device Network Id.

1 Like

You shouldn’t expect it to. The IDE is part of the legacy ecosystem built around Groovy Device Type Handlers. It only has limited understanding of integrations built for the current ecosystem.

1 Like

Thanks. I see. Still, how may I get the switch to work?

@iquix
Hi thank for your driver .
Does it support both version of hue dimmer ?

1 Like

Actually there are 3 different fingerprints of Hue Dimmer Switch in my driver.

2 Likes

Hello,

I seem to have gotten the driver and ST to recognize the remote but the only functions I can seem to use successfully is “pressed” and “hold”.

Is that expected or am I having an issue?

Thanks for doing this!

“pressed” and “held” are events that are supported in this device.

There’s a bug in SmartThings app (,not the drivers or DTHs) that it incorrectly shows unsupported button events in device detail view. I’ve reported this bug to Samsung.

2 Likes

@iquix

Thanks for the edge driver, it works well when I pair the remote for the first time and then a few hours later it doesn’t seem to send any commands to the hub.

It flashes the red led when I press any button and does not resolve it self until I remove device and then add device anew.

I can confirm it is not a signal issue as it pair’s successfully and works well at first. I even added a zigbee repeater close by in case its its that, but it is unlikely!

Any thoughts on this possible bug?

Also, when pressing the driver button under device settings, it doesn’t have any support information, maybe a link to this thread would be easy for people to provide feedback and/or issues?

1 Like

I’m not sure what causes the problem.

It must be something related to the zigbee communication problem, which is the lower level thing than the DTH or Edge Drivers can manipulate.

Maybe, some compatibility issue about the hue dimmer switch and repeaters? I’m not sure though…
(Something like this… Aqara repeaters or some old ZLL bulbs are generally known to make troubles with SmartThings zigbee mesh network)

1 Like

Thanks for the response. It’s is unlikely to be a problem with repeater, as I have tried with and without. I am using an IKEA Repeater.

Anybidy else experiencing the same problem?

I will have to re-pair via Hue Bridge to get this working…

@posborne
Hopefully, some support from Smartthings team might help…