EcoSmart Zigbee Remote

No it’s stock SmartThings DTH. All 4 buttons now showing additional Hold and Double Pressed capabilities. Use to be just pressed capability.
Responsivnes is back, it shows that button is pressed, but other issues are still there.

This screenshot is from device that i didn’t change anything, just loaded details page, and it still shows assigned automations.

Now, on new device i can’t assign automations to buttons 2, 3 and 4.

All my automations use to be assigned with Fast Automations from details page. Now, if I try to add Fast Automations to any other button besides button #1, they are jot appearing under thise buttons. They will show up under button number #1.

I have tried to assign them through Routines page, and that works. And only preesed action is available as use to be.


2 Likes

Ok, that’s caused by an issue that is already reported. It seems the supportedButtonValues property is ignored in the Detail View.

@SamsungZell, could you help us check the issue with the “fast automation” in the app described by @milandjurovic71, please?

Ok, you should use that for now so the device keeps working as it used to while the team checks this issue.

2 Likes

@nayelyz thank you for responding.

Can you maybe list a couple of current staff members, that we can work directly with for different issues.
For example for Edge driver issues, or for old Groovy issues, or Linked Services, or for devices supported by SmartThings. I have found that many times issues are solved much faster than calling support.

We are in direct communication with our internal staff to check on your issues, if you find there’s a delay in solving them, please notice that it may be due to the prioritization and current workload of our team as they are all constantly working to build more cool features for you. Please remember also, that you caught us in the middle of a holiday (Happy Thanksgiving!)
For development issues, you can contact me, @erickv, or @andresg or send an email to build@smartthings.com as well.
For ST app-related issues, you can tag @SamsungZell or send an email to the ST Customer Support of your region (Go to https://www.smartthings.com/ and click on “Support”)

We can guide you if you don’t know exactly what kind of issue you’re facing.

3 Likes

Hey there! @milandjurovic71, I’m sorry to hear that you’re having issues with the device tile and it displaying additional capabilities other than the desired ‘pressed’ to execute your Automation Routines.

Just to confirm your symptoms by ‘fast automations’, do you mean Automation Routines directly from the device tile>routines tab>+ that do not display correct capabilities on the device tile, adding the options for hold and double pressed?

I’ve been testing and I’m not having the symptom appear with the additional capabilities, which may mean I’m having trouble replicating the issue and we need to isolate it further. I was able to add the Automation routine from the device tile and the automation routine tab. See the below screenshot

Other than recommending removing and re-adding the device to see if functionality returns to normal, I’d say If you have not already, I’d recommend creating a support ticket so we can look into your symptom further.

You can reach out directly to a support team in your area using the below information:

US: 1-866-813-2404
US: support@smartthings.com
UK support 0333 0000333
UK: support@smartthings.co.uk
CA: support@smartthings.ca

I hope this message finds you well!

^SamsungZell

@SamsungZell and @nayelyz

Marking this post as solved does not solve the problem

Sorry for not responding in timely manner, as I was busy with my work.
Here is the issue that is happening all over, and it can be found in a lot treads.
Many button devices (remotes, switches with button capabilities) are showing more capabilities than they have.

My examples are

  1. EcoSmart remote with only Pressed capability, shows Pressed, Double Pressed, and Held capabilities.
    It should be like this

But now with all added capabilities looks like this

Assigning Actions on device details pages is not working correctly, as I stated. When I assign action to the 1st Button’s Pressed capability, it does save it correctly

When I try to assign Actions on device’s details page to other buttons (2, 3, and 4), it shows them under button #1 in other button’s capabilities.

It is the same behavior described in another @Trakker2 users post

  1. Now when I checked another brand remote it that has 4 buttons with only Pressed and Held Capabilities, that one shows more then dozen (19) capabilities for each button.

@SamsungZell You are telling me to remove and re-add devices (which I have more than a dozen), and to loose all Automations doing that. I have removed only one , and added back, and added more, but they all behave the same.
3. I have looked at another Zooz Switch Scene Controller with 4 buttons, and they all have same problem, added all possible button 19 capabilities, as shown bellow, for just one button


Post from another tread by @blueyetisoftware list same problem

Only thing that comes to my mind that I might have this problem is that as I am testing Edge drivers, that I have driver with button capabilities loaded on my hub, that creates conflict with all other DTH Groovy devices.
Otherwise Smartthings have this problem all over, and it needs to fix this asap.

How many more users need to post about the exactly same problem, to be looked at?

2 Likes

It seems the same problem that the fibaro KeyFob has with the stock beta driver edge zwave button

@nayelyz @SamsungZell
Looks like the latest app update fixed the issue with multiple capabilities showing for button devices:


Also button’s actions are working correctly now.
They are showing at assigned button.

@nayelyz
Only me being picky, I would ask that current edge driver for zigbee remotes, to be updated to have buttons and battery in correct order, battery should be always on the bottom, as we talked some time ago.

It is possible as edge driver for Hue Remote, created by one of the devs, has everything in right order:

If Samsung developer needs to look at the code, here is the link to the Hue driver, where there is a link to the GitHub

2 Likes

My fibaro keyfob button still shows 22 actions for each of the 6 buttons instead of 5 for each of the 6 buttons

@Mariano_Colmenarejo Did you update the app to the latest version?

Yes, updated yerterday.
Driver Change performed and memory cache cleared

1 Like

The new app update had eliminated the long list of unusable button options for me.

4 Likes

Bumping this old thread…
I had been using the DTH for my ecosmart remote, which was showing as cloud executed.
I tried switching the driver to ‘Zigbee Button’ so that it would execute locally.
This “sort of worked”; the device still shows as having four buttons, but I can only get the first one to work. Pressing buttons 2-4 seems to have no effect.
Did this happen to anyone else?
(I’d also like to try the edge driver, but I’m not sure it’s enabled yet; see Hub Connected Devices Now Use Edge Drivers - #89 by jamclam)

I’ve been using this edge driver with the ecosmart remotes for a while now and it works great. It doesn’t support the group binding that this driver was developed to support but all the buttons work.

1 Like

@Terri_Baker as the group functionality doesn’t work for you, you may as well use the official Samsung ZigBee button edge driver that my driver is based upon

I couldn’t ever get it to work correctly.

I’m still playing with group options in your driver, just haven’t had time recently

1 Like

I’m not sure they work for your remote, I don’t have one to test myself, and another user reported they don’t work

Figured I’d put this here…

So, I’ve been playing catch-up, realizing my Ecosmart remotes will soon need an alternative to webcore.

So, for now, I just took out the device specific (fingerprint) info from the custom DTH I’ve been using, so I can still use that handler without Smartthings defaulting to it upon pairing. This allowed me to have the Edge driver option for testing one remote while keeping my existing remotes on the custom DTH, for now. Maybe no one else would have that problem, anyway, but…

I know the official Edge Zigbee button driver has the Ecosmart remote fingerprint and that is apparently the only that does, but being that buttons 2 and 3 support “held”, I’m curious how they may be made workable with the Edge driver.

I’ve not got to the point of understanding how to use/edit custom edge drivers, but am working on it.

WOW! Thanks @milandjurovic71
I got the EcoSmart 4 button remote to work.

I deleted the device from the app
I clicked the large “+” and selected “Add a device”
I chose “Select from list of devices” and selected “SmartThings”
Then I selected Remote/Button
It showed a screen the single SmartThings button and I clicked “Start”
I used a straight pin to push the reset pin thru the hole in the battery cover

It added the device defaulting the name to EcoSmart Remote Control.
I clicked the device tile/icon to get to the settings:
There are five groups - Main, Button1, Button2, Button3, Button4
I did not assign any action to Main
I set up the other four actions and backed out of the setup.

They all work perfectly!!
I did the same with my other remote as well.

The “Driver” screen shows it as Zigbee Button with SmartThings as the developer.
The Groovy IDE shows the Type as placeholder like the Edge driver devices.

5 Likes

I love these remotes. I have 5 of them, got them for like $4 a piece + bulb, unreal deal back in the day. Hope nothing changes with their functionality with the groovy changes.