Leviton makes a 2 button/2 relay switch that works differently than SmartThings expects. Each button associates as a separate Z-Wave switch (theres a remote control that is also associated, but It seems to be less useful). The switches respond to SmartThings commands as you would expect, but pressing the physical buttons does not send standard on-off commands. Instead it sends scene commands.

I created a device type that interprets these scene commands as state changes so the buttons work like instant status updates.

The device type is available here:

1 Like

Very cool. Hopefully @alex_hawkinson will check this out as I know he has a lot of the Leviton devices in his house.

Hi Brian,

I also have this Leviton VRCS2 device - but it only recognized the scene controller - how did you do to make the hub recognize the 2 switches separately?


There is another post: Vizia rf+ VRCS2-MR 2-Button Controller that talks about the process of pairing. I have to say, I’m not sure if the steps there worked for me, I kept trying different combinations of long and short holding, resetting to factory, etc. I know at one point I had 8 or so ”remotes”. And then, magically, the switches paired properly.

When it did work, the switches reacted exactly like they do when you do a 5 second hold based on the instructions on that post, they just worked that time instead of giving me another controller. It may be that my switch may have not been reset from being paired at the factory. I wish I could give you a more informed response, but when I finally got it paired, I didn’t want to clear it out and try again…

Thanks a lot! Now I have them working and changed their device to your Device Type - there are two things still scrambled:

(1) The green leds are not behaving normally - one button turns the led on when the light is on and turns the led off when the light is off, the other button led is always on, no matter what happens with the button (physically or logically);

(2) The status on the Things dashboard is not being updated unless I force a refresh;

Hmm… in graph.api.smartthings.com check the devices and list the events. Check if anything is coming in when you press the button, it should say that it is seeing a switch on/off event. If there is a “zwave event” let me know what it says.

The button that stays on, does it click when you press it?

Thanks for writing this Device Type!

I’ve been trying to get my VRCS2 to work with ST, but so far, while I can control the loads from the ST app, the physical buttons no longer work, except to turn OFF the switch (e.g. if I turn them on via ST, and then turn them off via the physical buttons).

The logs seem consistent with the physical buttons only sending “off” events:
zw device: 36, command: 2C03, payload: 00 00 FF

The LEDs stay on all of the time

Any ideas what might be going on?

The VRCS2 is finicky in their pairing so you might want to try to unpair/repair it.

Well… I was going to point you to another discussion of how to reset and pair but it looks like you already made it there and got everything working. You even documented the process of pairing, hopefully that process works, I’ve been hesitant to unpaid my switch since it was such a pain to get it to pair in the first place.

Here’s a link if anyone stumbles across this again.

Thanks @david_daniel_cox for figuring this out.

Sincere thanks for the code, Brian. This was truly a learning experience for me. Using this great community, I was able to get my devices paired (key for me was to get the buttons blinking before starting the Connect New Device process on ST). I am grateful to everyone for the detailed explanations. My one hang up was that the button status was not updating on the ST app, if I hit them manually. Your code fixed that last piece! Very happy to have these working.

Now, if I could only get rid of the 3 "Z-Wave Remote"s I have listed on my Things. Force deleting not working…

1 Like

Has anyone got this custom device type to work on a Hub v2? I remember installing this custom device type awhile ago and it was working. I can’t remember if it was before or after I moved to the Hub v2 in September. I had a defective Hub v2 and just re-paired all my devices to my new Hub v2 and now I can’t get this custom device type to work. The Leviton switches are working if I trigger them in the SmartThings app and they work locally, but when I trigger them locally it’s not sending the on command to the Hub.

I just purchased this 2 button switch to work with a smartthings 2 hub and managed to get each button recognized and changed the device controller to your published one and now buttons turn on/off and smartthings app displays the status, but sometimes needs a refresh of the app to do so. When smartthings turns the device on and off, the led indicator lights on the switch buttons react accordingly, and turn on when on and turn off when off as expected. However there is still one issue. When the device is switched on via the physical switch button and switched off via smartthings app, the led light on the switch remains on and the switch button itself requires a double touch to turn the device on again via the physical switch. Any ideas?

Hi! Im looking for something like this. Is it reliable? Also, if Indont conect them directly to the lights, can I use them as scene buttons?

My idea is to control one light fron my room I dont have direct line routed to my room. But I have another smsrt switch tbat does.


I never saw this device type and have been using the basic SmartThings Z-Wave switch device type for each of the two loads, for quite a while (1.5 years at least).

Your description describes exactly my current behavior which I have just gotten used to over the time frame. >90% of my uses are automated and not locally done so the LED light loosing status and having to be double pressed is rarely a concern.

Basically, I’m wondering if this device type is still providing any benefit over the standard switch device type. Sounds like it may not be.

Im updating this thread so I don’t forget again, but if you set the scene controller device to Z-Wave Device Multichannel and the 2 buttons to Z-Wave Switch this device works great and seams to stay in sync. No custom device needed.

1 Like