Vizia rf+ VRCS2-MR 2-Button Controller


(Aamann) #1

I just bought this Z-Wave 2-Button Controller/Switch and was able to successfully pair it with my SmartThings hub. However, this is about the extent of what I can do with it. It shows up in ST as a remote but I can’t do anything with it. How would I properly set this up so that I can control the two lights attached to it using the ST app as well as the physical buttons on the device?


In-Wall, Two Switch Replacement options
Leviton VRCS2
Dual Switch Solution
4 Smart bulbs in one fixture - control as one?
Switch won't detect a double tap?
Smoke Detectors (UK)
Programmable In-Wall Light Switch for 2 Devices
#2

I got one yesterday as well. The “controller” is a device, and the two switches are paired individually as devices. Look at page 2, step 8 of the instructions. Sounds like you did step C, but not the other steps to include the 2 buttons?

You don’t need the switch to act as a remote because that’s what ST really does for you. You really only need to go into Include mode in the ST app, and do step D for both buttons. I’m installing mine tomorrow, and that’s what I plan on doing - just the buttons, not the controller in step C:

http://www.zwaveproducts.com/layout/manuals/vrsc2m.pdf

Hope that helps, and if I run into any problems tomorrow I’ll post back to this thread.


(Aamann) #3

Interesting - the instructions you linked are different from what I found and what was included with my switch:

http://www.leviton.com/OA_HTML/ibcGetAttachment.jsp?cItemId=wN.UeILDZm8z5teI899pJQ&label=IBE&appName=IBE&minisite=10251

My instructions threw me for a loop since they talked about the “center button” when adding switch 1 - I assumed that meant the center button in the remote (which I don’t have) so I didn’t continue there. Reading that the next step talked about button 2 I realized this might have been a typo…

So - I removed the controller form my ST hub and Z-Wave network and started again from scratch:

  1. move the ST hub right next to the switch (I was using internet sharing on my laptop to be able to do this)
  2. in the ST app, adda new “thing”
  3. press and hold both buttons on the controller until they turn amber
  4. wait…
  5. eventually the ST app will discover the device (it will be the remote - I don’t think it is possible to add the switches without adding the remote first) - name it whatever you want and then select the “Add more devices…” entry (not finished!)
  6. press the top button on the controller (or, in my case, the bottom button since I installed it upside down :wink: - I’m not sure whether this is required and whether this should be a short tap, long tap, or tap & hold. I tapped a couple times and eventually the ST app discovered a new device (Z-wave switch)
  7. select the “Add more…” entry again and repeat step 6) with the other button

Things are now working as expected - both buttons control the lights and I can control them from the ST app as well. Unfortunately it seems like there now always is a green LED on the two buttons (which was not there before I had completed all this setup). Changing the indicator light settings in the ST app doesn’t seem to make a difference here (I personally don’t like those indicator lights to be on ever but have to come to terms that this doesn’t seem possible for some - the GE dimmer switches don’t seem to honor the “never lit” setting either for me…)


#4

I got the same results as you, except status doesn’t update quickly at all. I’m also having the same behavior with the LED “lit when off” setting is ignored. Perhaps only the remote can tweak that?


(Aamann) #5

Yes - status updates are extremely slow for me as well. The LEDs are “lit when on” for me (which is what I prefer if “never lit” does not work as I prefer it to be dark in the room after turning off the light).


#6

It also included a zwave remote in my Things that does nothing, just like yours. I wonder what would happen if I deleted it from ST but not exclude it, and if the buttons would still work.


(Aamann) #7

I decided to give it a try last night and deleted the remote from the ST app (in the “Things” section, delta it and do the “force delete” without putting the remote into unpairing mode). The remote is now gone from ST and control via both, the ST app and the physical buttons still works.


#8

Thanks aamann, you’ve been very helpful. I’m going to do that right now as well.


(Gorgas) #9

Some clarity on the pairing process after some trial and error:

Pairing:

  • Push and HOLD the top button for 5 seconds - The LED will go amber - Now you can pair it with your hub. It should show up as a “z-wave switch”

  • Push and HOLD the lower button to repeat the above pairing for it.

  • Push and HOLD BOTH buttons for 5 seconds and you can pair it for the “remote mode”. I haven’t found a use for this yet with Smartthings.

Reset:

  • Push and HOLD BOTH buttons for 15 seconds and both LEDs will blink red. That’s a factory / pairing reset.

UPNP vs Controller Shift
(David Cox) #10

I just did battle with my VRCS2-MRZ 2-button controller and thought I’d share in excruciating detail what I think I did to make it work.

0) I think the ST hub needs to be super-close (~1ft) to the light switch to make anything work. Super convenient, right?

1) reset the VRCS2 by holding down button for 15 seconds. The lights will flash red, and then the switches will behave as ordinary dumb switches.

2) Exclude from a pre-existing network (a Vera, in my case), if necessary:

a) go to the “General Device Exclusion” option in the ST settings on your phone

b) exclude the individual switch “devices” one at a time. You need to hold down the button until it turns amber. If its working, when you release the button, it will blink for a bit. Wait some more. Hopefully the ST will then report that the exclusion is complete. Restart the exclusion mode on the ST app, and do the same for the other button.

c) now you still need to exclude the “controller” device (whatever that means…). Back into exclusion mode, and hold down both buttons until they blink amber. Again, if they don’t blink after you release, then it probably isn’t going to work. Wait and wait some more. If you’re lucky, the ST app will report that it is excluded.

3) Pair the “controller” device to the ST hub.

a) Press the big plus sign on the “Things” page and select “Add new device”. Then the SmartThings logo will begin spinning (does anyone else find it interesting that the logo of the company is a “wait” spinner?)

b) press and hold both buttons for ~10 seconds. I found that when it worked, two device were reported as being added, one in the middle of the long press and one that seemed to coincide with releasing the button. At this point, you can leave the “searching for devices” screen (e.g. back button on Android). The one/two added devices are bogus “remote control” objects that have no obvious value. Perhaps they are decoys to distract non-believers? Don’t worry about these, we’ll delete them late.

c) At this point, if the last step worked correctly, both lights should be green and the buttons will no longer control the loads (/lights). This is a good thing. Now it is time to add the first button. Press the big plus again to get the ST searching, and press and HOLD one of the buttons for ~7 seconds. It should turn amber and start blinking when you release. If it is blinking, the ST app should eventually report that it added another device. Leave the “searching for devices” screen again.

d) Repeat the last step for the other button.

4) if the lights are blinking red at this point, an animal sacrifice will be required. I bit the head off of a live bat, and that seemed to appease the dark spirits residing within the VRCS2-MRZ. Your mileage may vary.

5) Hopefully those last two devices added as switches rather than remote controls. If not, start over. If they are switches, they might even work. Huzzah. Drink a stiff drink to celebrate. I recommend single malt scotch. Bourbon might also work in a pinch. Curse SmartThings. Curse Leviton. Curse whatever awful group-think committee created the Z-wave protocol. Ah, catharsis.

6) Cleanup. I found that I could just delete the vestigial “remote control” things via the ST app. An hour later without the useless items, and everything seems to be working. Fingers crossed!

Yay, internet of things! IoT4eva! It’s so easy!


Leviton VRCS2-MRZ Device Type and inclusion
(David Cox) #11

Ah f***-it. Now it mysteriously stopped working again. The buttons sometimes work, but much of the time the on/off commands seem to “bunch up” and execute all at once some random number of minutes later.


(David Cox) #12

I’ve since figured out to reliably pair these devices – the key thing seems to be to keep the hub very close and to start the amber LED blink for each device (the controller / both buttons, the top switch, and the bottom switch) BEFORE starting the inclusion process from your mobile phone. When I do this, the 3 devices include correctly every time.

Unfortunately, while ST is able to reliably turn on and off the loads, I can’t get the physical buttons to work at the same time. Back on my Vera, it required associating the buttons (which are really a scene controller) with the switches/relays. Unforunately, the controller object on SmartThings doesn’t seem to work at all. I’ve tried Brian Dahlem’s custom device (as well as puttering around modifying it, but I haven’t been able to get it to work.

Worse, I’ve corresponded with SmartThings, and their response was basically that we are S.O.L. because they don’t support this device and don’t apparently have any plans to anytime soon…


(Jen S) #13

That IS disappointing.
These are great devices when they are working properly. Are you trying to get them to control remote devices or are you using the direct connection only or some combo thereof? I’m wondering if you could get the buttons to work as controllers with the Aeon minimote? I was able to use the Mote to set associations on an Evolve switch controller in another room, but my VRCS2 is not controlling anything other than directly wired lights so the Mote has nothing to “program”.


(Jen S) #14

The first time i included my VRCS2 into my ST network and added the buttons etc. then changed the device type to the custom device code (after sacrificing the bat) the physical buttons no longer worked. I too have faced this aggravating behavior with Vera inclusions/fails. Aaagh! (Bangs head against switch).
Not only did the switches stop working physically, they wouldn’t turn on/off via ST either.
I reset the controller to factory default but did NOT exclude it from ST - just re-included it and deleted the previous attempts from ST’s device list.

AND…the physical buttons PLUS the virtual ones are working.

WEIRD.

I’ll update in a while as to whether they continue to work. With the second attempt at including the controller I did not change the buttons to the custom device type as written by another helpful ST person but left them as the default switch.


(David Cox) #15

Agreed, this was a lovely device under Vera.

I’d be content if the switches just controlled the corresponding local loads while being able to also control the loads from ST. The moment I include the scene controller part of the VRCS2 in the network, the buttons stop controlling the local loads properly. The LEDs are also stuck on at that point.

Looking at the events coming through, it looks like the buttons do emit “off” events (and they can even turn off the loads if they are turned on first from ST). I am not able to get the loads to turn on with the physical buttons.


(David Cox) #16

I just tried the factory-reset-but-don’t-exclude-then-include-again maneuver, but no joy for me. Exactly the same behavior as before. Sigh.


(Jen S) #17

It would be great if the inclusion behavior was predictable and repeatable.
I’m sorry it didn’t work for you- you re-included the buttons again as well right?

I should mention that I had to do the old mains shut-off trick too at some point in this process (before 1st pairing) as it wouldn’t reset initially. Also typical.

Oh- and I factory reset each button before 2nd inclusion too. I’d try repeating the process but I’m afraid to touch it since it appears to be working…It will likely blow up in my face at some point in the future anyway and I’ll get to try it again! :smiley:


(David Cox) #18

Thanks for the added info! Yeah, I added the buttons again. Did you delete the old devices before or after you re-included? Also, you said you reset each button – how did you do that? I’ve only been able to get blinking red by holding down both devices at once.

I’ve been wondering if there are different rev’s of the device in the wild, given the diversity of different people’s experiences.


(Jen S) #19

If I hold down the individual buttons themselves they will also flash red. I don’t honestly know if it is any different from holding both down together- but when you are desperate…
I deleted the old buttons after I re-added the device. Didn’t affect anything as far as I can tell.

My VRCS2-MRZ was installed in 2011. And as far as I know it has not been firmware upgraded (if this is even possible), unless it happened behind the scenes at some point. I have a Leviton control stick that I used frequently when I couldn’t get Vera to program the Lev devices the way I wanted so, maybe?

That, however, is another really long story!


(David Cox) #20

In case anyone else is reading this, and it’s helpful, here’s some additional corroborating evidence that there exists a mode where the VRCS2 loads are included, but the original “factory default” button->load association persists: here are the instructions for getting this behavior on a Vera: http://forum.micasaverde.com/index.php?topic=23497.0

The Vera also knows about scene controllers (SmartThings does not), so there is another method for getting things to work where you associate the scene controller buttons with the loads via the Vera controller (http://forum.micasaverde.com/index.php/topic,13251.0.html). The reason that even Vera people want the direct association is that it is faster to respond and works even if the Vera controller flakes out. For SmartThings, at least with the current level of software support, preserving the “factory” association would be the only way to get the buttons to do anything useful, and it sounds like @jensed did manage to get it to work this way… somehow.

It is unclear if SmartThings has the right degrees of freedom to accomplish this inclusion process in a deterministic way (even on Vera it appears to be partly stochastic). From the Vera forums, it seems that the critical thing is to not let the Vera “configure” the controller portion of the device. Interestingly, SmartThings shows an option to “tap to configure” the controller after you include it, and its possible to skip this step (at which point it shows up in a list of “Yet to Configure” devices). Unfortunately, for me at least, skipping this “configuration” step didn’t change anything, but I did go so far as to cut the circuit breaker (as in the Vera instructions) yet.

In general, I wish there was greater clarity about what happens during a “configuration” (and also, exactly what state changes during an exclusion, inclusion, etc.). I get the impression that the whole stack is full of leaky abstractions and weird corner cases where past configurations persist in spite of resets, exclusions, etc. I feel like I don’t have an accurate internal model of the Z-Wave stack that enables me to understand why tripping breakers at those stages would make a difference. If anyone knows about decent Z-Wave documentation, I’d love to understand it better.