Leviton VRCS2-MRZ Device Type and inclusion


(Joshua Thompson) #1

Hello All,

I have successfully included my Leviton VRCS2-MRZ which functions fine for turning on my light manually, however when I include it into smartthings it doesn’t work. Smartthings sees it as a “z-wave remote” and I cant do anything with it. Also, after it’s paired with smartthings, the switches do not work until I exclude it.


3 Way Switch Help (GE 12722)
(Joshua Thompson) #2

One more thing: I tried this device type: https://github.com/bdahlem/device-type.VRCS2
When I switched it to that device type it showed as a single switch, however it still didn’t control either light and the switches didn’t work manually.


(Dale C) #3

It seems this switch has a history of pairing challenges.

But I’m reaching out to a member that I believe has one of these that has successfully paired it in the past

@johnconstantelo Can you give any guidance?

UPDATE: :anguished:
found another post from @johnconstantelo and he wants to replace his Leviton


(Dale C) #4

Check out these two posts for some steps to try. That whole thread is interesting but this post and the one above seem to have steps that work


(Joshua Thompson) #5

This is it! The only thing I am unable to do is remove the “z-wave remote”. I am not sure what he means by “9) Delete the “remote” from the ST app by going into preferences and deleting it. ST doesn’t support scene controllers anyways, so this is a useless entry.”

Can I just delete it from the IDE? (Edit: The answer is yes, I’m all set!)


#6

@jt114881 and @dalec,

I’ve actually begun to like this device and did not replace it. In fact, bringing the hub right up to the device for pairing works perfectly. I’ve done it several times since that post, and I’d have to retract my original statement about replacing it.

Please note: I did NOT remove the remote that gets added, and I do not recommend you do that, especially just deleting it from the IDE. The problem you have now is your zwave mesh still thinks the remote device still exists and since it had a valid Device ID, you could be trying to route through a nonexistent device. That will cause you performance problems.

I use to delete the remote, and once I learned more about zwave mesh networking I stopped doing that (including deleting any zwave device from the IDE). If I were you I’d start over and just stick the remote is some obscure Room, or just not put it in any room. That’s what I did, and have had practically zero problems with that device ever since.


(Dale C) #7

So what is the best way to recover from a deletion of a Zwave device using IDE so that there isn’t a ghost device with a valid device ID?


#8

Hi @dalec,

I’ve done 2 things, with varied success rates. I will tell you that I have an open ticket with ST regarding ghost devices, and there seems to be a problem on their end. Here’s the last thing I was told:

I was finally able to speak with our development team regarding these devices.
The unfortunate news is that we do not currently have a solution, but we are working hard with a few parties to get this resolved. It turns out that this issue has pretty high visibility.

Let me know if you have any questions, I personally really appreciate your patience.

I would suggest contacting support with the ghost device’s ID and see if they can nuke it. Sometimes that does work.

I have also been successful by manually creating a device via the IDE, using the ghost device’s ID, and using the device type of zwave switch. Once created, I use the app to find the manually created device, and then I Removed it via the app. Since it won’t find the physical device, just force delete it.


(Joshua Thompson) #9

I have ghost devices from some other devices and support has been unable to remove. How long has this issue been happening?


#10

I very, very, long time…


(Joshua Thompson) #11

I tried doing this and the device doesn’t delete even with a force delete. :frowning: