IFTTT and SmartThings (UK accounts)

oauth

(Chris) #1

I’ve received my Hub V2 today and had a little play around so far. But unfortunately it doesn’t seem like it’s working from the UK for the IFTTT - SmartThings channel. When I try to connect the channel it takes me to the the oauth page to login from smarthings. - https://graph.api.smartthings.com/login/auth it allows me to login but when it provides me with a dropdown to select my “location” the dropdown is empty, the other links in the header menu either link to the UK/Europe URL mentioned below or show No hub/device/apps etc connected.

From what I can tell there are two URL’s one for the US - graph.api.smartthings.com and one for the UK/Europe - graph-eu01-euwest1.api.smartthings.com. I’ve tried changing the URL to https://graph-eu01-euwest1.api.smartthings.com/login/auth and logging in. The login works ok but then there is no where to authorize the IFTTT channel and select the “location” and devices to use.

I’ve also tried to login to the US auth URL in the normal proceedure and then tried changing the URL that it uses for the auth page. (The one with the dropdown for the location). Looks like this - https://graph.api.smartthings.com/oauth/confirm_access?response_type=code&scope=app&redirect_uri=https%3A%2F%2Fifttt.com%2Fchannels%2Fsmartthings%2Foauth_auth&client_id=ifttt_production

I changed this URL to…

https://graph-eu01-euwest1.api.smartthings.com/oauth/confirm_access?response_type=code&scope=app&redirect_uri=https%3A%2F%2Fifttt.com%2Fchannels%2Fsmartthings%2Foauth_auth&client_id=ifttt_production

And I get a bit further as it lets me then select my location from the dropdown and choose my devices that I want to use. But unfortunately when I submit it gives me a server error.

Error 500: Internal Server Error
URI /oauth/authorize
Reference Id 06cd1b45-9101-4772-8be4-5d442f07f21c
Date Fri Sep 11 16:47:58 UTC 2015

So it seems like the IFTTT channel is not quite ready for the UK folks :expressionless:

I will try Support to see if they can comment on this and let us know when it will be supported as i’m keen to hook this up to other systems, if not I may have to go down the developer approach.


Echo - SmartThings Integration in UK
Can't see my virtual switch on IFTTT
Developer Impact - Infrastructure Changes
Hub not showing as present or accessible via API
Jawbone Up & Smartthings
Rules Engine?
Rules Engine?
Can not authorize Harmony Smart Control Hub to access ST
Contemplating buying the hub
Can not authorize Harmony Smart Control Hub to access ST
Unlocking Door the Simplest Way
FAQ: Help with Logitech Harmony (Connect) and Triggers (SmartThings Classic)
Lifx colour help!
How Do I Add Additional Users To the App
SmartThings Open Cloud & the ARTIK Chip
Github Integration for UK users
Simple rule builder - now private
(Chris) #2

Just got a reply from UK support which was quick! Good news, hopefully it should be resolved very soon…

"We are aware of a limitation right now that is preventing IFTTT authorising with SmartThings in the UK. There is a security lay in place from the global roll out that is holding up the cloud to cloud services. Our engineers are working hard to resolve this as soon as possible (days not weeks).

We’re really keen to get this working too."


(Ashiq Nazir) #3

It looks like the security layer issue is causing a lot of problems across the board for SmartThings UK devices / Integration.


Developer Impact - Infrastructure Changes
(Arron Forde) #4

I’m sure its the same issue for Sharptools - https://play.google.com/store/apps/details?id=com.boshdirect.stwidgets&hl=en
Nothing in the dropdown for uk hub


(Mike Turner) #5

Glad I came across this post as just found the exact same issue. Hoping it will be fixed soon so I can play with my SmartThings hub a bit more!


(Chris) #6

Looks like it will be “weeks” now not “days” unfortunately. Last update from Support yesterday:

“With IFTTT, we don’t like to promise timescales. It’s looking at being a couple of weeks before the integration is up and running. We’re checking all the security is in place, before we set this up for the U.K market.”

Going to have a play with developing to see if thats working for the UK.


(Joe Jones) #7

It makes it sound like they think they’re doing us a favour.

I and I’m sure many others have bought SmartThings under the impression that all of these integrations are in place.

Aside from that, they should have at least left core functionality working like inviting other users. I’m rather irritated, and tempted to return it until they sort it out.


(Chris) #8

Had a play around with developing a simple app, I was able to create an app easily and get it to send requests to my server to integrate it with various things. The IDE does not working well for testing unfortunately from my experience, however the app seems to work ok once published.

For the time being it is still possible to use IFTTT without the official integration. Basically its just a case of creating a simple app and then for the handler you can get it to send an HTTP request to the IFTTT maker channel. https://ifttt.com/maker. You can then create a new rule with the Maker trigger ‘Received Web Request’.

Its pretty easy to create an app and to do the IFTTT work around you can just follow the instructions from the ‘Getting Started’ section - http://docs.smartthings.com/en/latest/getting-started.html#walkthrough For UK you need to use the developer section here: https://graph-eu01-euwest1.api.smartthings.com in order to create the app.

Once you have created the app given in the example, then change the code in Step 6 so it would look similar to below… (You would need to create the Maker triggers first to obtain the rules)

if (evt.value == "open") {
 //Change the URL here for your IFTTT maker trigger
  httpGet('https://maker.ifttt.com/trigger/front_door_opened/with/key/EXAMPLEKEY12345')
} else if (evt.value == "closed") {
 //Change the URL here for your IFTTT maker trigger
  httpGet('https://maker.ifttt.com/trigger/front_door_closed/with/key/EXAMPLEKEY12345')
}

Of course the code can be simplified here but i’ve left it like this so the URL’s can clearly been seen. Parameters can also be used in the Maker triggers if desired.

Hopefully this helps someone that was keen to get IFTTT integration and can’t wait like me!


(David Bushell) #9

Looks like some movement here - I’m seeing an IFTTT app automatically added to my Smartapps now. It allows me to select which devices can interact with IFTTT. Still shows no devices when I try to authorise but looks like we’re getting there…


(Joshua Lyon (SharpTools.io Dashboard)) #10

From the Developer Impact - Infrastructure Changes thread:

@Arron_Forde hopefully once they get a solution in place you will be able to use SharpTools as expected!


LIFX built in device not working?
(Tim Smith) #11

is there any sign of a fix for this yet? If not, do you have an ETA? This and being able to add more users are the last 2 issues for me now.


(Mark Freelance) #12

According to twitter by the end of the month.


(fabrizio) #13

Hi any news about OAuth install?


(Mark Freelance) #14

@aaron S Any update, you’re CEO confirmed on twitter to me that this would be fixed by the end of the month and I’m not having any luck yet :slight_smile:


(Aaron S) #15

I am going to get him ‘fixed’ by the end of the month… :sunglasses:

Account sharing should be up and running by the end of the week. I am not sure about IFTTT and the rest of OAuth, but it is definitely in process (and a big priority).


(fabrizio) #16

Any News? apparently nothing changed in my oauth permissioning


(Ashiq Nazir) #17

Is there any news on the progress of this issues? End of month came and went. Surely someone noticed that.

There have been promised fixes since launch day. People notice arbitrary changes of things that start to work, then stop working and everything is a bit random. UK launch has been a car crash, but is there an end in sight?


(Mark Freelance) #18

Have to agree,Samsung has nearly half a million employees so why does it feel like I’m only ever talking to one of them. I want this to succeed but it’s taken nearly two weeks of emails and I’m still no closer to getting a replacement for a damaged outlet…As for the IFTTT issue, end of month commitments by the CEO and nothing. Very frustrating.


#19

I can only assume there was literally zero testing done on this before launch.

I’m really keen to start really putting some work into this and develop some smartapps etc, but the whole thing seems broken at the moment.

What I have at the moment, is essentially a £200 motion detector that turns a light on (sometimes).


(Aaron S) #20

because that SmartThings guy you talk to is the most loud, obnoxious person in the whole company… they should do something about him… I’m thinking an indefinitely leave of absence in the Caribbean or Hawaii :smile: