FAQ: Help with Logitech Harmony (Connect) and Triggers (SmartThings Classic)

I just sent this into Support, but checking here in case anyone has a suggestion and since support is already a day or two “late” on responding to a separate emailed issue. Thanks!

I’ve added a SmartApp via a ST template called Logitech Harmony (Connect). Unfortunately I did this BEFORE adding the Harmony Hub as a Thing and I now appears stuck in a bug.

When I click on Logitech Harmony (Connect) underneath Marketplace / My Apps it does not do anything except to create an instance under Rooms / SmartApps. Unfortunately I clicked that apparently 6 times trying to get it to respond, because I now have 6 instances of Logitech Harmony (Connect) within Rooms / SmartApps. When I click an instance, I get the spinning circle for a second and that disappears. There is no way way to delete these. Help!

1 Like

Next question… does anyone have to Harmony Hubs setup and connected to ST? The Harmony Smart Control in the bedroom is not being found. I’m almost sure I have the latest firmware installed. It’s the older model, no screen on the remote. Maybe it’s not compatible with ST?


According to the blog:

Only the Harmony Home Hub, the Harmony Home Control, or the Harmony Ultimate Home works with the smartthings hub.

1 Like

Bummer… not sure I want to upgrade that one yet. Maybe the next time they do a $100 trade in deal.


Hope Im in the right spot. Tried and am not able to integrate. I have the V2 hub and latest firmware and software for my Harmony Home hub and ST. I have static IP on both hubs. I have deleted, rebooted and reinstalled multiple times with no resolution. I am able to add ST via the Harmony app as a device and authorize all thru the web API. ST devices show up on the Harmony app. I then go to the ST app and I see the Harmony smart app associated with my virtual switch. I go thru the connect process to access the Harmony activities but get an unexpected error or not authorized error message. Anything Im doing wrong. IFTTT is so unreliable and useless.

Do you have a US account or UK account?

There is a problem authorizing any UK third party services right now, it affects Harmony as well as IFTTT.

US…when I add the Harmony hub ST won’t recognize it…I get an unexpected error message. I’ll send a screenshot.

Best thing is to contact support@smartthings.com then. They should be able to check things from their side. Good luck, I’m sure it’s frustrating. :confounded:

See the following ( this is a clickable link )

I am having the same issue only difference is I am using SmartThings V2. I set mine up using the logitech mobile app., setting up a new account. I have never owned another harmony hub, but I do have a harmony 659 remote that is setup on an old account that has a different email address. Anyone have ideas to help solve the problem?

Click on the link in the post above yours, that’s where the connection issues are discussed. Good luck!


Thanks for all the info in these posts. I have been able to connect to my Harmony Hub in ST. However I do not see the Logitech Harmony Trigger smart app under Marketplace\More. I have the v2 ST hub. Any suggestions?


Do you have a UK account? Harmony integration is one of those affected by the OAuth problems, and I believe the related smart apps will not appear in the marketplace for those accounts

No - I have a US account. At least I should since I live in the US and setup my account while here :). I am able to do steps one) and two) of your very well explained post #7 with no issues. Just don’t see the Logitech Harmony Trigger in Marketplace so cannot start on step three.

Looks like they are making some changes and there is a new SmartApp now called a Harmony control. This is different than the Harmony connect smartapp. If you can find that one it does the same thing as the trigger smartapp used to.

You can try starting from your harmony hub in the things list and look under its smart apps and see if control is there. I’m still figuring this one out it just appeared mysteriously

@JDRoberts, Thanks for the pointer - that worked. I can now trigger Harmony activities from ST. Using virtual switches I was able to control the Harmony activities from Amazon Echo - pretty cool! I find a lot of the navigation in ST somewhat non-intuitive. Still getting used to it I guess. But it is amazingly powerful and functional once you set it up. And these forums are just great!

1 Like

Update 21 November 2015

Yes, the official SmartThings/Harmony integration again changed without notice.

Yes, it crashes in the mobile app.

Yes, I opened a support ticket.

No, I don’t know what the changes were, how to use them, or how to get around the crash.

The harmony/echo integration that bypasses SmartThings and uses IFTTT works just fine.

I expect the first support suggestion will be to uninstall everything and reinstall it with the new smartapp, but I won’t have anybody who can do that until Tuesday so if somebody else has answers please post them.

Confirmed here as well. Although for me I get “An Unexpected error” Message.

@JDRoberts I wish I lived near you, I would come over to help. I am sorry that this is happening so often for you now.

1 Like

I was researching all of these steps only to find out I have the same Issue.

I was able to add a new Harmony Hub, and I was able to “grab” things for use by the remote rather easily. However it seems impossible to control the TV from Smarthings. I will be opening up a support ticket with Smarthings as I have the same screen as @JDRoberts.

Bummer! I was hoping this would be cool to integrate as I can’t get my lights to work off of any sort of time rule anymore… I will update if I hear anything.

I tried deleting all of the harmony triggers and the harmony (connect) smartapp. Reinstalled everything and it still didn’t work.