Echo - SmartThings Integration in UK


I live in the UK and was given an Amazon Echo by a US relative as a gift - they thought it would work the same in the US as the UK. Alas, we all know server / app configurations are often different, so alas a number of things don’t work perfectly (i.e. I can’t select a UK postcode to get local news/weather, etc. However it still works pretty well.

I bought the new ST Hub - set-up was pretty straightforward. The Amazon Echo hardware integrates with the Hub, which is great, but alas when I logon from the Echo account to the ST hub (web interface) the Echo hardware does dot display the location profiles (e.g. home, away), so I am unable to link to the devices. Anyone tried this and got it working? I’m thinking it’s a IP address in the UK issue, which Echo doesn’t like.

Cheers, Dec.

I think it’s more likely that it’s an authorisation problem that is occurring with many cloud to cloud services for UK customers right now. This includes IFTTT, for example, as well as smarttiles and sharpTools.

The problem is that the authorisation process for outside services is being directed to the US servers, and since your information is on the UK servers, no authorisation can be performed.

The only thing you can do about this right now is report it to support. That way they can let you know as soon as a fix is found.

I m in the UK and have my Echo successully paired with ST. Im not sure what you mean the Echo doesnt display the location profiles? It doesnt integrate that well…
Once the Echo was paired, I used the Echo web interrface to go through the device discovery - it found my suitable ST devices, so I can say ‘Alexa turn on office light’ etc.

Hi Andy,

Were you using a Amazon UK account?

I’m having the same issues as JDRoberts. It’s definitely a US to EU authorisation issue the Echo SmartThings connect request isn’t working correctly. Seems strange that it’s worked for you Andy - what devices / browser did you use to initiate the connection?

Yeah, I think I’ll have to report to SmartThings, although they’ll prob say it’s an Amazon Echo issue - I’ve already emailed AWS - I’ll keep you posted on response.


Hi Andy,

How did you pair the devices? I presume you used the Alexa app - if yes, what version?

The attached picture shows the authorisation screen, but no locations are populated in the drop down:-( hence I’m unable to pair the devices.

Rgds, D

I’m doing the same thing as everyone else, trying to get my echo authorized with smart things and having the “no location in dropdown” problem. Has anyone found a workaround yet?

It is as you say, if i call:

I get [] (no locations)

If I call:

… I get my expected locations. So the echo authorisation page is using US APIs when it should be using EU/UK

As the Echo app wont install and/or work due to locale and lack of US address in my Amazon account, I used the web version.
(I tried VPN access to get around the locale issue, but then Play or Apple store recognises no US address)

I did the pairing before the recent V2 updates - im away from home until Friday, so cant retry actions, but happy to try and remember via email questions until then.

ah - just remembered - I do have an Amazon US account, which I think I used to register the Echo (but it has my UK shipping address)

Both of those give me locations.

Since the echo’s not yet available in the UK i’m also using a US amazon account and bought it back with me from my US friend who forwarded it to me. Saying that i’ve not been prompted for an amazon account yet unless amazon is passing that to Smartthings for the authorisation attempt. I’d think more it’s a case of setting a “country” in my smartthings account profile or something which would fix this, which i can’t see an option for atm.

Different servers seems to be the issue - looks like you and I are having the same problem Henri.

Andy, maybe the previous software allowed youbto call the correct server. If so, Lucky you.

I have an Amazon US account calling a UK SmartThings account. I tried a VPN with a US IP address - I was thinking of registering for a US Smartthings account, which would then allow the Echo web service to call the ST web service, but SmartThings wouldn’t let me re-register the Hub to a different email address without going through support!

I’d be interested to hear if re-tracing you steps works Andy:-)


i guess i must have a US ST account (although I wasnt aware they had been segregated) as I registered much earlier in the year.

If you registered much earlier in the year, you have a US account. There were no UK server accounts until September 2015.

Might ask SmartThings Support to reset my Hub to allow me to try registering using a US IP. Would be good to have a better solution.

Thanks for the info.


Got everything re-set. Created a VPN and tried registering my Hub2 via a US IP Address - no luck! The US server didn’t recognise my Hub2 welcome code, which makes sense as they are two different servers:-( I’m hoping the IFTTT issue will sort the authorisation process out and I’ll be able to sort via a URL hack(similar to that suggested by Henricook) - probably wishful thinking!

ah yes :frowning: been through the migration now, last thing to go was my Echo.
Confirming is does NOT work now, as it is the Euro servers that are being called, so a report to Support is needed.

It looks like Ive still got access to the US servers as well, so might reinstate the v1 hub

I asked US support to register my Hub credentials to their server to see if I could bypass the US - EU API server call problem. Not sure that’ll work, but worth a try. It would be much cleaner if the US and EU servers were built and configured the same way!

@Dec - any progress?

Alas, none. Not sure if they are just busy or ignoring me!