SmartThings Community

Moving Devices Between Account Locations? (ST added a second “home” just for my TV in the new app)


(malamoney) #1

Hi. I have had a SmartThings hub (Hub v2 US) for about two years and have been running webCore for quite a while. I love it.

I recently purchased a Samsung Q8 and Q6 TV. During the process of setting up those televisions I tried to get those TVs added to my devices so I can include them in pistons. I ended up having to migrate to the new SmartThings app. Now I have both the Classic and new app on my phone.

However, when I log into the SmartThings IDE (https://graph.api.smartthings.com/) on my laptop I see I now have two locations. The one my original old hub was associated with and a new location named “Home”.

The original location has all of my devices associated with it, but the “Home” location has the two new QLED TVs. The “Home” location has no hubs associated with it according to the IDE.

Where did this new “Home” location come from?

I want to move the two QLEDs to the other location. I followed the steps for moving a device to another location via the SmartThings App and while they show up as moved in that SmartThings app, I do not see them in the list of devices associated with the other location in the IDE or the Classic app. When I log into the new SmartThings app on my phone (where I executed the move), the “Home” location is shown as having no devices and the two QLEDs are associated with my old hub location (which is what I want). So it seems the two apps are out of sync.

Just to summarize I somehow now have two locations:

  1. Hyrule (location) with my v2 hub associated which has webCore and all my devices
  2. Home (location) with no hubs and the two QLEDs (at least according to the IDE and Classic app)

Any help here would be greatly appreciated.

Thanks,
Mike


#2

Yes, this happens. There are already about a dozen threads about it.

The issue will be reported as either:

“My Hub is missing from the IDE” (it’s not, it’s in the second location the system magically created)

“I have two duplicate locations now” (yes, you do, the system magically created the second. If it’s empty, you’ll eventually be able to delete it.)

Or your situation: “I have two locations now. My hub and most of my old devices are on one, and my Samsung appliances and TVS are on the other.” (Yes, that happens. The official Knowledgebase article tells you that you can move the hub and its devices into the location that has the Samsung devices, but not the other way around. Then once you have an empty location, you can delete that one.)

Anyway…

  1. the answer to where the second location came from is that Samsung magically creates it if you had an original SmartThings account and now you have a Samsung account. As I said, many existing threads in the forum about this issue.

  2. Televisions and appliances now need to be managed with the new app. As you note, they won’t work with classic. (Many existing threads on that as well, btw.)

  3. it’s fine to use both apps at the same time, which many people have to right now. See the FAQ:

SPECIFIC differences between "SmartThings (Samsung Connect)" and "SmartThings Classic"

  1. to be honest, I’m not sure if you can use your televisions with Webcore or not, given the current state of things. Webcore has their own forum now, and you’ll get your fastest and best answer by asking there.

If what you want to do is move your hub with all of its devices over to the location that has the televisions ( it won’t work right if you do it the other way around), here’s the official knowledgebase article that tells you how to do that:

So that will get everything together again, but what I don’t know is if that means webcore will be able to access your televisions. I don’t think so, but I’m just not sure. Ask in the webcore forum and they should know.

Research Results

BTW, Here are just a few of the existing threads on the duplicate location issue, they should give you more details on points 1-3 above if you want them, although at this point they probably are moot as long as you read the official knowledgebase article on locations.

Next time, research a little more before posting your question so you can focus on the new stuff and save us all some time. :wink:

All of the following threads are talking about the same issue. :scream::scream::scream::scream::scream::scream:

Duplicate Locations now in ST Web Portal

2 Default Locations

Migration to Samsung Account: duplicate location?

Hub and ALL Devices Gone?!?!

IDE webpage suddenly shows 2 home locations - wont let me delete - I only have 1 hub

Migrated to Samsung Account - all devices are "unknown" in new app

Extra / Phantom Home Location created by new SmartThings app, Why?

And the official ST knowledgebase article:

Point 4 may already be answered in the Webcore forum, you’ll have to check there.

(@jkp May want to create a FAQ about it, since the question gets asked about twice a week and @jkp typically provides the answer. )


(malamoney) #3

Thanks for the very detailed response. I actually spent a few hours researching this issue before posting, but I didn’t see anything about why I was able to move the TVs from the “Home” location to my original location and then having the discrepancy between the IDE and the Classic and new apps. Based on the instructions I correctly and successfully moved the devices from “Home” to “Hyrule”, but yet I couldn’t see them. Just wanted to make sure you knew that I didn’t just post without taking any time to try and figure it out.

Again, thanks for taking the time to detail your response.


#4

You have to move the other way. Move the hub and its devices into the location that the cloud assigned the televisions to. As you noted, the televisions won’t work on the old location. And in your case you will want the location where the televisions were originally assigned to be the default location. That should at least let you see everything in the IDE. (I honestly don’t know if the televisions will show up in the classic app or not. I know they don’t work there.)

As @AdamHLG noted below, when you use this method all of the devices will be listed on the things list in the new app, but you will not be able to control a lot of devices that use custom device type handlers. :scream: For those you have to go back to the old app.

So, yes, it’s a mess.


#5

I am living with this over the last 2 weeks ad nausea. The televisions do not show up in the classic app I assure you that (I just got 2 new Samsung TVs). The TVs show up in the new app (the second “home”). However, the new second “home” does not show up in my IDE. Moreover, in the new app, I see the TVs and my Ring Doorbell, however, none of my Lutron Devices work that are setup on a custom SmartApp (Nate / Bill’s Lutron Pi 2.0). I see all of my Lutron switches listed in the new App, but pressing on any of them to control them brings up an error that says “device unavailable” and per my research on the topic, this is because the new app does not support custom device handlers. What a mess and I feel it will be that way for a long while.

My research on the topic seems to say that Samsung messed up by making things so complicated and a typical consumer should not need to access the IDE to make things work. I believe the direction this is going is that one day community smart apps will need to go through a Samsung process that makes them available in the new app (similar to how Samsung makes certain apps available like Speaker Companion or Smart Lighting). Until then, folks are told to stay on the old app until this “conversion” is complete (which im my opinion at this rate is probably years). This is fine, I will stay on the old app, but this means no TV integration (unless you do it the hard way, which is to create a virtual momentary button in the IDE, and have that control the SimpleControl SmartApp hooked to a SimpleControl hub, with the SimpleControl hub controlling Global Cache devices that blink IT emitters - which is how I do it).

Speaking of SimpleControl, don’t even get me started on Samsung TVs and trying to get Wake on Lan and power on over IP control working. It doesn’t. The TVs go to sleep when powered off - both on WIFI and Wired LAN. It’s a firmware thing. Unless I didn’t try something. But I tried everything. I’ve been at this for 3 weeks.


(malamoney) #6

So in my case the two new QLEDs do show up in the Classic app, but under the newly created “Home” location. Under the other location (the one I originally created) I see all of my other devices.

I just turned on my Samsung UltraHD Blu-ray player is I just got a notification in the new app that it found the Blu-ray player. After entering a pin that appeared on my screen I now see it in both the Classic and new apps. It too appears under the “Home” location in both apps. I see the “Home” location and the three devices (two QLEDs and Blu-ray) in the IDE as well.


#7

SmartThings staff have said multiple times that their typical customer has fewer than 15 devices and uses no custom code of any kind. So the new app should work fine for them.

The problem is that the original business model was that smartthings could be made to work with almost any home automation device and customers would be allowed to upload their own custom code to the smartthings cloud, and that’s what attracted a lot of the power users who frequent this forum and lead to community created innovations like WebCore. And those just don’t work with the new app.

In addition to the new app, there is also an entirely new cloud coming. You’ll still be able to do some custom code, but it won’t work the way it works now. Instead, the developer will have to host the code and then connect with a cloud to cloud integration. The groovy platform will be going away eventually all together. But that’s a topic for a different thread:


#8

Right, anything that is automatically added will now appear in the new home location.

Also note @AdamHLG ‘s Point that just because something appears in the things list in either app does not mean that it will be available for automations created through that app.

That’s why many people who have Samsung TVs or appliances are continuing to use both apps: they need the new app for those specific devices.


#9

Thanks JD for your guidance as always. I am curious how malamoney got his TVs to show up in the Classic app. I could not get my new 2018 Q9 or 2018 40" lower model to show under any location in the Classic app (existing or a ‘new’ location). I can get the TVs to show up in the new app. I will try it again.


(malamoney) #10

Here’s some proof. If I change locations in the Classic app to the auto created “Home” location, here is what I see for “Things”…


#11

So, two questions…

Do you to have exactly the same models? And are you in the same country? And I suppose are your televisions on the same firmware version?


(malamoney) #12

Same models of what? QLEDS? If so, then no. I have a 65" Q6 and an 82" Q8.

I am in the US (Massachusetts).


#13

You can try asking in the Samsung support forum. Unlike this forum, which is just customer to customer, they do have staff moderators who can give official support answers. They seem much more familiar with the televisions and Samsung appliances over there, so it might be worth a try.

https://us.community.samsung.com/t5/Smart-Home/bd-p/SMARTHOME


#14

lo and behold, being inspired by the success of malamoney, I tried this again and it worked! I had to add the 2018 QLED 65" to the new app, then delete it from the new “home” it created in the new app that had the TV, then change to the old existing ‘home’ in the new app, then re-add the TV to the old ‘home’ in the new app, and then when I opened the classic app, it was there!


(malamoney) #15

Nice, but it looks like we are moving in opposite directions. After waiting on hold for SmartThings Support for nearly an hour, I had an uneventful conversation.

My goal was to get the three devices (two QLEDs and one Samsung Blu-ray) successfully moved from the auto-created “Home” location to my real location with the rest of my devices.

Just to recap, I followed the instructions for moving devices between locations via the new SmartThings apps and it was successful. The new app reflected as much, but the Classic app and IDE did not.

The support person had me delete all three devices and then delete the “Home” location. Then they had me set my real location at the “default” location. Then I was to re-add the QLEDs. They were successfully added via the new app and showed up, but were nowhere to be found in the Classic app or IDE. I tried deleting and re-adding a few times. Some times manually adding them, but each time with the same result.

Then for shits and giggles I deleted the TVs. Then I created a new location using the new app and set it as the default location. Then I re-added the TV. It was added to the new location and showed fine in the new app. But in the Classic app and IDE, the new location was shown with no devices. This shouldn’t be this hard.

Based on your explanation of how you did this, I have some questions.

When you added the QLED from the new app, how many locations did you have before adding? I tried this with only my real location named “Hyrule”. When I added my QLED, it added, but in the new app, it called Hyrule “Home”.

When you say “then change to the old existing ‘home’ in the new app”, does this mean you had two locations named “Home”? How did you re-add the TV to the old “Home”?

Thanks and congrats!