Duplicate Locations now in ST Web Portal


(cjcharles) #1

I had the transfer over to Samsung account recently and that was all fine - not negative effects anywhere. However now when I look in my web portal I see duplicate Home locations, both with all of my devices in them, and one where my phone has multiple location sensors.

I fear this is my Samsung S8 phone trying to do smart home stuff in the background (after an update of Samsung apps that didnt come through the Play store) and causing a duplicate location somehow…

Everything Ive found on the forum just says delete the blank/empty one, but whilst I can tell which is the new one (because it doesnt have a location set, or sunrise times, or rooms…etc) I am worried that it will actually break everything (since it also has a copy of all of my devices).

Any advice would be very much appreciated!?


Migrated to Samsung Account - all devices are "unknown" in new app
(jkp) #2

Best advice would be to contact ST Support if you have devices in both Locations.
https://support.smartthings.com


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #3

Which one contains your Hub?

https://account.SmartThings.com

My Locations tab. Look for Hubs…


(cjcharles) #4

My hub was only listed in one location, you’re right there, thanks. That made me decide to try and delete it on the assumption they were just mirror devices, though no amount of changing Location details or renaming the dodgy Location would allow me to delete it. Think I may need to contact support after all…
Thanks all


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #5

I’m sure you’ve been thorough… but just in case; set be sure to set the one with your Hub to “default” and the other one to … not “default”. A “default” Location cannot be deleted.


(cjcharles) #6

Yes I tried that, but the new ‘dead’ location doesnt let me change anything about it, everything is greyed out apart from the name. And changing the other location doesnt seem to help from my testing. Thanks though!


#7

I just got around to deleting my phantom location that was created as part of my Samsung account migration. Just make sure to:

  1. Delete devices in the phantom location. Those should not be any device associated to any hub, but it could be your mobile presence device, or in my case my Samsung TV that was discovered somehow.
  2. Set the REAL location connected to your real hub as the default by editing that one first.
  3. Then edit the phantom location and click on the Red delete button.

If all that doesn’t work, then I’d email support.


(cjcharles) #8

Problem is it seems most of my devices are in both locations, hence Im cautious of deleting them from the fake location in case it deletes them from the real location. Also, you are right I am pretty sure it was my mobile presence device which has caused this device since there is a Samsung S8 device that is only visible in the ‘fake’ location, and whilst I can delete that device it still doesnt let me change the default location:
image

Ive emailed support now, will see what they say.


#9

Yeah, I’m sorry to hear that. If I saw duplicate devices I’d be worried too. Support will be able to help.

Can you go to the Location you want to keep and change that to “true” for the default? If I remember right, you can’t change the existing “true” Location, but instead you need to pick another one to make default.


(cjcharles) #10

The other/real location allows me to change the setting to true, but it fails to save if you change it. Fingers crossed it isnt too troublesome to fix. I’ll be dropping ST in a heartbeat if I have to rebuild stuff.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #11

My fingers :crossed_fingers: crossed for you too… But I’m not optimistic unless you reach a particularly skilled Support person.

There are countless reports of customers having to “start over” after Support purposefully or accidentally reset their Hubs / Locations during this transition… And only a handful of reported success stories.


(MarkTr) #12

Hmm. I renamed my “extra” location yesterday because I was unable to delete it, after confirming there was no hub or devices associated with it, just an extra mobile presence. When I got home, none of my “real” devices were working, just cloud connections; I assumed it was related to a power outage the night before, until I remembered things were still OK in the morning, and realized my mucking with the IDE was to blame…

I tried renaming the extra location back to home, no dice. Then I figured out my “real” location wasn’t set to default, and once I switched that, I was able to delete the extra. So now that’s gone, but it didn’t help; the only device that’s actually connected is a motion sensor I added during this limbo period. All the devices show last activity as middle of yesterday morning (approximately around when I logged into the IDE and got annoyed by the extra location). It’s like they’ve all been removed from the Z-wave / Zigbee networks, even though the entries are still present in the IDE. All the devices still show in ST Classic, but none of them are in ST Connect.

I’ve signed out and back into Classic app, rebooted the hub (thru the IDE, batteries still in), repaired Z-wave, etc, swapped locations. I have an email in to support but no answer 24h later. Is there any other action I can try to correct this?


(jkp) #14

open a device in the Classic app, click the cog in the upper right-hand corner of the screen and click Save. Force quit the samsung connect app, reopen it and see if that device shows. it could just be a sync issue which ST support can resolve.


(MarkTr) #15

That got the device to show up in Connect app but still no connection / control through either app…tried for a couple more devices and they showed up without the force quit. Edit / Update in the IDE also gets them to show up there, for the record.


(jkp) #16

one last thing to try… change your samsung password in the classic app. then login to both apps with the new password.


(MarkTr) #17

No joy but thanks for the suggestions so far. Any way to associate an existing hub with a different location? Want to try moving things around to see if that resets whatever’s broken.


(jkp) #18

probably best to let ST support work their magic


(MarkTr) #19

That’s what I’m hoping for now but after a day of having to turn my fans on by hand I’m getting impatient :laughing: