How to Update Smartthings Hub (2018) Wifi Settings?

Weirdly, one of my coworkers is also seeing the option greyed out in the same version of the app to.

The only suggestion I have for the moment is to take the hub offline and see if the option becomes available. Or otherwise if you have another android or iOS device, it might be worth a try there.

Sorry I don’t have a better answer. My coworker has made a comment to the app team, but that team is in Korea so it’ll be at least a day before I have anything more to suggest/ask.

Thanks for asking around. Taking offline has never worked and I did try that a few times. I really thought the big ST app udpate was going to make this a less tedious process. Please keep me informed if your coworker decides to dig in to see why his is grayed out as well.

I did also try my wife’s phone, same deal there. I guess I could try my ipad.

Yeah, it should have. :confused:

Let me know if you do.

Will do. If you haven’t heard back from me by Wednesday or Thursday, feel free to ping me again. I’m not always the best a remembering to follow up on this stuff.

I’m dying over here. I’m on with phone support right now and they’re not understanding and still think this cannot be done on a v3 standalone hub. Am I the only one in the world with a need to move his v3 hub to a new wifi network and not hard reset it?!?!

Patrick any assistance you can provide would be awesome. I’m just getting nowhere with support.

1 Like

Can you try the soft reset again so I can collect fresh logs? I tried to look for logs over the past 30 days and couldn’t find a rejoin attempt.

Hey Brad, I will try this tonight. I have not tried the soft reset in quite a while bc I was led to believe this was doable with the “Update Wifi” option inside the new app.

The soft reset always failed for me. I will do it again tonight and message you. Thanks.

1 Like

Thanks, just let me know after you’ve tried!

Being transparent for you and others, the soft reset is not addressing why “Update Wi-Fi Information” is greyed out which is still confusing and an issue. But I am hoping that with the soft reset we either get the hub switched over to Wi-fi or we can see logs that will help us figure out why the soft reset/reclaim workaround is failing.

I thought I would share how I updated my wifi settings after getting a new router (I also changed the SSID). To be clear, I was desperate and tired many things (including the recommendations throughout this thread). My hub was listed as disconnected within the new app and inactive in the old app (Android). Update wifi settings was grayed out in the new app. Blue light on hub was flashing. Hub was not appearing on my online ST account (I have 3 hubs at different locations and only two appeared online).

  1. Unplugged hub for 30 seconds and plugged it back in. Hub returned to blue blinking light.

  2. Opened new app (on Android).

  3. Pressed rest button on back the hub and released it immediately when the light started flashing red/green.

  4. Pop up within the app alerted me to a new hub (I did not have to go to settings). I went through the process of activating and registering it. Took a few times of selecting the SSID and entering the password before it “connected.”

  5. Once connected to the wifi, the app offered to register the hub. Tried that and it failed repeatedly. Could not connect. Lights remained flashing red/green.

  6. Unplugged hub for 30 seconds and rebooted phone.

  7. Upon restarting of both, my hub was connected to the new router (and new SSID) and everything within the app is fully functional. I did nothing extra at reboot. It simply started working. At no point was I able to get the wifi settings to work (remained grayed out throughout the process).

Unfortunately, I did not take notes during my haphazard experimentation so I likely can’t give more specific details.

Hope this helps some of you.


Hey, sorry I haven’t followed up on this in awhile again, got busy and haven’t been coming to the community much.

I kicked the ticket and the mobile team is looking at it again.

One clarification, The current app store version of the app does have support for changing the wifi config of a hub v3 without the hub first going offline. (I believe if you have the new UI you have a version new enough for this to be true, not 100% sure, I have confirmed it’s definitely there on my android phone with app version 1.7.27-25.)

I’ve now had both the menu item be greyed out and simply not appear, so I can definitely confirm the issue exists.

I have had it come back from being greyed out by just pressing back and going into the settings menu a couple of times. Note it can also take a few moments for it to become available, it seems to be checking something (no, I don’t know what), but even when it working it’s not instantly there.

If going in and out of the menu a few times doesn’t get it to work for anyone can you let me know:

  • AppVersion
  • Phone OS Version
  • Number of Locations in Your Account
1 Like

Thanks @john_0394 for the recap on your attempt. I’m getting somewhat renewed hope.

Patrick, interesting that you say this about it checking for something. I actually suspected this as several times going into the settings, I noticed that immediately the option was NOT grayed out for a split second. But there was no time to click it.

Did you confirm that this setting is actual for the hub wifi? Phone support (and I believe he went to check with a dev team) claims that this is just to update wifi for samsung smart appliances, tvs, etc.

Either way, I will try to mess around again this weekend. I owe Brad a msg to check the logs if I cannot get the soft reset to work. Just haven’t had a chance this week. I’m definitely on the latest app version, Oreo on a Galaxy S8+ and only one location/hub.

Yep, I have a location that only has a hub v3 on it where the option is available and is the only thing in the list it gives me after clicking on it.

1 Like

No idea why, but your steps worked for me!!! I never had to select an SSID, I assume when I entered the serial at setup or scanned QR that it was using my phone network settings. I had to restart and everything and then it connected to my network!!

Thanks for the help.

Will I lose all my devices if I changed from LAN to Wi-Fi?

No, your devices won’t get removed when moving between wifi and ethernet.

(The only possible exception I can think of would be if you had done anything really custom with LAN deivces where you’d hard-coded the IP address of the hub into an external device. The hub will get a different IP address. If you’re just using smartthings-provided DTHs (and probably most community DTHs) for those you don’t have to worry about this.)

1 Like

Is there a way to remove wifi and just use the ethernet cable? I am getting bad pings, in the 100-500s when using wifi even though it is next to my Netgear Orbi wifi router. With ethernet I get 1ms ping times. All other wifi devices such as laptops, tablets, phones, etc… get ping times in single digits.

The hub should prefer ethernet when it finds an active internet connection there. All you need to do is connect the ethernet. You should be able to verify this in your router’s DHCP status table. It should show up as a different “device” (though likely with the same name) because the MAC address is (slightly) different between the two interfaces.

I don’t think there is a way to specifically remove the wifi credentials (other than a factory reset). But you could change the wifi to a network that doesn’t exist if you want to make sure it never tries to connect again.

I have 2 entries for my hub on DHCP, one on ethernet and one on wifi. Just wanted to disable the wifi since I don’t think I will use it since the pings are terrible. Also wanted to disable it to free up resources and avoid any confusion since both IP addresses are pinging. It’s strange that both are active. On my laptop when I connect ethernet to the network my wifi is disabled so only 1 active connection is on. When I unplug my ethernet on my laptop then my wifi will automatically turn on.

That’s the expected behavior right now in order to allow for faster failover in some cases. As noted by Patrick, the default route will be through ethernet if both are connected and provide a working route to the internet.

To disable Wi-Fi, you may be able to go through the reconfiguration flow and enter invalid credentials. This may provide an error but still persist. We don’t currently have a simple way to clear credentials without going through a factory reset.

This limitation with the hub extremely disappointing, to say the least, that a simple option for changing Wifi is not accessible. I changed my router and now Smartthings is basically useless with my current configuration. Who is in charge of this fix? I would frankly like a refund and go with a smart-hub that is actually user-friendly and well supported. Smartthings should have basic accountability in supporting the products they sell…

You should be able to update your WiFi via the settings menu in the app without a complete reset.