SmartThings Community

How to Update Smartthings Hub (2018) Wifi Settings?


(Jack) #1

Hi,
I have setup my Smartthings hub (2018) with a wifi network, but now I have moved it to a new location with a different wifi network. How can I change the wifi settings for the hub in the app? I don’t see any option for this. I’d appreciate any help.


(Tony Fleisher) #2

(Allan) #3

That’s for the SmartThings wi-fi system, not for the new Standalone hub.

Currently there is no way to change the Wi-Fi settings on a new Hub unless you factory reset it. Which I’m still having trouble believing but a ST staff member already mentioned it in another thread.


(Ron S) #4

The option is disabled for some reason. I had to go the Ethernet way as I was unable to add it to a newer WiFi network.


(Dan) #5

The the one and only truly useful feature of this hub is now useless to you? That’s crazy!

If you “upgraded” from a v2 hub, you effectively now have a hub with 50% of the CPU and RAM, still no working Bluetooth, no battery backup, and broken WiFi… Way to go Samsung/SmartThings! :wink:


(Eric) #6

“what is the meaning of this!?!”

but maybe there simply is no there.


(Ron S) #7

Just to clarify. You can add it to WiFi network the first time. Thereafter if you changed your network, you cannot change network as it is disabled. As for me, it’s a piece of junk compared to v2.


(Mark) #8

They’ve done a lot of things in the last 3.5 years since I bought my v1 hub that are hard to understand.

This might actually beat out all the others.


#9

How about using the same ssid and login password with the new router?

Or hard reboot of the hub as a last resort?


(Ron S) #10

That doesn’t help.


(Allan) #11

Somewhere on here a SmartThings Staff member said they added the Wifi change abilities to the just released firmware but it required a app update to take advantage of it. And allegedly there is a large update for the “new” app coming out by the end of this month. Not super helpful right now but its something.


#12

Thanks Ron, it is interesting in that I was setting up a system for second home, and purchased a new router (both asus but different models - but with Merlin firmware installed on each router) and used the same ssid and password on each and am 99% sure I was able to use wifi on both.

I switched to ethernet at the second home AFTER using wifi to pair the already installed Schlage lock as the lock was far from the planned hub location. I wanted to use ethernet as the home is a vacation home and not inhabited.

The only thing I could add to this is that I copied the router settings to the new router before setting up the Hub v2018, and both had Merlin firmware.


(Brad) #13

An in-app reconfiguration option is coming.

A less than ideal but functional workaround:

  1. Remove the ethernet cable (if plugged in)
  2. Press and hold the reset button on the back of the Hub
  3. The LED will turn solid blue and then go dark
  4. Hold the reset button for ~15 seconds until the LED rapidly blinks yellow
  5. Release the reset button when it starts blinking yellow
  6. The LED will likely go solid magenta and then briefly solid red
  7. Once the LED is blinking blue, open the SmartThings app
  8. Navigate to Devices and select “Add a device”
  9. Select Wi-Fi/Hub --> SmartThings Hub (IM6001-V3P) --> Wi-Fi
  10. 9 Scan the QR code as directed and finish setup

Samsung SmartThings Hub (2018) discussion (Model GP-U999SJVLGDA aka V3)
Switch Smartthings Hub from Ethernet to WiFi
New hub v3 owner. When adding hub to app, it gets stuck on update page
(Allan) #14

And this will NOT factory reset the hub / wipe out all devices?

(I don’t think so since a factory reset is holding the pin 50 seconds until solid yellow but just verifying)


(Brad) #15

That is correct.


#16

Smarthings SamCon shows a greyed out option to change/update wifi settings. May be for the wifi mesh net system? Hopefully an upcoming update allows us to change the wifi beacuse the above does not work. The hub goes into join red/green flashing mode but gives me a random list of 1-4 wifi networks from the dozen or so wifi networks that are around here, of course it only manages to do this 1 out of 10 times, the rest it just refuses to do a damn thing, app sits at verifying code until it times out then says Hub Not Connected.


(MarkB) #17

So I had a similar problem. I set the hub up originally as WiFi when I got it and things were going great as I was in the process of converting my Lowe’s Iris system out. I needed to unplug the hub to move it closer to a device and when it powered back on it would not connect back to my WiFi. I was well in range of my WiFi as I have the Google mesh routers (4). I was never able to reconnect to the wifi so I had to plug it into the router and it showed back up. I tried the reset process above and it worked. Then I had to unplug it again and it was not able to connect since then even after going through the procedure above.


(Ahmed Hamada) #18

I have the same issue, I press the e dots but the only option available are “Information” & “Z-wave exclusion”.

I also tried from the settings menu but the “Update Wifi Information” Option is dimmed and not available.


(Allan) #19

@Brad_ST - Any update or a timeline when this will work properly? It seems kinda silly that the ability to change WiFi in a WiFi enabled device isn’t available in a device that was released 5 months ago (without going through a manual reset procedure).