How to Update Smartthings Hub (2018) Wifi Settings?

I am having this same issue and have for a while. in settings update wifi information is greyed out. Have the latest version of the app on my samsung note 10. I want to upgrade my router but fear that it is going to be a huge headache not being able to change over the wifi simply.

Hello everybody. I just signed up in order to share an easy way to change the WiFi identifiers that I found by intuition.

The fact that it is impossible without such tricks is worrying. Does Samsung abandon the development of the Hub?

So, here is the procedure :

  1. The hub is powered, don’t unplug it. Press the reset button until the light turns yellow. Release the button immediately.
  2. In the application, add a new device. You want to add a Samsung SmartThings 2018 hub.
  3. It will let you choose a WiFi network (and the associated password). It also asks you for the QR code under the hub, so you give it.
  4. The app does its thing for a minute and then tells you “the hub could not be reset” blablabla. You don’t mind, and that’s good news because it means that no setting has been lost.
  5. Exit the procedure. Close the app.
  6. Unplug the hub. Plug the hub.

That’s it.

Besides the fact that we need a non-documented trick to achieve a basic change of parameters, I’m worried also by the fact that the hub does not run any automation without Internet although all my devices are Zigbee.
What is the point of having invested in devices on an Internet-independent protocol if the hub needs Internet? and why would it need Internet to switch lights on anyway?
That’s very disappointing.

7 Likes
1 Like

Hi Brad. The procedure that you give doesn’t work for the last version of the hub (2018), hence the tricks shared by people in this thread.

And will Samsung fix the inconsistent need for Internet to run basic if/then automations? When my provider has an issue (or the day Samsung shuts down their servers, in 10 or 20 years) I can’t switch my lights on and off. How ridiculous!

Apparently still no way to update network setting on the V3 Hub unless you fully reset,

This doesn’t work?

The problem being the Update Wifi is greyed even when connected Via ethernet.

Interesting. My hub is connected via Ethernet but I can still choose this.

I have this same problem too. Does it matter have you set up login to hub via samsung accoubnt, or old smartthings account ?

My wifi setup button is greyed out and im logged in via samsung account.

Thank you, Barthelemy! You just saved my day.

Yes, official guideline dose not work on my device. Update wifi information is greyed out all the time.
I read the entire thread, and your method will do the trick.

1 Like

^THE SOLUTION. Thank you, Barthelemy!

Yes!! This worked great. Thank you Barthelemy for this (undocumented until now) fix to change WiFi network on my Smartthings Hub.

:grinning:

I’m not sure if this is helpful but thought I’d mention it…

I just changed my router and set the Wi-Fi SSID and password on the new router to be the same as those on the old one. The hub immediately connected to the new router and has run fine without issue since.

1 Like

I have the same problem and have been reading the above chain. My smart things hub is STH-ETH-250 with NO QR Code. My android smart things app is 1.7.86.21. My unit worked perfectly to dim 2 banks of lights, but I need to change the wifi ssid and PW and use a different router. Can someone please resend a known working set of steps for this. Thanks!