Switch Smartthings Hub from Ethernet to WiFi

Is there any way to switch my 3rd Gen Smartthings hub from ethernet to wifi without doing a factory reset?

If there is, I’ve seen nothing in this forum, nor is it intuitive in the app.

1 Like
1 Like

Thanks for the prompt reply. I wound up having to do multiple resets before I was able to get the hub to respond as I wanted it to.

I’d like to add to this request. Doing a hard factory reset for a simple reconfiguration is not a good customer experience. Please prioritize this feature highly. I’d argue it’s a common use case to perform initial setup on ethernet and then configure for wifi.

6 Likes

I’m very new to SmartThings (First post) and I agree with Dave_T.

I’d also like to add, people change their minds for one reason or another. Ethernet was maybe a good way to go in the beginning, but after some experience, maybe WiFi is better. That’s my case. I have a new V3 hub, a motion sensor and three water leak detectors from SmartThings. I also have two light bulbs (Sylvania), but all disconnect far more than they should. I’m not doing anything fancy (I want a light bulb to turn on and off on schedule and another light bulb to work with a motion detector) I’m tempted to go back to a light switch… I assume by changing from an Ethernet cord to WiFi, I will have to start from scratch, if so, I find that to be very poor planning on a system billed for ease of use. SmartThings should have provided instructions/guidance and had a method built into the app.

Apologies for being critical. I find it all very slick and looking to add more.

Thanks for the space. I’ll try making the change in a few days.

4 Likes

You apparently can do a semi-soft reset and set up to enter your wifi information without losing your devices, but I have never done it.

This issue has been fixed per below: [I could not even get my hub to finish the initial set up process on wifi and had to use ethernet and keep it on ethernet. Using wifi I would get to 99% on the initial update and it would freeze again and again.]

From what I’ve read eventually the app will allow wifi to be changed, it just isn’t there yet.

The limitations of smartthings can be glaring, but what it can do is pretty amazing! I’m willing to wait for development to catch up with potential.

And you’re right, it is very slick, and if you’re not careful you’ll spend any more money than you want to. Its addicting, but worth it.

this should be resolved as of last week

1 Like

Good to know - thanks!

1 Like

@Damian- Thanks for the help. I’ll look up a semi-soft reset. But, it almost sounds like I should try to make my setup work, at least for now.

You also bring up another good point when you said, “You apparantly can do…” I think the folks at SmartThings could use a lot more formalized documentation, instead of people fishing for answers. If it weren’t for this community with people in the know, customers like me would be sunk.

Thanks again for the help. I’ll try to not get carried away. :grinning:

1 Like

Thank you!

I think a lot of it has to do with lots of technical people learning how to use a ton of devices from lots of manufacturers faster than smartthings staff can keep up with being able to control them.

On thing they do very well is making sure that the hub can talk to damn near anything, which is a big feat.

I also think they are in the process of migrating everything to a newer app, while making sure everything still works. That has to be time consuming. The way DTHs work is changing too. It’s just a bunch of things they’re working on. We probably bitch about one lacking feature, while they’re adding 20 other features we haven’t used yet.

I haven’t been in this community more than a few weeks, so I can’t really speak too much on how they operate. Though I have noticed several smartapps from the classic app that are now available on the new app, that weren’t there when I setup my hub.

I actually created a login just to post this because I was very frustrated and then magically it worked… For some reason, it would not let me delete the hub so of course when I attempted to add a new one, it rejected it bc it was already registered. I couldn’t even get the work around to work bc it went right to red and green, no yellow. I was about to give up after I had run through adding it and being rejected when I went to read more responses… When I came back, the light was green and sure enough, it had added itself on to the wifi again. My reasons to go wifi were 1. CenturyLink blames EVERYTHING on what’s plugged in to their modems and 2. I wanted to move it in to another room. Hope this helps someone, i guess just be patient. I’m terrible at this so maybe go Google more and come back :rofl:

Hi Dak, how did this work out for you? I’m trying to switch from LAN to WiFi but don’t want to lose all my z-wave devices. Did the hub reset make you lose them?

Hi - I’m sorry to say that I never did figure it out. I decided to leave well enough alone. My issue was actually needing more repeater devices to spread my Zigbee signal. Adding a couple more outlets/sockets did the trick. Good luck.

Why hasn’t this issue been addressed? The original post was from almost two years ago!!! It’s absolutely not acceptable that there is no network configuration control in the ST app. When will the app be updated to include this basic functionality?

I have many frustrations with the ST platform being a LOT less “smart” than it should be, but this takes the cake. What a massive oversight!

1 Like

This is what you need to do.
It will not delete your settings or your stored devices.
Disconnect the ethernet cable if connected.
Disconnect the power.
Connect the hub to the power and wait a few seconds until you see the flashing blue light.
Press the reset button for about 5 seconds until you see the flashing orange light.
Go to the smartthings app and add new device
Choose connect via wifi and input your wifi settings and continue.
You will get an error message at the end saying the hub is not in reset mode. Unplug the hub from the power and plug again. Wait for solid green light and you should be good and connected via wifi.

2 Likes

Hi anyone!
I’m struggling with switching from ethernet to Wifi.
I’ve followed the above advice but the flashing orange light quickly switches to flashing blue.
Is it supposed to stay flashing orange while I access the app ?
Am I supposed to delete the hub and then re-add it? If so, I can’t figure out how to do so.
Any advice appreciated.
Thanks
UPDATE: I was able to reset it and it’s now on Wifi. My next challenge it to pair my LeakSmart valve and devices to it.

this works.