Newbie broke it again! (New router, now how do I changeover ST V3 hub?)

Sorry about this folks, but I’m looking for some more help with this again. We had, until recently, a rubbish AT&T 4g modem. It was 10mb and we had loads of stuff connected. Not surprisingly, half the time it didn’t work very well. It was so bad we had to have two connections, one for the smartthings stuff and one for the house.

Now, we finally got Telmex to fit proper internet and have a whopping 100mb connection. It’s not as good as we had in the UK, but from 10 to 100 is like Spam to Filet Mignon! So, now that we have a decent connection, I wanted to set the SmartThings hub up on the new network. I couldn’t figure out how to simply change the wifi, so I deleted the devices and did a factory reset. This seemed to do the trick and the hub saw the few Hue devices I’d setup straight away. However, it doesn’t see any of the other devices at all. I tried setting up the GE switches but none of them are seen at all. Yesterday, after about 4 hours searching, it found one. But even after adding this one, it doesn’t seem to be a valid one. I can’t find which switch it is as switching it on and off doesn’t change any lights at all.

Can someone tell me how I get the devices back on please?

Which model smartthings hub do you have?

( there are eight or nine different hub models now and they do have somewhat different features, so in the future it will save everybody time if you specify which model hub you are using, which version of the SmartThings app you are using, and which country you are in.)

1 Like

Are the GE switches z-wave versions? If they were previously connected to your hub, you will need to perform a general device exclusion on all your z-wave devices.

for classic app:

if you are using the STSC app, let us know.

1 Like

JD, The hub is v3 I think. I only bought it last year. I can’t find a model number on it, but it’s square with a small green light on the front. The Amazon order page says "3rd Generation [GP-U999SJVLGDA] "
jkp, does STSC mean the Classic app? If so, I’ve got both. JD told me to install the classic app a while ago, and thankfully so, it was much easier to install stuff using it than the other one. However, neither seem to help here. I tried both. I’ve tried putting the app into general exclusion mode but it says mode active and that I need to go to the manufacturers site for instructions on how to exclude it. I can’t find anything on the GE site, or Philips, or Shlage that tells me how to do this (sorry for the dumbness!)

STSC = SmartThings (Samsung Connect) or the newer app.

For GE switches, put the hub in exclusion mode and press the toggle or paddle on the GE switch. you should see a message in the ST app that a device was excluded or something to that effect. Then you should be able to pair it, choose Add Device and press the toggle or paddle on the ge switch. sometimes you may need to click a few times on the ge switch when adding before it is found.

1 Like

Ah ok. That makes sense. I tried that with both the classic and the new app but I never get the message. It just keeps spinning in the classic and says no devices excluded in the new one.

I did just watch a video that says I need to flick the tab out at the bottom of the switches. This worked for the kitchen switch, but isn’t working for any others.

I’m kind of surprised that the SmartThings hub “cared” what was providing its Internet connection.

I recently had my ISP change from a DSL modem to optical fiber, didn’t have to do anything to my SmartThings hub.

If I’d created the new 100mb network with the same SSID as the original rubbish 10mb it might not have cared, but I changed it to a new name since the old one was still up.

OP said they didn’t know how to change the wifi settings on his v3 hub → I couldn’t figure out how to simply change the wifi, so I deleted the devices and did a factory reset.

The hub you have is called the V3 or the 2018 hub. There are some features, including setting it up, for which you have to use the new app.

It turns out that changing that particular model from one Wi-Fi network to another Wi-Fi network is just both complex and tedious because of the cloud component. You have to get the hub to disconnect from the SmartThings cloud long enough to register as off-line in order to make the change. See the following thread, which has contributions from several smartthings staff members.

1 Like

Ah, that explains it.

When I converted from “traditional” Wi-Fi router+extender to eero mesh, I stuck with the same SSIDs and passwords to try to avoid having to update the 40+ devices I have in the house. There were still a few that wouldn’t connect but happily the SmartThings v2 hub wasn’t a problem

1 Like

@Tim_Foster, I posted a small suggestion to try in How to Update Smartthings Hub (2018) Wifi Settings?

I’m also looking for some basic info from people having this issue if that doesn’t help.

Hi @psbarrett. This may have helped had a discovered it earlier. Unfortunately, I’ve already reset it (sort of). It’ll definitely be helpful next time though.

I’m still no nearer to getting things back up. It seems that most of the GE switches aren’t being seen. Nor are the GE fan controllers. Philips Hue is also have problems. I have the regular Hue bulbs seen in Hue and then SmartThings sees those and the Hue bridge, but the strips aren’t being seen by either Hue or SmartThings.

I’ve tried the reset method for the GE devices, both trying general exclusion in ST classic and pressing up (both with the light on and off). I’ve also tried pulling out the tab at the bottom of the switch to factory reset it, but I still can’t get any to be seen. One, the kitchen switch, did get picked up, but I don’t know what I did to make it work. I was just searching and going back, searching and going back and eventually it saw it. Nothing for any of the others though.

For the Philips Hue strips, their solution at the moment is try adding by serial number, which would be fine, if the serial number wasn’t on the sitcky side where it has been stuck to my wood panel for six months. Trying to remove it just pulled the plastic box apart!

I don’t have any GE switches but, on the dimmers I do have, the tab at the bottom is an air-gap switch to ensure there is no power going to the fixture. It’s primarily to make sure it’s safe for b you to change bulbs.

Yes, that was what I understood it to be. I was following this video and it seems to cut the power (when that’s a reset or not, I don’t know) but still doesn’t let me add them agai.

I’ve emailed Jasco to find out how to properly reset them.

According to Jasco, the reset is to press up three times and down three time in quick succession. I’ve tried this on all the switches though and it doesn’t flash the blue light on any of them as they said it would.

the method to reset GE/Jasco devices is different for different models of the zwave switches.
Usually, you can find details for “factory reset” in the product manuals, which are available (for current products) on the product pages (support section) at

OK folks, quick update. I spoke to Jasco, and the latest series, the 500 series, can be reset to factory settings. With the light off (not sure if this was necessary, but it worked for one, so I wasn’t going to change what I did), press up 3 times in quick succession (and I mean quick) and then immediately press down 3 times in quick succession. The blue light should flash for a second or two. Then if you set SmartThings into discovery mode, it finds the light again and you’re all good.

Thanks to Jasco for that. They were very helpful. Unfortunately SmartThings, not so much.

Now, I just have a couple of Sylvania strips to get back onboard and the remaining Hue strips and I’m back up to speed.

Unhelpfully, Philips put the serial number on the side of the control box that is stuck to the wall. We only had our kitchen installed in September and the box is stuck fast to the wood panelling. Hue seem reluctant to agree to make good any damage in removing the box. I’m fairly sure that having it find the lights by serial number will work, but general discovery doesn’t. I don’t see that it’s something I should take the hit on because of the bad design by Philips. If the general discover doesn’t work (which it often doesn’t hence the option to add by serial number) then I don’t think it unreasonable that print the serial number in an accessible area, like, erm, the front maybe? Printing it in the area that is least accessible is ridiculous.