New hub v3 owner. When adding hub to app, it gets stuck on update page


#1

It gets to 99% and never moves past that. Waited 20+min with no change. Tried a factory reset without success… Any ideas?

Edit: additional info, the hub flashes blue led constantly during the stuck on update screen


Can Not Get Smartthings Hub V3P01 to Run in WiFi Mode
(jkp) #2

Probably best to contact ST support and let them look into it. https://support.smartthings.com


#3

I did and have received no responses. This is my secondary source of trying to get help :confused:


(Jeff C) #4

I had the same issue and resolved it be re-settting the hub and connecting it via ethernet into the router, then restarting the entire process.


#5

Did you then switch it back to wireless? I did try hardwiring and it updated fine, but then there doesn’t seem to be a way to switch it to wifi without a hard reset (which leads to the same original issue)


(Jeff C) #6

No, I didn’t try going back to wireless. I was okay leaving it wired. (Although not my preferred installation.)

Interesting that the problem persists when switched back. I thought the hub stored the update info, so it would have simply launched in wireless mode. Frustrating.


#7

Yeah, I got it specifically for wireless (as opposed to v2) so if I can’t get it to work it’ll probably be returned. Disappointing.


(Brad) #8

You can connect via ethernet and do a soft reset to switch it from ethernet to wi-fi.


#9

Will try this but I do anticipate it will get stuck on the update page again.


#10

Followed those steps and this is what resulted:

Even though it was updated via ethernet, when I soft reset it and then tried setting it up as wireless, it still went through and did the same update (57mb). It got to 57/57mb, 99%, with a magenta flashing led, and once it reached 57/57, led turned off for about 20sec, came back on solid red, then blue then back to blinking blue.

I’ve only ever been able to get blinking blue, when setting up wirelessly (aside from magenta while it’s installing the update).


#11

I had to factory reset my hub, which was working previously, and now this is happening to me as well. Hanging at 99% update and blinking blue,


#12

Add me to the list of people suffering from this frustration. I need to be on Wifi so I can pair with my Schlage lock which was already installed. Ethernet worked, but trying to setup for Wifi has been a nightmare. Finally had to factory reset and now I am stuck at 99% of the 57MB update with led constantly blinking blue.

Very disappointed with Smartthings ease of setup so far (and I’m a fairly technical end user).


#13

Please post here if you find a solution and I will do the same. No luck so far.


(Tony Glass) #14

I’m getting the problem too: 57/57 99% hang.

Makes me think this is a problem on Samsung’s side, not ours. I too am trying to connect a Shlage lock (already intstalled), so I need the hub on wifi. Waited excitedly for this thing to get here now stuck with this. Samsung please acknowledge and advise!


(MarkB) #15

I am in the same boat, but with a little different start. When I first set it up it worked great. I then unplugged it to set up a lock and when it rebooted after power up it went to the blue blinking light. I reset it with the above reset and was able to get it to connect to my wifi but when i moved the hub again it went back to the blue blinking light and I have not been able to get past it unless I plug it back to the router via network cable.


(Tony Glass) #16

Anyone have any luck resolving this? I’ve about given up, planning on sending the hub back to amazon tomorrow morning if all else fails.


#17

OP here. No solution yet. Contemplating a return as well but going to see what they recommend for fixes before doing so.

Please update here if you do get yours working.


#18

Hi folks. I ordered a v3 hub from Amazon as well. Experienced same issue that OP described. Called customer service, spent hour or so on phone with them. Nothing helped the issue so they said they’d escalate and that someone would call me within 72 hours. That was sometime last week. No return phone call yet. I figured I just got a bad hub, so I stopped in Best Buy this weekend and picked up another…same deal as before!!! So now I have 2 of the v3 hubs stuck in the same offline state because they hung up during the initial setup update process. One of them was wired for setup and one was wifi setup. Both did exactly the same thing. I would love a fix for this if anyone comes up with one!


#19

@Brad_ST These instructions you provided are not working. The hubs go “offline” when they hang up on the update. Do you have an email or phone number for anyone in support who can help us through this issue? I’ve purchased 2 different hubs in the last 2 weeks thinking that the problem was on my end. I spent over an hour on the phone with a support lady last week and got nowhere. I’m still waiting on a return call, with no luck. PLEASE HELP!!! :thinking:


#20

So the latest from a thread on Reddit is that this is an issue with Samsung phones and Smarthub V3… go figure!

Do all the folks with this issue here have a Samsung phone? I have an S9+. Perhaps try with another android device if available and see if you have better luck. Apparently Samsung is going to have to release an updated version to the app but that may not arrive very promptly.