SmartThings Community

How to Update Smartthings Hub (2018) Wifi Settings?

(Michael Leonardo) #41

To clarify, there is no way to select the “Update Wifi settings” part of the process. It’s grayed out. I’ve tried everything. I was told by support that this is for the integrated hub/router model.

0 Likes

(Tony Fleisher) #42

Did you see this note from earlier in this thread?

0 Likes

#43

See post #13 in this thread

0 Likes

Hub V3 WIFI
(Michael Leonardo) #44

Yes, saw that. Still no go. So you all have that option available with a disconnected v3 hub? I’ve tried everything. Like I said, I gave up bc support told me on the phone that this wasn’t possible yet.

1 Like

(Brad) #45

I believe the feature was added in December’s app update. Is it possible your app is out of date? Your Hub is definitely in a disconnected state when you are attempting to update the settings?

0 Likes

(Michael Leonardo) #46

Yes confirmed on both. I’m usually on top of app updates. Both the classic and new app are up to date. By disconnected, we’re talking about power correct? I know that’s a silly question but I’ve tried this so many times thinking that it’s possible. But again, phone support went and checked with a higher level tech and came back to explain that this wasn’t possible yet to the general public.

Does it have anything to do with the classic app being installed or running?

0 Likes

(Brad) #47

Well it’s more than just removing power. The cloud has to indicate that the hub is in a disconnected or offline state. You should be able to confirm that in the mobile app or the IDE.

If you’ve confirmed the cloud/mobile app thinks the Hub is disconnected or offline and you’re not seeing the Wi-Fi configuration option, that is a bug.

0 Likes

(Michael Leonardo) #48

Absolutely a bug. Both of my ST apps indicate the hub is offline before I attempt to change networks.

I will ask this though, when I was on with phone support and mentioned the instructions you outlined above, they told me that holding the reset button for 15 seconds was definitely a factory reset and that I would lose everything. I never did that bc I couldn’t chance it with so many things setup.

I did follow the instructions here to a T - https://support.smartthings.com/hc/en-us/articles/115002084806-How-to-add-a-SmartThings-Hub-in-the-SmartThings-app

I can always get to “scan or enter serial number” and neither option leads to a success. Is there anywhere ST can see an error? I assume somewhere in my app log?

0 Likes

(Paul Osborne) #49

Just to confirm, for step 8 from the support article:

  1. Once the LED turns solid green, using a pin or a similar tool, press and hold the reset button on the back of the Hub until the LED begins blinking green and red

Were you able to confirm the LED was blinking red/green. The reset button here will need to be held for between 2 and 7 seconds in order to get the device (when green/claimed) to enter “reconfiguration mode.” This is different from a factory reset – it is just enabling the Wi-Fi Soft AP used for changing Wi-Fi creds (it is disabled normally as it would otherwise present a security risk and affect Wi-Fi performance).

If the LED is not red/green, the scan/enter serial step will fail as the mobile app will not be able to see the Soft AP of the hub.

0 Likes

(Michael Leonardo) #50

Yes, I had done that step the first few attempts. Now I’m wondering… would an ethernet cable plugged in affect that at all? It definitely wasn’t connected to the router but just in the back of the ST hub. I will give it a go again tonight without it.

0 Likes

(Paul Osborne) #51

Certainly worth a shot. You can also confirm that the Soft AP is present by checking to see if when the hub is red/green there is an AP around named hubv3-XXX where XXX are the last digits of your hub serial number. The phone gets the credentials to connect to that AP from the scan/entering serial and then uses that connection to do the rest of the configuration.

0 Likes

(Michael Leonardo) #52

Paul, sorry, I think the issue is that I can’t get to step 8 because the option is grayed out. Nothing I do makes that option available in the app, disconnected or not. Does that not matter?

Update: I’ve also tried to bypass the “select change network option” and went into config mode, confirmed the ST network is broadcasting, the QR is scanned fine, and the setup always dies at 64% with “Couldn’t register hub”. My guess is because I’m not able to select that update wifi option in the app.

2 Likes

#53

Updating connection preferences appears to be impossible on the V3 hub at this time.

1 Like

(Michael Leonardo) #54

That’s what I’ve discovered. But why is everyone here saying that it can be done. I’ve followed all the steps.

0 Likes

(Michael Leonardo) #56

Any updates here? I’m on the new and latest ST app and this option is still grayed out. Hub is showing disconnected yet the option to “Update Wifi settings” is still grayed out. What am I missing guys?

0 Likes

(Patrick) #57

@leonardo, what version specifically, do you have installed? I have 1.7.27-25 installed from the Play Store and it appears to me, at least on my device, that the “Update Wi-Fi information” button now works any time, not requiring the hub to be offline.

0 Likes

(Michael Leonardo) #58

Hi Patrick, here’s what I see. It’s really driving me nuts bc I need to get my hub more central and resetting and starting over is not an option. Could something be stuck from a previous wifi connection?? Is there anyway for a developer to get in there and see what the problem is?

0 Likes

(Patrick) #59

Hmm, that is odd. I do see a very brief flash of the button being greyed out when I go to that screen, so it’s still checking something, but I don’t know what.

Are you on a Samsung phone? I know at one point the app was automatically using the wifi settings from the phone on samsung devices. If so it could be something related to that.

Also, just to make sure:

  • you’re trying to change the connection settings on a V3 hub
  • you’re signed into the account that has already claimed that hub
  • you’re viewing the location that has the hub before clicking the gear icon

Is that all correct?

0 Likes

(Michael Leonardo) #60

That is all correct. Yes, I’m on a Galaxy S8+. I’m currently connected to my router via ethernet. I do not have the old network anymore but wondering if the issue could be that it needs to be on the old network to be moved?

0 Likes

(Patrick) #61

It really shouldn’t need to be on the old network. I can’t actually think of a way that the app could know it’s has been switched to ethernet as long as it has an active internet connection.

Unfortunately I don’t know who to poke for app issues any more, but I’ll ask around and see if I can find anyone that does.

0 Likes