Update Wifi information on IOS app - option unavailable

I cannot change the wifi connection on my SmartTHings Hub (IM6001-V3P04)
I just replaced my Wifi router and , the option “update Wi-fi Information” under Settings is not available on my phone app (the text is gray and inactive).
The hub is trying to connect to my old wifi network - i tried the reset by pressing the reset button and it always returns to flashing blue light (cannot get the flashing red/green light to turn on).
Did anyone has a solution?
Thanks a lot!

1 Like

Hi, did you manage to resolve this in the end? Thanks!


Hi, thanks for the link. It sounds like its resetting the hub. Does that mean all the devices connected to the hub will be removed?

Did you read the article at that link? It specifically says of the method listed in the article:

This will not affect any devices connected to the Hub, and does not require a factory reset.

That specific method doesn’t have anything to do with resetting the hub: it’s just changing the Wi-Fi credentials.

Yes. Thanks for pointing that out. I wanted to find out if anyone has actually done it.

Also, as stated in the original post, the option “Update Wifi Information” in the SmartThings app is actually greyed out and can’t be selected.

1 Like

Then you will need to contact support:

A quick of update on this:

Turns out that this is only an issue for non US V3 hubs. The method described here (link) works for US V3 hubs. I spoke to someone really helpful from SmartThings support and he mentioned that this matter will be raised. Hopefully, it will be fixed soon.

Another thing, in that method, the Hub doesn’t actually flash red and green after the reset button is pressed, it flashes yellow. Which is good, because it won’t be confused with adding devices or when you are adding the hub for the first time.

1 Like

Was this ever resolved? If so, how? I’ve run into this now myself having just put in a new Deco setup.

I’ve reached out to ST Support for help to try and get this resolved. Will update if I get anything back.

1 Like

Can you email mobile app logs to support via your current support ticket? Force close the app, re-open the app, navigate to the menu where the option is greyed out (overflow menu → gear icon). Then collect app logs: overflow menu → Help → Report a problem → “Create a log?” OK. Thank you!

Done now Brad.

Thanks, I am not seeing the logs attached to your support ticket #1174610. Did you sent them to support@smartthings.co.uk?

Hi Brad,
Not sure why they didnt attach but I just mailed them into support@smartthings.co.uk now as part of my conversation with Hannah who pointed me to this post to try:
How to Update Smartthings Hub (2018) Wifi Settings? - #84 by Shane_Dorey

Before I try that though, I’d like to make sure that it wont destroy my current ecosystem.

1 Like

Thank you so much! Based on the logs it looks like your v3 hub is incorrectly being identified as a v2 hub so the ability to change Wifi is not presented in the app. That is a major help in getting the issue resolved platform-wide.

As for the steps listed in that other post, my initial thought was that it wouldn’t do harm but wouldn’t work. I tried it though and it does seem to work. The main thing is to release the reset button while it is blinking yellow. Holding it too long and then releasing it could possibly reset the hub and connected devices.


Thanks Brad. Is this likely something that will be fixed or do I need to go through that semi-reset process? ST is pretty much the last thing on my old wifi network which I kinda would like to switch off.

It will get fixed but I don’t have an estimate as to how long that will take. I believe it is a cloud-side fix which would be quicker than an app update though.

1 Like

Cool, thanks Brad. I’ll pause for now but that approach outlined above can be my fallback if I really do need to switch across.


This is now resolved. I got version 1.6.65 of the app today (along with this weeks firmware update) and had the option to change wifi. Did it there now and the hub has moved across without issue.


It was actually coincidental that the app release lined up with the cloud change that fixed this but regardless glad to see it fixed!