Smart Life integration (July 2020)

That’s when I switch to HA

You can control the SmartLife scene with native ST automations. You do not need WebCore.
You only need to wake the SL scenes up once and they will continue to work even if they show offline.
You can wake up the SL scenes using the ST web portal or WebCore.

Agreed. Automations will work, I just happen to use webcore.

One interesting Ive noticed is that if I click the icon of the “device” that shows offline in ST, it won’t work. However, if I click the home icon and then all devices, in that list I can power on the scene and it reconnects. just wanted to share.

Hey! I’m new here but wanted to ask if anyone has been able to figure this out. When I turn on my SMARTLIFE Wifi Dimmer manually it of course will show ON in both SMARTLIFE and Google Home – How can I get Smarthings to recognize this has happened as well? I’m using the simple TAPtoRUN automations to get the switches to work but any advice would be helpful. Thanks!

I tried everything except this and it didn’t work

When i tried this solution i got below error

((# Access Denied

We’re sorry, but you are not authorized to perform the requested operation))

I searched for a solution for it and tried many things including other browsers and incognito mode nothing worked

Anyone can help me?

Thanks

Here is the long version.

Pair each device with the SmartLife or Tuya apps.

In the SmartLife or Tuya apps create separate ON and OFF “tap-to-run” automations (scenes) for each device you want to use in SmartThings.

In SmartThings run the Tuya integration under add a device by brand. Do NOT use the SmartLife integration. (The difference between the SmartLife and Tuya integrations is that the Tuya integration doesn’t end with an error message. And when you look on linked services the imported scenes are listed under Tuya, unlike SmartLife which is blank.

When you go back to the devices tab in SmartThings you will find ON and OFF switches for each device possibly under No Room Assigned.

They will say they are off line. You can wake them up by turning them on and off in the ST web portal, https://my.smartthings.com. You only need to do this once for each imported switch.

Create a virtual switch in SmartThings using create a device in the IDE or using SmartThings Labs on the Menu tab in the mobile app. ST Labs is only available in the Android version of the ST app.

Using SmartThings automations create 2 automations. One will say toggle the “ON” scene when the virtual switch is turned “ON”. The second will say toggle the "OFF” scene when the virtual switch is turned “OFF”.

I have been using for a year with no issues.

FYI: If you open each device in the SmartLife/Tuya app and hit the edit icon (pencil) it will list the “3rd party controls” that are available for that device.

I have a number of SmartLife devices. Most list Alexa and Google controls. Only 1 lists Smartthings and only 1 lists IFTTT.

Any SmartLife/Tuya automations or scenes you create get integrated with SmartThings. Lol

4 Likes

Great post! :sunglasses:

Just one small note:

As of this writing, The virtual switch creator from SmartThings Labs is not yet available on iOS. :disappointed_relieved:

AWESOME! These instructions are perfect. I would just add, to wake them up in ST web portal, find the device, and toggle switch to ON. Then check your phone and they will be live.

1 Like

Odd issue I am seeing… TAP TO Run scenes that were previously running on Alexa have now been replaced with smartthings scenes of the same name. Is there any way to prevent smartthings from overriding the smartlife scenes in Alexa? Of note they are not duplicates scenes but rather appear to have overiden.

Open the smartthings scenes you don’t want in Alexa and disable them

Unfortunately doing that does not result in the smart life scene returning within Alexa. Disabling just leaves me with a disabled smartthings scene and no smartlife Scene. If I delete the device from smartthings that does result in the smartlife Scene returning to Alexa, but it is eventually replaced and overiden again when smartthings adds the smart life device back, which it does periodically on its own.

Any other ideas? Thanks.

1 Like

Have tried unlinking and relinking the SmartLife skill in Alexa?

Yes, the problem replicates itself again unfortunately.

I am out of good ideas.

If you are stuck using the ST version of these scenes, you may need to “wake then up” once so that they work. You can do that by going to the web application my.smartthings.com and toggling each scene several times to wake them up. You should only need to do this once.

Thanks yes they were awoken. What I am seeing now is that the smartthings scenes from smartlife have states (on/off) which is problematic because the original smart life scenes are stateless. Because of the state, alexa triggers only work if the state is set back to off again after the previous use. Simple enough to fix with a routine, except that turning the scene off again after use results in a second trigger of said scene. Basically it seems like no one thought this through or tested it. Frustrating