Smartlife devices not showing

Just tried my first WiFi controlled smart outlets.
The brand is Nedis and uses the SmartLife app and adding them there was super simple
and the work great.

Added Smartlife via the + sign, SmartLife and then picked an outlet.
This opened up the connection to SmartLife and I logged in with my Smartlife
account. I get a confirmation that the connection has succeeded but the devices doesn’t show up…

Any suggestions on why?
It’s not like I can do much wrong… :slight_smile:



Open the device in the SmartLife app, click on the pencil in the top right and check if SmartThings is listed as a Third-Party connection. Not all SmartLife devices work with SmartThings.

1 Like

You could use it via Alexa though. Just use virtual switch to put it on and off. Complicated but probably only way to make it work.

For few Nedis zigbee based devices there are drivers already. Motion sensor, contact sensor, humidity sensor. They work flawlessly with SmartThings.

1 Like

Aaaaah… Now that was stupid… :upside_down_face:
Why only have some devices work with ST? :smiley:
I can add them to Google so I’ll run the automations in GH but so very annoying…

Thanks for showing me…

1 Like

Check out this link for adding SmartLife devices that do not have Smartthings integration:

1 Like

Oh that worked perfectly, even with the SmartLife app… :astonished: