Smart life devices not showing in smartthings

Hello everyone,
I have been trying to integrate smart life into smarthings. I understand that not all smart life devices are compatible with smartthings integration. However I do have 3 switches and 2 outlets which claim smartthings capability. Those devices work flowlessly in smart life.
I have linked my smart life account in smartthings, and receive confirmation of successful linking, however no devices are added. Does anyone have suggestions?


An idea… Try adding any random SmartLife device, by brand, through the add device menu, in Smartthings. It doesn’t even have to be a device that exists.

That has worked with automations, it seems to refresh things.

You may want to contact Smart Life support and verify the devices work with their integration. They own and maintain it. :slight_smile:

@N3rdy Open each device in the SmartLife App and tap the edit icon (pencil). Under 3rd party controls Smartthings should be listed if the device is truly compatible with Smartthings. Very few are comparable

Open Linked Services (click gear icon on menu tab) in Smartthings app, and click on SmartLife. Any devices that have integrated with Smartthings should be listed.

Look in “Room not assigned” at the bottom on the devices page to see if they are hiding there.

You could also try the Tuya integration instead of the SmartLife integration. Some times it works better. They are both listed under add devices by brand.

If all of the above fails there is a work around using tap-and-run automations (scenes) built in SmartLife. These scenes will carry over to Smartthings when you run add a device.

1 Like

Thanks so much for your responses. I have tried either linking the service, or adding a device, nothing works. I’ve been talking to smart life support for month (since december last year!!!), and go in loops: unlink the services, delete the device, re-add the device, send us a video, send us the device ID… Until I get the "be patient, the issue is being investigated (december 20), then back to delete device, is it listing smartthings, are the app up to date, re-add device, unlink, link… It’s driving me crazy haha
@Paul_Oliver you are suggesting it also should import the tap-and-run automations to smartthings? I have a bunch of those, some involving the few smartthings compatible devices I have in smart life, and neither devices nor automations are imported.
Is there a region specific restriction on linking smartthings and smart life? I’m in Canada, and we do seem to get features later than our big brother from the south…
I’ll try adding a device to tuya and link, but everything is in smart life for me, it would really be a bummer if I had to re-add all my dozens devices and recreate my automations in Tuya instead of smart life…

@N3rdy You can use the Tuya integration with the devices in the SmartLife app. No need to change apps.

I don’t think it is a regional thing. Lots of Australians use SmartLife devices and comment on these pages. I an in the US.


Just another thought…

When I was trying to get my tap-to-run (scenes), which I previously describe as “automations”, Nothing was working until I performed the Smart Life to Smartthings authorization, and then the Smartthings to Smart Life authorization. I don’t really remember how those were initiated, though.

Hoping that might help.

edit: I suppose the both authorizations could have been essentially the same thing, but I’m pretty sure one was initiated from Smart Life, and the other from Smartthings.

The Smart Life app for iOS was updated two days ago and it is completely different.

  • they switched it to landscape view which I hate
  • they have removed all the settings for 3rd party integrations or at least I am unable to find it and I have searched. You can no longer view what you are connected to like the previous version.
1 Like

I actually much prefer landscape view on tablet, but the hilarious thing on mine is that it’s upside down (up is controlled by position of keyboard vs volume buttons), and won’t rotate haha

Thanks everyone who tried to help! I found the solution: after figuring out I also had issued with my link to Google Home, I read somewhere the advice to change the smart life password, which I did and Voila!! Problems with both smartthings and google home link solved! I thought I would share in case someone else experiences a similar issue and stumble on this thread :slight_smile:

1 Like

Just posting here since when I did a search on Google for ST and Smart Life, this was the only good post with info.

As a point of reference, I was easily able to get the Novostella NTF36 integrated into ST using the Smartlife integration.

Thank you I just want to add for me at least, on IOS app, there is still another step after creating the Automation in Smartlife and linking the account/device in SmartThings. The automation does show up as a “device” but it shows as offline.

The “trick” is to then create a scene in SmartThings that uses the device. Note that when you create the scene the first time, the Smartlife automation icon is dimmed, but after you add it/save the SmartThings scene that references it, it then shows “bright”. Now you can use the scene to trigger the Smartlife automation.

This means having to make an on and off automation and scenes rather than being able to switch a “device” on/off but so far this is the only workaround I have found.

1 Like

Hi, just reading through your post. I’ve encountered the same issue with integrating a Smart Life LED plug with SmartThings and I can’t get the device to appear in ST. I have tried changing the password to my Smart Life account but nothing seems to change. Within ST, when I click on the Smart Life integration, it just passes through without prompting me to update to my new password.