[REMOVED] Nest Manager v2.5

###This SmartApp and Device Handlers are Outdated

Please follow the link below to the newest version:


It seems as if the versions between the groovy code and the JSON are inconsistent. After updating to the latest version (via Github in the IDE) I seem to have v2.3.5 but I’m being told that 2.5 is available (which according to Github 2.3.5 is the latest…)

Thanks for catching Andreas… I have updated the code

1 Like

Thanks for the latest update, However when I upgraded I now get that my fan is not supported.

Can you send me a Screenshot please?

I tried to remove everything and readd it, now I can’t get passed this

Damn it… That’s because of the android client bugs. I completely forgot about that. Do you have an ipod or ipad you can use to do the initial setup?

No only Android

Okay It took a while but I was eventually able to choose my location. And the complete uninstall and reinstall fixed the fan

I’m sorry i have tickets in to support but completely forgot about the issue.

At line 262 of the manager code if you change submitOnChange: true from/to submitOnChange: falseit will allow you to move passed that. It will require you to go back once after selecting the location to refresh the page

1 Like

I’ve updated but keep getting notified that there is an update.

After the update I can’t change the temp or the fan mode. What should I do?


I am having the same issue. iOS. Logs dont reveal much. Tried using my cooling temp:


Did you guys open the manager app and press done?

Looking through the exception data I’m seeing a ton of not authorized meaning that person’s token has been revoked. I just can’t tell who because it only collects the exception message. So please verify that your install is functional

Yes, I can confirm it’s installed, working properly from a token perspective. I get accurate updates.

1 Like

Well if there is an error than it will likely generate an error in the thermostat logs or the manager app logs

Nothing in logs but this:

15377292-9778-40f3-be60-bcdb100d6859 9:55:08 AM: trace coolingSetpointUp()…

I hate to ask but did you update the device handlers?

1 Like

I actually didn’t. But I just did and have same issue…also look at the enlarged leaf.