Ikea 5 button remote killing batteries

So I recently picked up two 5 button Ikea remotes and both are killing new batteries with in 24hrs. I have another one and it’s been working fine for months.

Does anyone know of a fix for this issue or is it a bad batch?

1 Like

@orangebucket did you ever sole your Ikea button battery issues that cropped up?

This may not be what’s going on, but sometimes you see this when there are no nearby available parents for new devices so the devices newly added have to resend multiple messages and that uses up the battery.

So sometimes just adding a new repeater, like the IKEA Tradfri smart plug, then taking the hub off line for about 20 minutes so that all the other devices go into “panic mode“ and then putting the hub back on power (which will cause all the other devices to look for a new parent, thus improving the efficiency of the network), will solve the problem.

Most zigbee repeaters can parent 3 to 5 children, although it does vary from model to model.

1 Like

No, my beta hub was put back on the 2.9.0 stack for some more logging but I haven’t heard anything since. My two IKEA buttons I could manage without seem happy at the moment. One seemed to be a bit low on battery last time I looked but is still working. However with 5.1.2 or 5.2.1 they’d be doing well to last 24 hours from new, and certainly wouldn’t survive 48 hours.

I have not had battery life issues on any button on 2.9.0. I have had 100% failure on 5.1.2/5.2.1. I have, however, seen battery reporting issues on both stacks.

I have, however seen reports of similar issues on ST that must have dated from the old stack, and issues on other platforms. The details are beyond my current level of understanding.

Update: Corrected version numbers.


@JDRoberts well as the crow fly inside my house… Yes I know that wouldn’t be straight my buttons are maybe 30ft from the hub. No granted there maybe a couple walls I the way but my other stuff is scattered all over the house with no connection issues. Update to the original post my other Ikea button is a first gen with the big pairing button.

1 Like

So here’s an update approximately 4hr later one button has 47% and the other has 11% battery and both were brand new lithium Energizer 2023.

1 Like

@orangebucket is the 2.9.0 and 5.2.1/5.2.2 firmware of some sort?

Yes, but it is the firmware that is specific to handling Zigbee and often referred to as the ‘stack’. It can be installed independently of the hub firmware and appears as the ‘Zigbee version’ when you view the hub in the IDE. I don’t think you can see it in the app.

I have two V2 hubs so can’t vouch for other hub versions, but …

The hubs have been on Zigbee version 2.9.0 for quite some time. It was apparently updated to 5.1.2 for those beta testing version 35.x of the hub firmware but not pushed out into production.

I enrolled one of my hubs into the beta program in time for version 36.x of the hub firmware and the Zigbee version was updated to 5.1.2 prior to my receiving the hub firmware. It was subsequently updated to 5.2.1. It was not pushed out when version 36.5 of the hub firmware rolled out into production.

Within 24 hours I found most of the IKEA On/Off (aka Dimmer) buttons I had on the hub no longer responded. One or two still worked. One or two could be paired again and worked. The others needed new batteries. Within another 24 hours all the buttons that hadn’t received new batteries had now failed in the same way, and so had some with new batteries. Those buttons remaining on my other hub remained fine. Over the next day or two I got through two or three batteries per button and so switched all but one back to the other hub where they remain (I have since added another to the beta hub to provide more data).

ST swapped my beta hub back to the old Zigbee version and the buttons were happy again. Then back to the updated version and they lasted 24-48 hours. Now back on 2.9.0 and they are still working.

A secondary issue was that I wasn’t seeing battery reporting on some buttons. I know that disappeared from the event history several months back but the attributes themselves remained null. ST noted communication errors had blocked the battery configuration commands. Power cycling the repeaters (Tradfri outlets) the buttons were communicating via and pairing the buttons again dealt with that. However that happened on both my hubs.

I don’t know if this is an ST or an IKEA issue, or neither, or both. It is making me rather nervous though. I need ST and IKEA to be best friends.

Update: Corrected version numbers.

1 Like

I am having the same issue, please bear with me I am somewhat new to this. My Connect Home shows a zigbee version of 5.1.3 on firmware 35.00005 would this still be 2.9? I just got this hooked up from a tradfri hub recently and would like to stick with it. The coin cell lasted about a year on the tradfri hub, and the ST hub will flatten a battery in about a day. I even got desperate and soldered in a pair of AAAs and that would last about a week.

I don’t have a ton of devices and would be fine running an old firmware if it means I can keep my button working Any suggestions?

Sorry, I put the wrong version numbers in my previous posts (now corrected).

Rather than 5.2.1 and 5.2.2 as I originally put, it was 5.1.2 that preempted my beta firmware and then 5.2.1 that came with the beta.

It sounds like 5.1.3, which would presumably be a minor fix to 5.1.2, may have been pushed out to some versions of the hub. Not something I was hoping to see.

No real suggestions except to make sure the issue is logged with support.

I don’t know what is going on but the IKEA buttons seem popular so it needs resolving.

@tpmanley can you provide any insight on things we can do to help troubleshoot or information we can give to support?

A Zigbee update is scheduled for the v2 hubs next week. That could be ‘interesting’.


We shall see. That means I must go buy more 2032 batteries… What’s funny is my 1st gen Ikea button has no issues it’s just the two new ones.

Any word on if the update has been pushed?

Yes, the update has been completed. My hub that was in the hub firmware beta has stayed on the old Zigbee version it had been reverted to by an ST engineer but the other one is now reporting version 5.2.1.

It was updated yesterday evening so if there are any issues I’d expect to start seeing them from about now. I haven’t noticed anything yet. Several buttons are at 0% in the app but are actually showing null values in the IDE and probably merit further investigation in the morning as that was a secondary issue I saw previously.

Just replaced two batteries in buttons and re-paired. Last battery reports 87% and 11% but stopped sending events and couldn’t be reset. I wasn’t methodical enough to confirm the pairing was actually needed.

Any more failures and ripping out ST becomes a realistic option.

I am noticing the same thing here where my Tradfri 5 button remote as well as a Tradfri shortcut button all are consuming batteries like crazy. My 5 button remote went through a brand new CR2032 battery in under a day. Seems like I am on Zigbee version 5.2.1 at the moment. Any other updates so far?

My Connect Home still shows ZigBee 5.1.3… I suppose its not like it can drain CR2032 batteries faster though.

Is there a way to modify the device handler? I don’t even use the button on SmartThings, I just need it paired first to SmartThings to then pair to the lights. (If I just pair the button to the lights it steals them from SmartThings.) SmartThings doesn’t let me use the “hold and release” function of the buttons.

I am also interested in updates, anyone think is it worth reaching out to Samsung for support?

I am tempted to switch back to the Tradfri hub and ditch SmartThings altogether until this is sorted.

1 Like

Yes, because they need to get a feel for the scale of the situation. I don’t know the scale of it myself.

I reported the issue with 5.1.2 / 5.2.1 as part of a firmware beta test so it was being investigated. I haven’t heard any more on that for six weeks or so and I didn’t chase it up as I was busy with other things and my hubs were back on the older stack so I had nothing to contribute anyway. I can’t actually get into Centercode to follow it up at the moment because a new beta is about to start.

The situation has been complicated because there were suspiciously similar surrounding reports quite some time ago, when the hubs would presumably have been on older Zigbee firmware, and I was a lone voice reporting issues on the beta and it wasn’t the first beta with that firmware as far as I know. Also these buttons are popular but the sky doesn’t seem to have fallen in so maybe there are other factors involved.


Today I changed batteries on four more buttons that had stopped communicating properly over the last few days, and wouldn’t work again without being paired. I had a couple already on my other hub, which has older Zigbee firmware where Ikea buttons frolic happily, and two which I moved before they could fail, but otherwise I lost the lot, EXCEPT for one. Unless I have got myself totally confused (possible) it seems to have kept going, bless its little cotton socks, and I’ve absolutely no idea what it knows that the others don’t. It has the same firmware as some of the others, and about the unusual thing it is doing is reporting a direct route to the hub, but I’m pretty sure that is a recent change too.

I should comment that things don’t feel quite the same as they did a couple of months ago. Then it seemed very aggressive - one or two days and the buttons were toast. Now it is more like three days.