Firmware update and zigbee issues

I have seen some suggestion of similar problems happening many months ago with ST, and the same problem has certainly happened on other platforms. However the current extreme problem does seem to be triggered by using versions 5.1.x or 5.2.x of the stack. Indeed I luckily still have a hub running 2.9.0 and that is currently my lifeboat for these buttons.

That doesn’t place the blame on the update per se. The buttons may have dodgy firmware and I’m getting a bit worried about the IKEA outlets too.

34-302 is a very common error indicating that while in “Add” mode, the Hub did not find any device and there are no new devices in your “No room assigned” category. Basically, nothing added when the hub was expecting something to be added (Zigbee, Z-Wave, LAN).

If you want PM me your Hub’s Serial Number, I can have a closer look.

@garrett.kranz my zigbee devices (ikea dimmers) stopped working after latest update. They are draining battery within a day. Prior to this, battery would last for months/year. Now a day!!!
Also devices need to be readded

1 Like

Hi @garrett.kranz ,I’m going to post in the beta topic, but something is definitely odd with Zigbee devices for me.

1 Like

@garrett.kranz I have had problems with my sengled light strips for a few weeks now. It would hold the connection for 2 days & now it just drops. I have 3 seat in my kitchen & hub in livingroom next to kitchen & never had a problem the last year. Any chance I can get your assistance?

@garrett.kranz there are more issues with zigbee devices in last couple days, reported here.

1 Like

Yes, please do. Are you aware of how to send Hub Logs via the IDE? Being able to send those when you are experiencing an odd behavior would be very helpful to look into this for your Beta Hub.

Let’s start off with checking your WiFi Router’s 2.4Ghz Channel compared to your Hub’s Zigbee Channel (these two should be sufficiently separated). This can be found when logging into the SmartThings IDE → “My Hubs” → “View Utilites” → “Zigbee Utilities” section and it is listed/configurable there.

I’d also recommend trying powering down your Hub for an extended period of time (~20 mins) as this can help the Zigbee Mesh re-build itself.

Last but not least, if your entire Zigbee mesh relies on bulbs, that’s something I would look at correcting for the long-term stability of your network. Get some Outlets, Switches, etc. that are AC-powered and designed for a reasonable load.

Sengled Bulbs generally do not repeat, but some do and even those should not be the main Router nodes in your mesh as a best practice. Hope this helps, if not please do reach out to Support@SmartThings.com.

That first one was an example of a warrantied return and the second one (IMO) sounds like it could be an IKEA device issue (“I recently picked up…”). Willing to be wrong of course, but we do need people to report via Support Channels (and someone should probably also try and report to IKEA) to properly triage such issues.

Hi all I managed to fix mine, seemed a really odd fix, just to add something else to consider (I never did), this was my reply to SM

Hi I am getting to the bottom of this, 5 weeks ago I got a unifi dream machine, for 3 of them the 2 devices worked fine next to each other.

I think the update to zigbee changed something, and they no longer like to co exist.
It does not apear to be a wifi interference more of a physical interface not sure why this changed.

By moving the smarthub about 10" away seems to have solved the issue.

I found something on YouTube that led me to try this.

Sounds a but like marriage to me!!!

Wifi that is too close to your hub can kill your Zigbee even if it’s not on an overlapping channel. The reason for this is that the radio transmission is never completely clean and restricted to the specific channel. There is always low level side noise but it does drop off pretty quick with distance. By putting some distance between the Wi-Fi and the hub to can often eliminate the effect. I would try to put 10’ between ion you can. You might find it help your battery life as well.

1 Like

Would you say this is a slow degradation on the zigbee over time or is it bang and dead?

Sorry when I said kill I meant interfere with the radio transmissions to the point that devices lose events, drop off, etc. It would not cause long-term damage. Putting some distance between the Wi-Fi and the hub should see the situation improve almost immediately.

Yup, I’ve done that so many times I’ve lost count. I did it again a few minutes ago as well. So far the last 15 hours have been calm, but I expect that to eventually change based upon history the last few days.

1 Like

@garrett.kranz thank you for responding. I saw your message this morning but had to go to work. My zigbee channel is 20, the 3 single light strips that are causing me issues are in my kitchen & my hub is in the living room. I only have a halo zigbee light in my hallway & have no issues with that light. I have a iris smart plug downstairs that sometimes my sengled lights would connect too & I moved that plug. As I have said, I have has no issues doe a long time, years but I did recently replace my router with a linksys wifi 6 mesh router. My smartthings hub is next to my router & has been in the spot since I first got it. I could not see the channel for my 2.4 ghz on my router so I called linksys but have to wait till I get home today.

No problem!

Usually with mesh systems (in my experience) the Channel they use is non-configurable or at least has only a few options. Once you know what this Channel is, you can use the IDE to change the Zigbee Channel of your Hub should there be overlap.

If devices are going “Offline,” they are both not responding to their scheduled “pings” in a timely manner (response required in 15 seconds for Zigbee) and the events they produce (On/Off/Dim/Perhaps Color for these light strips) are not making it to the Hub. I’m not going to dismiss the possibility of either the Firmware Update for the Hub or the Firmware Update for Zigbee (separate items that occurred at separate times) from causing issues, but I will say your behavior is unlikely to be caused by either.

Best of luck with the troubleshooting, let us know how it goes!

@garrett.kranz I just spoke with linksys & was able to figure out channel. My bands are split, with 2.4 in channel 20, 5gh is auto. My zigbee channel on smartthings is 20. What should I do? Thanks.

2.4 Ghz WiFi channels are only 1-14. Zigbee channel 20 is between Wi-Fi 8 and 9 so as long as your Wi-Fi is not on either of those and more than a metre or so away from the hub it should be OK. The more distance the better.

BTW, 2.4Ghz Wi-Fi is usually on channels 1,6 or 11

I would recommend making your Hub’s Channel something other than 20, which can be done using the IDE found at https://account.smartthings.com.

  1. Log in.
  2. Click “My Hubs.”
  3. Click “View Utilities.”
  4. In “Zigbee Utilities” section, you’ll find a drop down list of available Channels.
  5. Select a Channel and hit “Update.”
  6. Allow some time for this to change.

If you have older Kickstarter generation Zigbee devices, the lowest you can go is 14. If you don’t then maybe start with 11 and gauge results from there.

@garrett.kranz ok I will try. I only have a halo signed light in my hallway, couple of windows sensors which are smartthings & lowes iris so I’m not site zwave or zigbee. The rest is zwave or wifi hooked up via cloud. Thank you.

All of the brands you mentioned here specifically would be using Zigbee (Halo, SmartThings, Lowes Iris).

i only had one bosch motion that was part of a dual-facing setup that stopped responding to motion despite saying it was still online. the fix was to pop the 4 batteries out and put them back in then it started working again.