New Ikea tradfri Shortcut Button?

Work for me although I change it back to Ikea button after works perfectly

1 Like

Hi my friends, in resume, can I think with confidence about integrate New Ikea Tradfri Shortcut Button to my Smartthings ecosystem ?

Hi my friend, then do you recomment standard pairing and pick up the Ikea Button DTH to get it work ?
Thanks !

Unfortunately, just recently people have started reporting a new problem with these devices, that they are going through batteries in just a day or two. It seems to be an issue with polling after a recent Update to the smartthings’ zigbee stack. See the following thread:

1 Like

I took a stroll over to Ikea this morning (actually that isn’t right, I caught a tram) and while I was there I picked up one of these shortcut buttons to see how I got on.

I took the approach of assuming they behave in the same way as the other Ikea buttons and so added them into the Ikea Button handler in the same fashion others have been added. That is certainly a valid approach as pushed and held are working. Just waiting to see if the battery makes sense when it puts in an appearance.

Then I have to see if they suffer from the bonkers battery bug.

UPDATE: The battery is reporting fine. It was reporting half the correct value but I’d missed a method that identified all the IKEA devices that was used to prevent a divide by 2 (the DTH also handles a SOMFY device).

1 Like

This worked for me but button burns baterries within a couple days. Tried different brands same results

This didn’t work for me however changing the Label to “Zigbee Button” instead of “Shortcut Button” worked a treat.

I found this thread around the holidays after seeing the Shortcut Button for $15 on, and thought I had a perfect use case for it. I waited patiently for the Shortcut Button to be available anywhere in eastern Canada, but it still isn’t, and unlike elsewhere, if IKEA Canada doesn’t offer something in a region, they won’t make it available for delivery. I finally gave up and ordered off the US site for $16 US shipped (to a mail-forwarding warehouse on the border) and picked it up yesterday. And then I saw all the recent messages here and at HE about the battery issues :flushed:.

Anyway, just reporting in that I had trouble getting it discovered in ST, tried your method, it was discovered and paired with the generic ZigBee Button DTH, and it works fine for my purposes (“on or off”). Thanks!

Battery showing 89% right off the bat, I’ll keep an eye on it over the next few days. I’ve had bad experiences with batteries in Sonoff and Dome sensors as well as Sensative Strips, and I’ll be disappointed if the same thing happens here.

We have the same battery?! :innocent:

Here the problem of empty battery, 2 times. Now the problem is solved, the battery is fine for a week.

The 5-button puck from Ikea didn’t suffer.

Grtn Ben

1 Like

Kan zijn! Lol :grinning_face_with_smiling_eyes:

FWIW it amuses me that I’m using this (nominally) $10 button to “dumb down” a smart integration in my home. Basically it’s a bedside button to turn on (and preheat) my old-school Rancilio espresso machine in the kitchen as I’m getting out of bed. I had been using a variety of routines and automations based on time, presence and triggers, and five days out of seven I’d find that because of distraction and my weird sleep schedule, the machine would idle needlessly for a few hours a day. I put a Kill-A-Watt on it last week and found that it alone was consuming more than 1 KWh per day, for my two espressos. :man_facepalming:t2:

15 or 20 minutes of preheating the hefty brass contraption is plenty (and then two coffees in a half hour), and this dumb solution cuts that consumption by about 75%. It’ll take about 15 months to get a ROI on the IKEA Shortcut Button. :joy: But it also reduces wear on the espresso machine so hopefully I can extend the MTBO on it (currently around 3000 hours, and ~$80 in gaskets and parts, plus several hours of my time).

Dead. Useless.

I managed to get three days out of the original IKEA battery. Yesterday it showed 56% and last time in the log was at 22:40 (had only been pushed once yesterday, at 10:20 am). This morning still shows 56% but completely dead. Fresh Energizer battery, paired twice more to get ST to see it, back to 100% and functioning. Volt meter shows old battery at 2.36V. Great.

This worked for me! 89% SOC for battery Out of the box. Hope no loss on battery in Long term

Update #1: Morning the battery is showing 100% - lol

1 Like

I’ve managed to get the shortcut buttons to work. Firstly you need to add the buttons to the tradfri hub so it can get the firmware update and set to all off in the ikea app. Then start up the smartthings app and add a new device, Remotes and buttons, then ikea button. Follow the instructions and press the pairing button 4 times and wait for 10 seconds for the shortcut button to reset then hold the pairing button for a further 10 seconds and let go and after a few seconds it should pair as a ikea shortcut button, with short and held press and with the battery percentage. Hope this helps


Hi ST tribe !
Do the tradfri buttons problem about drain battery power is solved?
I am waiting to purchase them…but I do not want get problems in my new devices.

This issue is being discussed in detail in the following thread. Look near the end for the most current comments. Some people are definitely still having problems.

Ikea 5 button remote killing batteries

1 Like

I’m testing 2 Shortcut buttons at the moment, each on different V2 hubs.

One I’m using the “Ikea Button” custom DTH. It has gone from 100% to 30% battery in 21 days with very little use (idle except for testing - its not setup to trigger any actions).

The other I’m using the “Zigbee Button” built in handler. It’s still at 89% in about the same timeframe.

1 Like

Add to Tradfri Hub? So, because of this button we need to buy one more hub?

Changed the battery July 6, still works, still shows 89% with the generic button DTH.

1 Like

Died on September 14, app still showing 89%. Exactly 10 weeks. Just got around to changing the battery, still shows 89%. :crossed_fingers: they solve this some day before I run out of batteries.

1 Like