New Ikea tradfri Shortcut Button?

Hello, is there already a device handler for the new Ikea a button shortcut button?

3 Likes

@BroderickCarlin, will be a device handler for new IKEA button?

No news, on the shortcut button ?

Is possible to add this button? I’ve tried adding it as an Ikea button but it just added as a “Thing” so edited it in my devices in my Smartthings account and changed it to Ikea button and ZIgbee button neither of them work. Any advice?

I’ve had luck with adding the Trådfri shortcut button and then changing the device type to a “Zigbee button”. This enables battery and single press but NOT hold function. But a single press is better than no press I guess.

2 Likes

This gave me hope, but I can’t get it to work this way, unless I’m doing something wrong…

I just connected the button with my hub, changed the device type, closed the app and waited 2 minutes and then it worked.

Just bought this yesterday. doesn’t seem to be working for me. It connects as a thing but changing handler doesn’t do anything …

Ok figured it out, the key is to change the Name to zigbee button. changing just the Type doesn’t work.

That’s weird… Didn’t do it for me. When I reset it and add it again it comes up right away as ZigBee button though.

I have been able to add the tradfri shortcut button to my hub (shows in IDE and app), but unable to get it to trigger any actions. I had it set up as an IKEA Button and also tried it as ZigBee Button. Neither registers a button press. I have the NVidia Shield SmartThings dongle and not the standalone hub. Could that be the issue?

This is what my Edit Device screen looks like for the shortcut button on the IDE website. I have a smartthings v3 hub, not sure if it makes a difference

Thank you @HardLuck for the quick response. I changed the Name to “Zigbee Button” instead of “ZigBee Button” and it now responds to button press. Note to all - this is case sensitive. Hold does not work, but button press does. I wish I bought the 5 button one, but this does the job.

1 Like

I just assumed it was make it something other than Thing.

I’m planning on using it as a simple on off button for lamps or to set scenes/modes. It’ll look nicer than the 5 button one on a side table.

That’s funny I thought it might be case sensitive so I spelled it ZigBee. When it didn’t work i didn’t think changing B -> b would make a difference !

Might have something to do with how smartthings looks at the device, if it’s the same name as a device type it might act differently. That’s the only real thing I can think of. I saw mine was still called thing so I changed it and didn’t look at the capitalization on ZigBee

Tnx, that works now, single press.

It works also with the V2 hub.

Tried to set/change the Hold time in the DTH to enable Hold. No result.

Damn. My son threw away my Samsung Button. I was hoping this would be a good alternative.

Anybody know how to reset the shortcut button ?