Ikea 5 button remote killing batteries

I have received two more of these today. I added them to the hub and I’m just letting them sit as cook. Test Button 1 had 60% battery at the time of adding it to the hub, Test Button 2 had 100% battery at time of adding. Let’s see how they do after a couple hours.

It should be some sort of the firmware issue that are recently pulled out.

I have tons of repeater in my bedroom, so that all of my devices have LQI 254~255. All of my devices including ikea buttons had been working fine over a year.

I experienced the battery drainage yesterday, so I change it with a new one, but after 1 day, it stopped working again

I hope the firmware gets fixed or rolled back.

2 Likes

Update: buttons were added at 3:08pm at 8:12pm

Button 1 is still reading 60%
Button 2 is now reading 87% yet it returns to 100% but after a couple button presses it goes to the 87%.

Let see how these do overnight.

Buttons survived the night, however they didn’t survive the day.

1 Like

Zigbee changed to 5.2.1 and yesterday all my ikea button batteries died together.

All replaced and lets see how long they last.

2 Likes

I have the same issue here.
How do you request a downgrade of your hub?All my tradfri that are completely useless now.

@foppert you can call 1-866-813-2404 for smartthings support

@Sleeping-Llama Did this work for you? If so what version of ZigBee/what firmware did you move to?

Having the same issue with killing the batteries and I’m on zigbee 5.3.0. I guess I need to report it up. Weirdly enough my 5 button ones seem to be ok, but the 2 new dimmer models I added a week ago have be men giving me issues since I got them

Same happening to me, this is my 3rd set of batteries for the 2 button dimmer!

And now that one has failed. I note that in the IDE it is now reporting a route through a Tradfri Outlet instead of a direct route but I draw no conclusions from that.

DTH is local execution?

No, the Ikea Button DTH is cloud execution. There have been similar issues with Ikea buttons and certain Zigbee stacks on a number of platforms which I understand is thought to be something to do with short and long polling but I guess the bottom line is the buttons aren’t sleeping for some reason.

It should be something like this, since don’t see excessive traffic in the log.
You tried to install the dth in the IDE simulator with a real button and run configure, refresh … to see what responses device sends?

No. I’ve never touched the simulator, ever. In fact I think you are the only person I’ve heard of ever using it.

Jajaja, I come from aviation, everything first to the simulator just in case … :rofl: :rofl:

1 Like

I’ve been having the battery draining issues on 3 different IKEA 5 button remotes for about 3 weeks now. Each lasts only about 24-48 hours before they are dead. I’ve called support and reported the error through the app. Anyone find a solution that has worked to resolve this yet?

1 Like

I think any solution will require Ikea’s firmware and ST’s Zigbee stack to start singing from the same hymn sheet. This is not a problem unique to ST and if anything ST seem to be encountering it later than most.

I’m beginning to get worried about IKEA’s kit.

They’ve been “idiosyncratic” from the beginning, which fits their general design philosophy. (Case in point: any of their plumbing fixtures. :scream:)

Blockquote
I’ve called support and reported the error through the app. Anyone find a solution that has worked to resolve this yet?

@Mike_Beckner What error do you get in the app?