Ikea button (dimmer) not working

Hello,

I have recently bought Ikea button(dimmer) and I have connected it to my Smartthings hub but any action that I had made for the button is not working. Also it shows that battery is on 0% so I changed the battery and still it wont work. When I press or hold the button nothing happen. Please does anyone knows how to fix this?

Here is a screen show of my device inside of new smartthings app


I do know that the Tradfri devices aren’t compatible with the v1 hub… are you using a v1?

No, im using v3. Also my ikea remote control with 5 button is not working as well. Same problem like the dimmer button

Are they showing the correct DTH in IDE when joined?

Did you buy buttons that came with bulbs? They come paired to the bulb and will have to be reset to work with the hub. But I don’t think you would have been able to even add them if that were the case. Just thinking out loud…

I checked and everything is fine. It had the right device handler. I really don’t have an idea why it won’t work

I thought about that too but then I trying another button that didn’t come with the bulb and still same problem

Okay I have find a solution and it simple.

I just paired IKEA button from an old SmartThings app and then I went to the new app to give buttons a task and everything worked just fine. Also I can see the battery status now.
This steps worked with IKEA 5 button remote control.

Hey Spaka,

I’m having the same issue with the (i assume, the same) new ikea dimmer that is square. Can you please be a little more specific with what “give buttons a task” means?

I’ve added from smartthings classic and used the new app to set the buttons to turn on virtual switches and physical switches, no luck for me.

@bgates, what version of the Hub do you have?
If you press the switch on or off or hold it, does it show up in the device history?

1 Like

My hub is V3. I’ve tried ON/OFF/HOLDing the buttons on the switch and it does not show up in the device history.

Ok, then you need to pair again. Start pairing from the new app, and press 6 times the button on the back until the red LED starts to breathe.

I’ve just tried re-pairing from the new app 3 times. Each time it’s paired without problems. But It appears unresponsive, meaning that no actions appear in history once i have assigned actions to the button pushes/holds.

Scratch that! One more re-pair and it worked. The only thing that I did differently was pair it further away from the hub than usual. Doubt this actually made any difference, but it worked this time round.

Many people does try to pair it close to the hub (literally on top of it), but that is not required. You should pair it where you want to use it, to make sure you have got there zigbee coverage.

Hi, I just started having issues with the Ikea Dimmer Button. I had 4 of them and pair all of them correctly. For the 3 of them, I am using it with the Ikea Wireless Curtain and I set the functions I want using the new App (set Press button 1 for function A and button 2 for function B). All is well.

Today, when I go into the button on the app, I no longer see the anything (it used to be able to see Top button on Standby/Pressed, and the history). It’s totally blank now. The function still works, but I can no longer assign a different functions as it is total blank screen now. I tried to repair one of them, it successfully paired but when I go into the tile, it is still blank. I’m not sure if there are any recent update but I am totally lost now.

Hi @keltong, I myself am facing this issue along with all other users of the Tradfri remotes/buttons, pleas see the below discussion for this exact issue:
Ikea Tradfri Button (square)

Yeah…thank you…I am following that thread now.