EcoSmart Zigbee Remote

@SamsungZell and @nayelyz

Marking this post as solved does not solve the problem

Sorry for not responding in timely manner, as I was busy with my work.
Here is the issue that is happening all over, and it can be found in a lot treads.
Many button devices (remotes, switches with button capabilities) are showing more capabilities than they have.

My examples are

  1. EcoSmart remote with only Pressed capability, shows Pressed, Double Pressed, and Held capabilities.
    It should be like this

But now with all added capabilities looks like this

Assigning Actions on device details pages is not working correctly, as I stated. When I assign action to the 1st Button’s Pressed capability, it does save it correctly

When I try to assign Actions on device’s details page to other buttons (2, 3, and 4), it shows them under button #1 in other button’s capabilities.

It is the same behavior described in another @Trakker2 users post

  1. Now when I checked another brand remote it that has 4 buttons with only Pressed and Held Capabilities, that one shows more then dozen (19) capabilities for each button.

@SamsungZell You are telling me to remove and re-add devices (which I have more than a dozen), and to loose all Automations doing that. I have removed only one , and added back, and added more, but they all behave the same.
3. I have looked at another Zooz Switch Scene Controller with 4 buttons, and they all have same problem, added all possible button 19 capabilities, as shown bellow, for just one button


Post from another tread by @blueyetisoftware list same problem

Only thing that comes to my mind that I might have this problem is that as I am testing Edge drivers, that I have driver with button capabilities loaded on my hub, that creates conflict with all other DTH Groovy devices.
Otherwise Smartthings have this problem all over, and it needs to fix this asap.

How many more users need to post about the exactly same problem, to be looked at?

2 Likes

It seems the same problem that the fibaro KeyFob has with the stock beta driver edge zwave button

@nayelyz @SamsungZell
Looks like the latest app update fixed the issue with multiple capabilities showing for button devices:


Also button’s actions are working correctly now.
They are showing at assigned button.

@nayelyz
Only me being picky, I would ask that current edge driver for zigbee remotes, to be updated to have buttons and battery in correct order, battery should be always on the bottom, as we talked some time ago.

It is possible as edge driver for Hue Remote, created by one of the devs, has everything in right order:

If Samsung developer needs to look at the code, here is the link to the Hue driver, where there is a link to the GitHub

2 Likes

My fibaro keyfob button still shows 22 actions for each of the 6 buttons instead of 5 for each of the 6 buttons

@Mariano_Colmenarejo Did you update the app to the latest version?

Yes, updated yerterday.
Driver Change performed and memory cache cleared

1 Like

The new app update had eliminated the long list of unusable button options for me.

4 Likes

Bumping this old thread…
I had been using the DTH for my ecosmart remote, which was showing as cloud executed.
I tried switching the driver to ‘Zigbee Button’ so that it would execute locally.
This “sort of worked”; the device still shows as having four buttons, but I can only get the first one to work. Pressing buttons 2-4 seems to have no effect.
Did this happen to anyone else?
(I’d also like to try the edge driver, but I’m not sure it’s enabled yet; see Hub Connected Devices Now Use Edge Drivers - #89 by jamclam)

I’ve been using this edge driver with the ecosmart remotes for a while now and it works great. It doesn’t support the group binding that this driver was developed to support but all the buttons work.

1 Like

@Terri_Baker as the group functionality doesn’t work for you, you may as well use the official Samsung ZigBee button edge driver that my driver is based upon

I couldn’t ever get it to work correctly.

I’m still playing with group options in your driver, just haven’t had time recently

1 Like

I’m not sure they work for your remote, I don’t have one to test myself, and another user reported they don’t work

Figured I’d put this here…

So, I’ve been playing catch-up, realizing my Ecosmart remotes will soon need an alternative to webcore.

So, for now, I just took out the device specific (fingerprint) info from the custom DTH I’ve been using, so I can still use that handler without Smartthings defaulting to it upon pairing. This allowed me to have the Edge driver option for testing one remote while keeping my existing remotes on the custom DTH, for now. Maybe no one else would have that problem, anyway, but…

I know the official Edge Zigbee button driver has the Ecosmart remote fingerprint and that is apparently the only that does, but being that buttons 2 and 3 support “held”, I’m curious how they may be made workable with the Edge driver.

I’ve not got to the point of understanding how to use/edit custom edge drivers, but am working on it.

WOW! Thanks @milandjurovic71
I got the EcoSmart 4 button remote to work.

I deleted the device from the app
I clicked the large “+” and selected “Add a device”
I chose “Select from list of devices” and selected “SmartThings”
Then I selected Remote/Button
It showed a screen the single SmartThings button and I clicked “Start”
I used a straight pin to push the reset pin thru the hole in the battery cover

It added the device defaulting the name to EcoSmart Remote Control.
I clicked the device tile/icon to get to the settings:
There are five groups - Main, Button1, Button2, Button3, Button4
I did not assign any action to Main
I set up the other four actions and backed out of the setup.

They all work perfectly!!
I did the same with my other remote as well.

The “Driver” screen shows it as Zigbee Button with SmartThings as the developer.
The Groovy IDE shows the Type as placeholder like the Edge driver devices.

7 Likes

I love these remotes. I have 5 of them, got them for like $4 a piece + bulb, unreal deal back in the day. Hope nothing changes with their functionality with the groovy changes.

Sorry to revive this, but I cannot pair neither the bulb nor the remote to my hub to save my life.
I unpaired the two using EcoSmart method. The bulb now flashes RGB 3 times when it’s turned on, and then goes into solid white. I tried flicking the switch off and on 6 times (1 sec interval), same behavior. The remote, I am holding next to my hub, pressing the button, it flashes red for a few seconds, then stays solid red for a few more seconds, and then the light stops.

I tried using both “Search Nearby” options and Third Party partner, EcoBee.

Any ideas, or am I just missing something?

Thanks!

These are EcoSmart and not EcoBee. I have the Zigbee Button Groups driver installed from Lrmulli.

Zigbee Button + Groups - Alpha Test - Devices & Integrations / Community Created Device Types - SmartThings Community

1 Like

I definitely meant EcoSmart, not sure why I typed Ecobee. Long day. I’ll try those and see what happens.

Thanks.

2 Likes

Did you get it working?

Mine are just using the stock Zigbee Button driver for the remote and stock Zigbee Switch driver for the bulb.

Did not. I could not get either device to show up when I searched for them in Smartthings app.