EcoSmart Zigbee Remote

I know trying to explain it sounds kinda convoluted, but yep, I think that is accurate.

haha, as long as the remote and bulb are both paired directly to the smartthings hub and not to each other all should be good. =]

Anyone have a handler that displays “held” for for buttons two and three in automations. webCoRE has been more snappy than usual, but looks like I can recreate the pistons with automations now.

Sorry to resurrect the thread, but thought I’d ask before I go hacking at the DTH.

If i remember correctly, at one point there was work in progress version with Held on buttons 2 and 3, but it didn’t make it to official version. Maybe one of links in this post have old version

1 Like

I have one that worked with the old app or maybe it worked with Smart Lighting, modified by @BertABCD1234, but was hoping to have the “held” options appear in the new automations.

I think the main concern with not including the “held” in the official DTH was the “Button 4” behavior.

I can probably figure it out, but didn’t want tax my brain too much, if someone had already created one.

Can the ecosmart bulb be paired with ST hub and the remote be touch linked to the bulb?

My goal is to control lights through automations but also retain functions of the remote WITHOUT using custom DTH.
Thanks

Yes it can be connected to both. You have to unpair remote from lights, prior to pairing with ST hub, and then pair TouchLink again.

Will it work with SmartThings?
Yes, but…

TouchLink will take over all zigbee ecosmart light bulbs, as they will group together.

I have many remotes and almost all of my regular lights are tunable ecosmart bulbs. I have tried connecting group of lights at the time, than another group, and conecting remotes and TouchLink, but fails every time.

Simply it does not work with SmartThings.

However i have remotes connected only to SmartThings and I am not using Touch Link. They work fine. Plus you can use this remotes for ofher functions.

Using ABC Manager, you can regain all Remotes’ functions, almost as factory, but it will not be the same. Hint: memmory button

I unpaired the remote and bulb, paired the bulb to ST (did not pair the remote), and paired the remote to the bulb with touch link. The bulb blinks as it should when touch linked with the remote but I am unable to control the light with the remote.

I guess I will add the remote into ST and use automations.

It worked for me, but remote started to control all other bulbs too, not just that one that is paired to.

1 Like

They have to all be on the same Zigbee network, so you have to pair the remote and the bulbs individually to the smartthings hub first.

Once they are all on the same network, then use touchlink to pair the remote to the bulbs.

Since you didn’t pair the remote to the hub, it’s going to try to set up a separate network, that’s why it didn’t work for you.

However, as others have noted, the eco-smart device is using a groupcast to control the bulbs and the bulbs are predefined to all be in group one, so when you control one you will be controlling all of them. Which is annoying, but it’s the way the manufacturer did it.

3 Likes

It seems the EcoSmart remote are not supported in new Smartthings app anymore. I am trying to add a EcoSmart remote, go to brand, select EcoSmart, it shows light only.

Anyone can confirm this? Thanks. BTW, I am in US.

I have this in my personal notes.

Push pin in hole in back of remote
Scan for nearby in app
Place remote very close to hub
May take up to 30 seconds

@Zach_Varberg Something happened with DTH for Ecosmart Remote, or with platform.
Device handler worked flawlessly since January 2020.

Suddenly device capabilities changed and some buttons become unresponsive. Also no fast automations can be assigned to any button besides button #1. When I tried to assign automations to other buttons, looks like nothing is happening (saving), however after an exit from device and return to device details, those Automations show up under button #1.
Also, Double pressed capability just showed up, and Held on the button #4.

Current non working device details page

Old Device automation assignments

Device handler was created by @BroderickCarlin. Who can look into this?

@Automated_House does your remote still working normally? Who should be contacted from SmartThings?

@nayelyz

The UI for multi button devices seems to break so frequently it’s hard to tell when things are actually working normally. I reported to support my Routine assignments not showing properly on my ikea 5 button several days ago. Looking at my ecosmart remote, it looks like it’s suffering from the same problem.

What do you mean unresponsive? The event for the buttons is sent directly by the DTH when the device reports a button was pushed.
I guess that as this is a custom DTH, you installed it in your IDE account, right?. You can enter the DTH and check the logs using the simulator.

About issues with the automation, is it only happening with the devices using this DTH or do you have another multi-button device that is using a stock DTH?

No it’s stock SmartThings DTH. All 4 buttons now showing additional Hold and Double Pressed capabilities. Use to be just pressed capability.
Responsivnes is back, it shows that button is pressed, but other issues are still there.

This screenshot is from device that i didn’t change anything, just loaded details page, and it still shows assigned automations.

Now, on new device i can’t assign automations to buttons 2, 3 and 4.

All my automations use to be assigned with Fast Automations from details page. Now, if I try to add Fast Automations to any other button besides button #1, they are jot appearing under thise buttons. They will show up under button number #1.

I have tried to assign them through Routines page, and that works. And only preesed action is available as use to be.


2 Likes

Ok, that’s caused by an issue that is already reported. It seems the supportedButtonValues property is ignored in the Detail View.

@SamsungZell, could you help us check the issue with the “fast automation” in the app described by @milandjurovic71, please?

Ok, you should use that for now so the device keeps working as it used to while the team checks this issue.

2 Likes

@nayelyz thank you for responding.

Can you maybe list a couple of current staff members, that we can work directly with for different issues.
For example for Edge driver issues, or for old Groovy issues, or Linked Services, or for devices supported by SmartThings. I have found that many times issues are solved much faster than calling support.

We are in direct communication with our internal staff to check on your issues, if you find there’s a delay in solving them, please notice that it may be due to the prioritization and current workload of our team as they are all constantly working to build more cool features for you. Please remember also, that you caught us in the middle of a holiday (Happy Thanksgiving!)
For development issues, you can contact me, @erickv, or @andresg or send an email to build@smartthings.com as well.
For ST app-related issues, you can tag @SamsungZell or send an email to the ST Customer Support of your region (Go to https://www.smartthings.com/ and click on “Support”)

We can guide you if you don’t know exactly what kind of issue you’re facing.

3 Likes

Hey there! @milandjurovic71, I’m sorry to hear that you’re having issues with the device tile and it displaying additional capabilities other than the desired ‘pressed’ to execute your Automation Routines.

Just to confirm your symptoms by ‘fast automations’, do you mean Automation Routines directly from the device tile>routines tab>+ that do not display correct capabilities on the device tile, adding the options for hold and double pressed?

I’ve been testing and I’m not having the symptom appear with the additional capabilities, which may mean I’m having trouble replicating the issue and we need to isolate it further. I was able to add the Automation routine from the device tile and the automation routine tab. See the below screenshot

Other than recommending removing and re-adding the device to see if functionality returns to normal, I’d say If you have not already, I’d recommend creating a support ticket so we can look into your symptom further.

You can reach out directly to a support team in your area using the below information:

US: 1-866-813-2404
US: support@smartthings.com
UK support 0333 0000333
UK: support@smartthings.co.uk
CA: support@smartthings.ca

I hope this message finds you well!

^SamsungZell